Announcement

Collapse

New version of forum

Hi,

As you can see, the forum has been updated.

We took advantage of this migration to change the theme of the forum and to reorganize sections.

These new sections allow better classify subjects discussed. The old topics have been classified in the "Archives" section of the forum and remains accessible.

We reclassified the recent topics (since the 1st of July) in the news sections. To find your topics, please use search menu. We will reclassify active topics from Archives section to the new ones frequently.

Enjoy reading and discussions
See more
See less

check_http et caractere pipe dans l'url

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • check_http et caractere pipe dans l'url

    Bonjour,

    Je doit superviser une url contenant un pipe (|) et je rencontre un petit soucis de graph.
    Le problème provient du fait que le pipe sert aussi de délimiteur pour les perfdatas, du coup, centreon me créé plein de courbes.

    J'utilise la commande suivante :
    check_http -L -H $ARG1$ -p $ARG2$ -u $ARG3$ -f critical -s $ARG4$ -t $ARG5$ -a $ARG6$
    Avec les arguments suivants :
    ARG1 = xx.xx.xx.xx
    ARG2 = 8080
    ARG3 = "/LOCAI\?TITI=TOTO\&id=test\|"
    ARG4 = "TEST"
    ARG5 = 10
    ARG6 = :

    L'argument 3 contient un pipe à la fin, il en résulte les perfdatas suivantes dans centreon :
    " target="_blank">HTTP OK: HTTP/1.0 200 OK - 290 bytes in 0.046 second response time |time=0.045755s;;;0.000000

    J'ai essayé de le protégé avec un \ devant comme pour les '&' mais cela ne change rien.
    Quelqu'un a-t-il déjà eu le problème ?

    Merci d'avance.

  • #2
    Salut,

    Si tu le remplaces par | ??
    C'est sa valeur numérique

    Comment

    Working...
    X