Announcement

Collapse

New version of forum

Hi,

As you can see, the forum has been updated.

We took advantage of this migration to change the theme of the forum and to reorganize sections.

These new sections allow better classify subjects discussed. The old topics have been classified in the "Archives" section of the forum and remains accessible.

We reclassified the recent topics (since the 1st of July) in the news sections. To find your topics, please use search menu. We will reclassify active topics from Archives section to the new ones frequently.

Enjoy reading and discussions
See more
See less

Problems with clapi as part of CES Standard VM

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problems with clapi as part of CES Standard VM

    I'm looking to move to the recently released CES Standard 2.0. When I upgraded my last system I used the clapi to recreated my contacts, hosts, etc.

    I'm having trouble with the new clapi. It doesn't seem to support some of the newer features. For example, I can create a contact, but the following parameters do not work as shown in the wiki:

    /usr/share/centreon/www/modules/centreon-clapi/core/centreon -u admin -p mypassword -o contact -a setParam -v "Systems_Engineer;enable_notifications;1"
    Unknown parameter type.

    "comment" also doesn't work as shown in the wiki. The rest of them seem to work, at least the ones I use.

    Another problem. Contacts that I create with the clapi or not selectable when I go to Contact Groups and want to add the contact as a Linked Contact. If I manually create a Contact, making the same selections, then it shows up ok.

    I looked to see if I could download a new version of the clapi and I'm not able to find one. My version is:
    # ./centreon -V
    Centreon API version 2.3.7 - Copyright Merethis - www.centreon.com
    This software comes with ABSOLUTELY NO WARRANTY. This is free software,
    and you are welcome to modify and redistribute it under the GPL license

    usage: ./centreon -u <LOGIN> -p <PASSWORD> -o <OBJECT> -a <ACTION> [-v]
    .....

    Anyone know if this is an existin g issue or if there are any workarounds?

    Thanks,
    James

  • #2
    Hi,

    The command than you've test is not available on your version. You need clapi 1.3.x

    This version is not yet on CES repository.

    For use these feature, you can install the new release from sources, or wait the 1.3.x in our repository.
    Open Source Monitoring Addict
    OS: Ubuntu / Debian / CentOS / RedHat / Solaris / Arch Linux / Open Suse


    ! NO SUPPORT IN PRIVATE MESSAGE !

    Comment


    • #3
      Anybody????

      Comment


      • #4
        Sorry for last reply. Thanks for response.

        Can I try the latest clapi from source or do I have to update everything?

        It looks like CES is updated, at least the enable notifications in in the configuration.

        Thanks,
        James

        Comment


        • #5
          Yes you can try an update from source.

          In CES you have not the lastest version. You can verify it with this command: rpm -qa | grep centreon-clapi

          You're CES is updated, yes but not centreon-clapi beacause is not in the repository.

          Thanks,
          Open Source Monitoring Addict
          OS: Ubuntu / Debian / CentOS / RedHat / Solaris / Arch Linux / Open Suse


          ! NO SUPPORT IN PRIVATE MESSAGE !

          Comment


          • #6
            Just to be clear, you are saying I need an OLDER version of the clapi?

            Thanks,
            James

            Comment


            • #7
              No I never said that.

              You have 2 possibilities:

              1) UPDATE from sources;
              2) DELETE the old release, and install the latest release from sources.

              Is it clear for you ?
              Open Source Monitoring Addict
              OS: Ubuntu / Debian / CentOS / RedHat / Solaris / Arch Linux / Open Suse


              ! NO SUPPORT IN PRIVATE MESSAGE !

              Comment


              • #8
                Let me step back. Here's what WAS not clear to me.

                I installed CES Standard 2.0, which has version 2.3.7 of clapi, when doing centreon -V. You said I need version 1.3.x.

                Even on my old server my clapi version is 2.1.12.

                I see now you are saying the rpm needs to be 1.3, where mine is 1.2-4.

                Sorry for my confusion. Plus I think our replies were crossing at about the same time which didn't help.

                I really appreciate your help. I'll try to get clapi updated.

                James

                Comment


                • #9
                  I was able to get it working. Thank you very much for you help and patience.

                  James

                  Comment


                  • #10
                    You're welcome. ;-)

                    Have fun with Centreon-CLAPI !
                    Open Source Monitoring Addict
                    OS: Ubuntu / Debian / CentOS / RedHat / Solaris / Arch Linux / Open Suse


                    ! NO SUPPORT IN PRIVATE MESSAGE !

                    Comment

                    Working...
                    X