Results 1 to 2 of 2

Thread: check_http et caractere pipe dans l'url

  1. #1
    Join Date
    Nov 2008
    Location
    Paris
    Posts
    32

    Default check_http et caractere pipe dans l'url

    Bonjour,

    Je doit superviser une url contenant un pipe (|) et je rencontre un petit soucis de graph.
    Le problème provient du fait que le pipe sert aussi de délimiteur pour les perfdatas, du coup, centreon me créé plein de courbes.

    J'utilise la commande suivante :
    check_http -L -H $ARG1$ -p $ARG2$ -u $ARG3$ -f critical -s $ARG4$ -t $ARG5$ -a $ARG6$
    Avec les arguments suivants :
    ARG1 = xx.xx.xx.xx
    ARG2 = 8080
    ARG3 = "/LOCAI\?TITI=TOTO\&id=test\|"
    ARG4 = "TEST"
    ARG5 = 10
    ARG6 = :

    L'argument 3 contient un pipe à la fin, il en résulte les perfdatas suivantes dans centreon :
    " target="_blank">HTTP OK: HTTP/1.0 200 OK - 290 bytes in 0.046 second response time |time=0.045755s;;;0.000000

    J'ai essayé de le protégé avec un \ devant comme pour les '&' mais cela ne change rien.
    Quelqu'un a-t-il déjà eu le problème ?

    Merci d'avance.

  2. #2
    Join Date
    Mar 2011
    Location
    France, Essonnes
    Posts
    70

    Default

    Salut,

    Si tu le remplaces par | ??
    C'est sa valeur numérique

Similar Threads

  1. Replies: 6
    Last Post: 11th August 2011, 09:32
  2. Replies: 0
    Last Post: 25th May 2009, 00:07
  3. Caractere spécial dans un parametre Centreon
    By grigribou in forum Plugins
    Replies: 6
    Last Post: 21st October 2008, 11:39
  4. problème de caractère spéciaux dans interface
    By gregorybel in forum Interface
    Replies: 10
    Last Post: 7th February 2008, 12:37
  5. probleme check_http dans l interface oreon
    By arnaudmrs13 in forum Plugins
    Replies: 4
    Last Post: 31st August 2007, 11:07

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •