Results 1 to 10 of 10

Thread: Problems with clapi as part of CES Standard VM

  1. #1
    Join Date
    May 2009
    Posts
    62

    Default Problems with clapi as part of CES Standard VM

    I'm looking to move to the recently released CES Standard 2.0. When I upgraded my last system I used the clapi to recreated my contacts, hosts, etc.

    I'm having trouble with the new clapi. It doesn't seem to support some of the newer features. For example, I can create a contact, but the following parameters do not work as shown in the wiki:

    /usr/share/centreon/www/modules/centreon-clapi/core/centreon -u admin -p mypassword -o contact -a setParam -v "Systems_Engineer;enable_notifications;1"
    Unknown parameter type.

    "comment" also doesn't work as shown in the wiki. The rest of them seem to work, at least the ones I use.

    Another problem. Contacts that I create with the clapi or not selectable when I go to Contact Groups and want to add the contact as a Linked Contact. If I manually create a Contact, making the same selections, then it shows up ok.

    I looked to see if I could download a new version of the clapi and I'm not able to find one. My version is:
    # ./centreon -V
    Centreon API version 2.3.7 - Copyright Merethis - www.centreon.com
    This software comes with ABSOLUTELY NO WARRANTY. This is free software,
    and you are welcome to modify and redistribute it under the GPL license

    usage: ./centreon -u <LOGIN> -p <PASSWORD> -o <OBJECT> -a <ACTION> [-v]
    .....

    Anyone know if this is an existin g issue or if there are any workarounds?

    Thanks,
    James

  2. #2
    Join Date
    Sep 2010
    Location
    Paris
    Posts
    808

    Default

    Hi,

    The command than you've test is not available on your version. You need clapi 1.3.x

    This version is not yet on CES repository.

    For use these feature, you can install the new release from sources, or wait the 1.3.x in our repository.
    Open Source Monitoring Addict
    OS: Ubuntu / Debian / CentOS / RedHat / Solaris / Arch Linux / Open Suse


    ! NO SUPPORT IN PRIVATE MESSAGE !


  3. #3
    Join Date
    May 2009
    Posts
    62

    Default

    Anybody????

  4. #4
    Join Date
    May 2009
    Posts
    62

    Default

    Sorry for last reply. Thanks for response.

    Can I try the latest clapi from source or do I have to update everything?

    It looks like CES is updated, at least the enable notifications in in the configuration.

    Thanks,
    James

  5. #5
    Join Date
    Sep 2010
    Location
    Paris
    Posts
    808

    Default

    Yes you can try an update from source.

    In CES you have not the lastest version. You can verify it with this command: rpm -qa | grep centreon-clapi

    You're CES is updated, yes but not centreon-clapi beacause is not in the repository.

    Thanks,
    Open Source Monitoring Addict
    OS: Ubuntu / Debian / CentOS / RedHat / Solaris / Arch Linux / Open Suse


    ! NO SUPPORT IN PRIVATE MESSAGE !


  6. #6
    Join Date
    May 2009
    Posts
    62

    Default

    Just to be clear, you are saying I need an OLDER version of the clapi?

    Thanks,
    James

  7. #7
    Join Date
    Sep 2010
    Location
    Paris
    Posts
    808

    Default

    No I never said that.

    You have 2 possibilities:

    1) UPDATE from sources;
    2) DELETE the old release, and install the latest release from sources.

    Is it clear for you ?
    Open Source Monitoring Addict
    OS: Ubuntu / Debian / CentOS / RedHat / Solaris / Arch Linux / Open Suse


    ! NO SUPPORT IN PRIVATE MESSAGE !


  8. #8
    Join Date
    May 2009
    Posts
    62

    Default

    Let me step back. Here's what WAS not clear to me.

    I installed CES Standard 2.0, which has version 2.3.7 of clapi, when doing centreon -V. You said I need version 1.3.x.

    Even on my old server my clapi version is 2.1.12.

    I see now you are saying the rpm needs to be 1.3, where mine is 1.2-4.

    Sorry for my confusion. Plus I think our replies were crossing at about the same time which didn't help.

    I really appreciate your help. I'll try to get clapi updated.

    James

  9. #9
    Join Date
    May 2009
    Posts
    62

    Default

    I was able to get it working. Thank you very much for you help and patience.

    James

  10. #10
    Join Date
    Sep 2010
    Location
    Paris
    Posts
    808

    Default

    You're welcome.

    Have fun with Centreon-CLAPI !
    Open Source Monitoring Addict
    OS: Ubuntu / Debian / CentOS / RedHat / Solaris / Arch Linux / Open Suse


    ! NO SUPPORT IN PRIVATE MESSAGE !


Similar Threads

  1. Replies: 1
    Last Post: 26th March 2012, 17:31
  2. SNMP trap MIB standard
    By lucif in forum Setup
    Replies: 1
    Last Post: 28th October 2011, 17:38
  3. Clapi 1.2
    By Ader in forum Suggestions for Modules
    Replies: 1
    Last Post: 19th October 2011, 13:10
  4. Replies: 0
    Last Post: 8th July 2011, 14:14
  5. Paramétrage standard de la RC6 sur le debug
    By naparuba in forum Centreon devel version
    Replies: 1
    Last Post: 22nd October 2008, 15:27

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •