Announcement

Collapse
No announcement yet.

Red central icon - Yellow collector

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Red central icon - Yellow collector

    English version below


    Bonjour,

    Après avoir modifié l'adresse ip (DHCP réservé - Windows Server 2012 r2) d'un serveur Centreon (de test), je me retrouve avec des icones rouges :
    • Central not running
    • Certains collecteurs ne mettent pas à jour la base de données.
    Le collecteur s'est coloré de jaune et n'accepte plus de modifications depuis l'heure du changement d'IP.

    J'ai un centreon 2.8.17 installé à partir d'un Centreon ISO.
    Voici une tentative de déboguage :
    Code:
    tail -f /var/log/centreon-broker/central-module-master.log
    error:   TCP: could not connect to localhost:5669: Host unreachable
    Code:
    tail -f /var/log/centreon-broker/central-broker-master.log
    error :  TCP: could not connect to localhost:5670: Host unreachable
    Code:
    netstat -an | grep ^tcp | grep 5669
    tcp        0      0 0.0.0.0:5669                0.0.0.0:*                   LISTEN
    Code:
    netstat -an | grep ^tcp | grep 5670
    tcp        0      0 0.0.0.0:5670                0.0.0.0:*                   LISTEN
    Code:
    sudo tcpdump -i lo tcp dst port 5669
    tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
    listening on lo, link-type EN10MB (Ethernet), capture size 65535 bytes
    ^C
    0 packets captured
    0 packets received by filter
    0 packets dropped by kernel
    Je pense que les fichiers de conf sont correctes puisqu'identiques à un serveur Centreon en prod.
    J'avoue ne pas savoir où chercher. Si quelqu'un avait une idée

    -------------------------------------------------------------

    Hello,
    After having modified the IP address (DHCP reserved - Windows Server 2012 r2) of a Centreon server (of test), I got two red icons:
    - Central not running
    - Some collectors do not update the database.
    The collector is colored yellow and no longer accepts changes since the IP change time. I have a 2.8.17 center installed from an ISO Centreon.
    Here is an attempt to debug:
    Code:
    tail -f /var/log/centreon-broker/central-module-master.log
    error:   TCP: could not connect to localhost:5669: Host unreachable
    Code:
    tail -f /var/log/centreon-broker/central-broker-master.log
    error :  TCP: could not connect to localhost:5670: Host unreachable
    Code:
    netstat -an | grep ^tcp | grep 5669
    tcp        0      0 0.0.0.0:5669                0.0.0.0:*                   LISTEN
    Code:
    netstat -an | grep ^tcp | grep 5670
    tcp        0      0 0.0.0.0:5670                0.0.0.0:*                   LISTEN
    Code:
    sudo tcpdump -i lo tcp dst port 5669
    tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
    listening on lo, link-type EN10MB (Ethernet), capture size 65535 bytes
    ^C
    0 packets captured
    0 packets received by filter
    0 packets dropped by kernel
    I think the conf files are correct because they are identical to a Centreon server in prod.
    I confess I do not know where to look. If anyone had an idea
    Last edited by booga; 1st February 2018, 14:44.

  • #2
    Bonjour,
    Ton serveur Central de test a -t-il plusieurs pollers ? Normalement, pour le central en mode standalone il ne devrait pas avoir d'impact. Par contre pour les pollers distants, il faut modifier la configuration du broker au niveau de chaque poller pour modifier l'adresse IP du central comme ci-dessous :
    conf_broker.jpg
    Visiter mon site perso http://eric.coquard.free.fr/atelier/

    Comment


    • #3
      Merci pour cette réponse.
      Le central de test est en mode standalone. C'est d'autant plus étonnant.

      Comment


      • #4
        Ok, essaie de mettre 127.0.0.1 au lieu de localhost dans la configuration Broker, Output du central-module-master. J'ai déjà eu ça avec une machine CentOS. redémarre centengine et vérifie la connexion TCP 5669
        Visiter mon site perso http://eric.coquard.free.fr/atelier/

        Comment


        • #5
          On progresse (un tout petit peu) sur le netstat :
          Code:
          netstat -an | grep ^tcp | grep 5669
          tcp        0      0 0.0.0.0:5669                0.0.0.0:*                   LISTEN      
          tcp        0      1 x.x.x.x:56204          y.y.y.y:5669           SYN_SENT
          Mais toujours rien sur le tcpdump :
          Code:
          sudo tcpdump -i lo tcp dst port 5669
          tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
          listening on lo, link-type EN10MB (Ethernet), capture size 65535 bytes
          ^C
          0 packets captured
          0 packets received by filter
          0 packets dropped by kernel
          Last edited by booga; 5th February 2018, 12:15.

          Comment


          • #6
            Oui mais ce n'est pas glop, SYN_SENT indique que le socket attend une connexion. Ce qui me gêne, je ne l'avais pas vu avant, c'est la ligne
            tcp 0 0 0.0.0.0:5669 0.0.0.0:* LISTEN
            Il doit avoir un problème dans ta config réseau car tu devrais avoir ceci, il me semble
            tcp 0 0 *:5669 *:* LISTEN
            Visiter mon site perso http://eric.coquard.free.fr/atelier/

            Comment


            • #7
              Ok je vais chercher du côté réseau. Pourtant la config a l'air propre.
              Peux-tu m'expliquer la différence entre :
              Code:
              tcp 0 0 0.0.0.0:5669 0.0.0.0:* LISTEN
              et
              Code:
              tcp 0 0 *:5669 *:* LISTEN
              Merci pour ton aide

              Comment


              • #8
                Je n'arrive pas à avoir la même config. Peux-tu essayer cette commande
                netstat -i
                cela permet de voir les interfaces réseaux qui acceptent les flux comme ceci
                Table d'interfaces noyau
                Iface MTU Met RX-OK RX-ERR RX-DRP RX-OVR TX-OK TX-ERR TX-DRP TX-OVR Flg
                eth0 1500 0 5680 0 0 0 4753 0 0 0 BMRU
                lo 65536 0 5187 0 0 0 5187 0 0 0 LRU
                lo étant la boucle locale 127.0.0.1 ou localhost
                Visiter mon site perso http://eric.coquard.free.fr/atelier/

                Comment


                • #9
                  Je précise que c'est une VM (vmware) dupliquée à partir d'une VM en prod. Mais bon jusqu'à présent, y'a pas eu de souci.
                  Voici le résultat :

                  Code:
                  Table d'interfaces noyau
                  Iface       MTU Met    RX-OK RX-ERR RX-DRP RX-OVR    TX-OK TX-ERR TX-DRP TX-OVR Flg
                  eth0       1500   0 42001281      0      0      0 28335213      0      0      0 BMRU
                  lo        65536   0  1923194      0      0      0  1923194      0      0      0 LRU
                  Bon...y'aurais peut-être un problème au niveau du vsphere. Il n'affiche ni nom DNS, ni IP.
                  Je vais essayer de creuser de ce côté.
                  Last edited by booga; 6th February 2018, 10:55.

                  Comment


                  • #10
                    J'avoue que je coince, je n'arrive pas à recréer ton problème mais je sais que je l'ai eu une fois lors de mes manips. Pour contourner le pb, essaie d'ajouter l'adresse IP du central au lieu de localhost dans la configuration Broker, Output du central-module-master.
                    poller-tcpip.jpg
                    Ensuite arrête le poller
                    service centengine stop
                    redémarre le broker
                    service cbd restart
                    Démarre le poller
                    service centengine start
                    et vérifie la connexion
                    Visiter mon site perso http://eric.coquard.free.fr/atelier/

                    Comment


                    • #11
                      Merci pour toutes ces informations.
                      Je reviendrai ici quand j'aurai trouvé la solution


                      Last edited by booga; 6th February 2018, 15:35. Reason: La modification de l'IP ne change rien.

                      Comment


                      • #12
                        Pour conclure :il s'agissait d'un problème avec les VM-tools.
                        Nous les avons réinstallé et tout est au vert sur Centreon.

                        Un grand merci pour ton aide.

                        Comment


                        • #13
                          OK, merci pour le retour
                          Visiter mon site perso http://eric.coquard.free.fr/atelier/

                          Comment

                          Working...
                          X