Announcement

Collapse
No announcement yet.

Host/Service check command execution failed:pipe creation failed:Too many open files

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Host/Service check command execution failed:pipe creation failed:Too many open files

    Hello,

    I was checking the CentreonEngine log file (centengine.log) and found the errors below.

    They occur quite frequently:

    tail -f /var/log/centreon-engine/centengine.log
    ...
    [1519252467] [4794] Error: Service check command execution failed: pipe creation failed: Too many open files
    [1519252467] [4794] Error: Service check command execution failed: pipe creation failed: Too many open files
    [1519252467] [4794] Error: Service check command execution failed: pipe creation failed: Too many open files
    [1519252467] [4794] Error: Service check command execution failed: pipe creation failed: Too many open files
    [1519252467] [4794] Error: Service check command execution failed: pipe creation failed: Too many open files
    [1519252467] [4794] Error: Service check command execution failed: pipe creation failed: Too many open files
    [1519252467] [4794] Error: Service check command execution failed: pipe creation failed: Too many open files
    [1519252467] [4794] Error: Host check command execution failed: pipe creation failed: Too many open files
    [1519252467] [4794] Error: Host check command execution failed: pipe creation failed: Too many open files
    [1519252467] [4794] Error: Host check command execution failed: pipe creation failed: Too many open files
    [1519252467] [4794] Error: Host check command execution failed: pipe creation failed: Too many open files
    ...

    I have already configured Linux kernel parameters:
    --------------------------------------------------------------------
    [root@srvl-33 ~]# cat /etc/sysctl.conf
    fs.file-max = 10485760
    fs.nr_open = 10485760
    [root@srvl-33 ~]#

    I already configured the PAM:
    ----------------------------------------
    [root@srvl-33 ~]# cat /etc/pam.d/login
    #%PAM-1.0
    auth [user_unknown=ignore success=ok ignore=ignore default=bad] pam_securetty.so
    auth substack system-auth
    auth include postlogin
    account required pam_nologin.so
    account include system-auth
    password include system-auth
    # pam_selinux.so close should be the first session rule
    session required pam_selinux.so close
    session required pam_loginuid.so
    session optional pam_console.so
    # pam_selinux.so open should only be followed by sessions to be executed in the user context
    session required pam_selinux.so open
    session required pam_namespace.so
    session optional pam_keyinit.so force revoke
    session include system-auth
    session include postlogin
    -session optional pam_ck_connector.so
    session required /lib/security/pam_limits.so
    session required pam_limits.so
    [root@srvl-33 ~]#

    I already configured the limits.conf
    ----------------------------------------------
    [root@srvl-33 ~]# cat /etc/security/limits.conf
    # /etc/security/limits.conf

    root soft nproc 524288
    root hard nproc 524288
    root soft nofile 1046576
    root hard nofile 1046576
    root soft stack 10240

    mysql soft nproc 524288
    mysql hard nproc 524288
    mysql soft nofile 1046576
    mysql hard nofile 1046576
    mysql soft stack 10240

    oracle soft nproc 524288
    oracle hard nproc 524288
    oracle soft nofile 1046576
    oracle hard nofile 1046576
    oracle soft stack 10240

    apache soft nproc 524288
    apache hard nproc 524288
    apache soft nofile 1046576
    apache hard nofile 1046576
    apache soft stack 10240

    centreon soft nproc 524288
    centreon hard nproc 524288
    centreon soft nofile 1046576
    centreon hard nofile 1046576
    centreon soft stack 10240

    nagios soft nproc 524288
    nagios hard nproc 524288
    nagios soft nofile 1046576
    nagios hard nofile 1046576
    nagios soft stack 10240

    centreon-engine soft nproc 524288
    centreon-engine hard nproc 524288
    centreon-engine soft nofile 1046576
    centreon-engine hard nofile 1046576
    centreon-engine soft stack 10240

    centreon-broker soft nproc 524288
    centreon-broker hard nproc 524288
    centreon-broker soft nofile 1046576
    centreon-broker hard nofile 1046576
    centreon-broker soft stack 10240
    You have mail in /var/spool/mail/root
    [root@srvl-33 ~]#

    But even using with these settings, the error messages in the "centengine.log" log file persist.

    Does anyone know what it can be?

    Thank you

  • #2
    Hello

    Anybody know?

    Any return?

    Comment

    Working...
    X