Announcement

Collapse
No announcement yet.

[Help] - Can't get a working service with SNMP Traps

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Help] - Can't get a working service with SNMP Traps

    Hi Everyone,
    First of all, sorry for many things : i'm new to CentOS, Centreon, Monitoring... and so other many things


    I recently intalled and configured a Centreon with hosts and active services, and everything is working fine.

    I would like also to monitore passively a NetApp disk Array.
    So I imported at first the NetApp MIB in Centreon
    Then, after creating my host, i created a service "Trap" and i check the "passive check" box
    And finally I get back to "snmp traps" and Generate the trap database

    And now when I force my NetApp to send a traptest, nothing happens

    I tried to follow as close as I could the documentation about traps but I probably did somehting wrong, or missed something.

    I would appreciate if someone can help me (I can try to explain it better, even French speaking)
    Thx everyone

  • #2
    Hey there ! IU don't give up !!!
    I made a TCPdump on my Centreon and i send a "test message" with snmp traps from my remote host I want to manage, the result is my Centreon is receiving correctly this trap.
    So the "only cause" of this non-working service is wrong parameters in this passive service / mib import etc... nothing with networking

    Comment


    • #3
      Bonjour,

      Quite the same problem here and now… I'm trying to setup SNMP traps. I can see the trap is received on my poller, then processed by centreontrapdforward (the file doesn’t stay in /var/spool/centreontrapd/…) but the associated service doesn’t change its status. I’ve tried different settings but cannot manage to make it work.

      Did you managed to get it working yourself ?

      Comment


      • #4
        Answer to myself. It’s working now. I think I spotted a bug : if the linked passive service has non-ASCII characters in its name it doesn’t work. centreontrapd doesn’t find the service if it has non-ASCII characters in its name.

        Code:
        # rpm -qa |grep centreon
        centreon-perl-libs-2.7.13-1.el6.noarch
        centreon-broker-storage-2.11.8-2.el6.x86_64
        centreon-broker-cbd-2.11.8-2.el6.x86_64
        centreon-engine-daemon-1.5.3-1.el6.x86_64
        centreon-connector-ssh-1.1.2-1.el6.x86_64
        centreon-trap-2.7.13-1.el6.noarch
        centreon-engine-1.5.3-1.el6.x86_64
        centreon-connector-perl-1.1.2-1.el6.x86_64
        centreon-broker-core-2.11.8-2.el6.x86_64
        centreon-broker-cbmod-2.11.8-2.el6.x86_64
        centreon-engine-extcommands-1.5.3-1.el6.x86_64
        centreon-connector-1.1.2-1.el6.x86_64
        centreon-clib-1.4.2-1.el6.x86_64
        centreon-plugins-2.7.13-1.el6.noarch
        centreon-common-2.7.13-1.el6.noarch
        centreon-broker-2.11.8-2.el6.x86_64
        centreon-poller-centreon-engine-2.7.13-1.el6.noarch

        Comment

        Working...
        X