Announcement

Collapse
No announcement yet.

Import problem for mib SNMPv2-SMI.mib

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Import problem for mib SNMPv2-SMI.mib

    Hello,

    Using Centreon 2.1 I need to import many SNMP MIBs refering to the original SNMPv2-SMI MIB...

    This mib define the "iso=1" initial element of an OID but Centreon detects a bad parsing in the file syntax...

    It's impossible to import this mib and all mibs inheriting...

    ***** Processing MIB file *****

    snmptranslate version: NET-SNMP version: 5.3.2.2
    severity: Normal

    File to load is: /tmp/SNMPv2-SMI.mib
    File to APPEND TO: /tmp/SNMPv2-SMI.mib.conf

    MIBS environment var: /tmp/SNMPv2-SMI.mib
    mib name: SNMPv2-SMI

    Processing MIB: SNMPv2-SMI
    #
    Line: 315
    NOTIFICATION-TYPE:
    Enterprise:
    Looking up via snmptranslate: SNMPv2-SMI::
    No log handling enabled - turning on stderr logging
    Attempt to define a root oid (iso): At line 9 in /tmp/SNMPv2-SMI.mib
    Bad parse of OBJECT IDENTIFIER: At line 9 in /tmp/SNMPv2-SMI.mib
    Unknown object identifier: SNMPv2-SMI::
    OID:

    Done

    Total translations: 1
    Successful translations: 0
    Failed translations: 1

    Moving traps in DataBase...

    Generate Traps configuration files from Nagios configuration form!

  • #2
    hello,
    i think i have the same problem today..
    do you know the dolution?
    snmptranslate version: NET-SNMP version: 5.3.2.2
    severity: Normal

    File to load is: /tmp/SNMPv2-SMI.mib
    File to APPEND TO: /tmp/SNMPv2-SMI.mib.conf

    MIBS environment var: /tmp/SNMPv2-SMI.mib
    mib name: SNMPv2-SMI


    Processing MIB: SNMPv2-SMI
    #
    Line: 301
    NOTIFICATION-TYPE:
    Enterprise:
    Looking up via snmptranslate: SNMPv2-SMI::
    Unknown object identifier: SNMPv2-SMI::
    OID:


    Done

    Total translations: 1
    Successful translations: 0
    Failed translations: 1

    Moving traps in DataBase...

    Generate Traps configuration files from Nagios configuration form!

    Comment


    • #3
      Gravedigger here! I have the same problem as centrave above. Same issue here:
      https://forum.centreon.com/forum/cen...b-constructeur

      Did you find a solution?

      Comment

      Working...
      X