Announcement

Collapse
No announcement yet.

[BDD - VIDE] Perfparse ne remonte pas d'info

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [BDD - VIDE] Perfparse ne remonte pas d'info

    Donc toutes mes installation ce sont bien dérouler, et j'arrive au moment crucial de faire remonter les infos de nagios dans la base de données Perfparse, mais rien ne remonte.

    J'ai suivi une procédure trés détaillé fournis par quelqu'un du forum pour installer l'ensemble nagios, perfparse, oreon sur fedora6.

    Aucune remonter ne ce fesais, et aucun fichier de sorti n'était généré.

    J'ai donc utiliser la méthode :

    http://forum.oreon-project.org/showt...arse-import.sh

    Et la toujours rien ne remonte

    Manuellement :
    cat /usr/local/nagios/perfparse-service-perfdata.dat | /usr/local/nagios/bin/perfparse-log2mysql -c /usr/local/nagios/etc/perfparse.cfg -r

    Me donne le tableau joint en image.

    Mes fichiers perfparse-service-perfdata et perfparse-host-perfdata ce remplissent bien et possedent bien des \t entre chaque valeurs

    J'ai vu que beaucoup avais des probleme plus ou moin similairen, mais aucune solution proposer dans les autres poste ne m'ont permis d'avancer.

    J'espere que quelqu'un a une solution lol Merci d'avance.
    Attached Files

  • #2
    Originally posted by FoX View Post
    Donc toutes mes installation ce sont bien dérouler, et j'arrive au moment crucial de faire remonter les infos de nagios dans la base de données Perfparse, mais rien ne remonte.

    J'ai suivi une procédure trés détaillé fournis par quelqu'un du forum pour installer l'ensemble nagios, perfparse, oreon sur fedora6.

    Aucune remonter ne ce fesais, et aucun fichier de sorti n'était généré.

    J'ai donc utiliser la méthode :

    http://forum.oreon-project.org/showt...arse-import.sh

    Et la toujours rien ne remonte

    Manuellement :
    cat /usr/local/nagios/perfparse-service-perfdata.dat | /usr/local/nagios/bin/perfparse-log2mysql -c /usr/local/nagios/etc/perfparse.cfg -r

    Me donne le tableau joint en image.

    Mes fichiers perfparse-service-perfdata et perfparse-host-perfdata ce remplissent bien et possedent bien des \t entre chaque valeurs

    J'ai vu que beaucoup avais des probleme plus ou moin similairen, mais aucune solution proposer dans les autres poste ne m'ont permis d'avancer.

    J'espere que quelqu'un a une solution lol Merci d'avance.
    Que contient ton fichier /usr/local/nagios/etc/perfparse.cfg ?
    Raphaël 'SurcouF' Bordet
    Je ne teste pas mes plugins en root, tu ne testes pas tes plugins en root...
    Dons Paypal

    Comment


    • #3
      Merci pour ton aide surcouf mon fichier perfparse.cfg contient ceci :
      Code:
      Server_Port = "1976"
      Service_Log = "-"
      Service_Log_Position_Mark_Path = "/usr/local/nagios/var/serviceperf.log"
      Error_Log = "perfparse.log"
      Error_Log_Rotate = "Yes"
      Error_Log_Keep_N_Days = "7"
      Drop_File = "/tmp/perfparse.drop"
      Drop_File_Rotate = "Yes"
      Drop_File_Keep_N_Days = "7"
      Lock_File = "/var/lock/perfparse.lock"
      Show_Status_Bar = "Yes"
      Do_Report = "Yes"
      Default_user_permissions_Policy = "rw"
      Default_user_permissions_Host_groups = "rw"
      Default_user_permissions_Summary = "rw"
      Output_Log_File = "No"
      Output_Log_Filename = "/var/log/perfparse_output_log"
      Output_Log_Rotate = "Yes"
      Output_Log_Keep_N_Days = "7"
      Use_Storage_Socket_Output = "No"
      Storage_Socket_Output_Host_Name = "localhost"
      Storage_Socket_Output_Port = "1974"
      Use_Storage_Mysql = "Yes"
      No_Raw_Data = "Yes"
      No_Bin_Data = "No"
      DB_User = "nagios"
      DB_Pass = "MotDePass"
      DB_Host = "localhost"
      Dummy_Hostname = "dummy"
      Storage_Modules_Load = "mysql"

      Voci également un extrait de mon fichier perfparse-service-perfdata.dat :
      Code:
      1170252895      Imprimante      Check_Alive     PING OK -  Paquets perdus = 0%, RTA = 12.52 ms  OK
      1170252914      Passerelle      Check_Alive     PING OK -  Paquets perdus = 0%, RTA = 4.89 ms   OK
      1170252934      SV-Nagios       Check_Alive     PING OK -  Paquets perdus = 0%, RTA = 0.22 ms   OK
      1170252955      VM-Ubuntu       Check_Alive     CRITIQUE - Hte injoignable (192.168.0.59)       CRITICAL
      Voili voilou, encore merci

      Comment


      • #4
        Originally posted by FoX View Post
        Merci pour ton aide surcouf

        ...

        Voci également un extrait de mon fichier perfparse-service-perfdata.dat :
        Code:
        1170252895      Imprimante      Check_Alive     PING OK -  Paquets perdus = 0%, RTA = 12.52 ms  OK
        1170252914      Passerelle      Check_Alive     PING OK -  Paquets perdus = 0%, RTA = 4.89 ms   OK
        1170252934      SV-Nagios       Check_Alive     PING OK -  Paquets perdus = 0%, RTA = 0.22 ms   OK
        1170252955      VM-Ubuntu       Check_Alive     CRITIQUE - Hte injoignable (192.168.0.59)       CRITICAL
        Effectivement, c'est plutôt normal qu'aucune données de performance ne soit remontée dans la base de données de perfparse car... tu n'en as aucune !
        Soit les plugins utilisés ne sont pas compatibles avec perfdata, soit ils ne génèrent pas de données de performance (perfdata) parce que l'option n'est pas activée, soit tu ne fournis pas la macro $SERVICEPERFDATA$ à la commande ou au modèle perfdata défini pour Nagios.
        Raphaël 'SurcouF' Bordet
        Je ne teste pas mes plugins en root, tu ne testes pas tes plugins en root...
        Dons Paypal

        Comment


        • #5
          Arf

          Je suis un NooB désolé ^^ je pensais que le ping été l'information qui allé remonter

          ==>Soit les plugins utilisés ne sont pas compatibles avec perfdata :
          Les plugins nagios ? j'ai installer ceux sur le site de nagios (nagiosplug 1.4.5) J'ai peut être effectué une mauvaise manip lors de l'installation. Comment le vérifier?



          ==> soit ils ne génèrent pas de données de performance (perfdata) parce que l'option n'est pas activée :
          Je suis pas sur de moi mais est ce qu'il faut verifier cela dans l'interface Nagios >> Process Info :

          Performance Data Being Processed? Yes


          ==> soit tu ne fournis pas la macro $SERVICEPERFDATA$ à la commande ou au modèle perfdata défini pour Nagios. :
          Comment le vérifier?

          En tous cas merci pour ton aide je sais que sa doit être lourd de voir des questions aussi bête mais bon, j'ai bien essayé de parcourir les docs et les liens que j'ai à ma disposition et le résultat et que j'y comprend pas vraiment grand chose Lol

          Comment


          • #6
            Est ce que cela ressemble plus a ce que je devrais avoir ? :

            Code:
            [SERVICEPERFDATA]       1170319691      Imprimante      Check_Alive     0.087   0.303   PING OK -  Paquets perdus = 0%, RTA = 4.86 ms
            [SERVICEPERFDATA]       1170319712      Passerelle      Check_Alive     0.072   1.013   PING OK -  Paquets perdus = 0%, RTA = 0.82 ms
            [SERVICEPERFDATA]       1170319731      SV-Nagios       Check_Alive     0.160   0.666   PING OK -  Paquets perdus = 0%, RTA = 3.53 ms
            Lorsque j'execute :
            cat /usr/local/nagios/perfparse-service-perfdata.dat | /usr/local/nagios/bin/perfparse-log2mysql -c /usr/local/nagios/etc/perfparse.cfg -r

            J'obtient le meme tableau que dans mon premier poste, mais cette fois, toutes les ligne sont rejeté

            Comment


            • #7
              Originally posted by FoX View Post
              Je suis un NooB désolé ^^ je pensais que le ping été l'information qui allé remonter

              ==>Soit les plugins utilisés ne sont pas compatibles avec perfdata :
              Les plugins nagios ? j'ai installer ceux sur le site de nagios (nagiosplug 1.4.5) J'ai peut être effectué une mauvaise manip lors de l'installation. Comment le vérifier?
              La série 1.4.x fournit des plugins compatibles sauf pour check_ping. Il faut utiliser check_fping (attention, il nécessite les privilèges root) à la place.
              Les sorties de performances sont assez faciles à repérer.
              Raphaël 'SurcouF' Bordet
              Je ne teste pas mes plugins en root, tu ne testes pas tes plugins en root...
              Dons Paypal

              Comment


              • #8
                oki je vais essayer cela merci je revien pour vous tenir au courant.

                Comment


                • #9
                  SA Y EST j'ai des graphiques avec des courbes, bon je n'ai pas encore assez d'info pour que sa soit trés parlant mais le principal est que cela fonctionne .

                  Merci Surcouf pour ton aide je sais que j'ai du êtreu n peu lourd avec mes question mais bon
                  Je vais poursuivre mon voyage nagios Oreon

                  Merci a tous pour votre soutient ^^

                  Comment


                  • #10
                    tu as une methode ici avec ls dernieres versions : perfparse nagios
                    Cordialement,

                    2JS

                    solutions opensource

                    Comment


                    • #11
                      Bonjour,

                      Comment as-tu obtenu
                      Code:
                      [SERVICEPERFDATA]       1170319691      Imprimante      Check_Alive     0.087   0.303   PING OK -  Paquets perdus = 0%, RTA = 4.86 ms
                      [SERVICEPERFDATA]       1170319712      Passerelle      Check_Alive     0.072   1.013   PING OK -  Paquets perdus = 0%, RTA = 0.82 ms
                      [SERVICEPERFDATA]       1170319731      SV-Nagios       Check_Alive     0.160   0.666   PING OK -  Paquets perdus = 0%, RTA = 3.53 ms
                      Au lieu de ce que tu avais avant car j'ai exactement le même problème, ma base ne se remplit pas et pourtant mes fichiers se remplissent ... Merci d'avance

                      Comment

                      Working...
                      X