Announcement

Collapse
No announcement yet.

DB Error: no such database

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • klure
    replied
    Par contre moi j'ai un autre soucis

    Nagios tourne bien 0 warning 0 error, j'importe le tout dans oreon, je génère les fichier tout est ok. Je lance nagios -v /etc/nagios/nagios.cfg (pour nagios) et nagios -v /usr/local/oreon/fileGeneration/nagiosCFG/nagiod.cfg (pour oréon) et pour ces deux la j'ai 0 warning 0 error.

    Mais maintenant avec nagios je vois les hotes down, et dans oreon toujours rien dans monitoring, vue oreon,et acceuil Par contre je vois bien les hosts dans reporting et configuration.

    Quelqu'un aurai une chtite idée ? :confused:

    Ah une autre ptite question avant l'importation dans le fichier escalation de nagios j'ai quelque chose et lorsque je l'importe dans oréon il ne me crée pas d'escalades. Est ce normal ??

    Info qui pourrait peut être être utile :roll: : ma version d'oreon est la 1.4 et je suis sous kubuntu
    Last edited by klure; 5 June 2007, 10:36.

    Leave a comment:


  • NoS
    replied
    Cela peut aussi venir du fait que ton nagios ne peut pas ecrire son fichier de lock.

    Tu peux le définir dans les options nagios dans oreon (nagios cfg). Il faut que ton utilisateur nagios puisse creer ce fichier de lock.

    Leave a comment:


  • klure
    replied
    J'ai eu le meme message d'erreur et apparement dans ce qu'il dit il faut lancer nagios. Pour cela tu tappes dans un terminal : /etc/init.d/nagios start

    Ayant eu le meme message d'erreur que toi pour moi ca a marché cette commande.

    Apparement cela ne fonctionne que si tu n'as aucune erreurs danstes fichiers de conf.

    Total Errors : 0
    Last edited by klure; 4 June 2007, 12:47.

    Leave a comment:


  • netzuko
    replied
    l'import à marché nickel, sauf une chose.
    lorsque l'import s'est réalisé, il a modifié les fichiers de conf nagios.
    depuis ce temps là, le reportind marche ( j'ai bien accès aux hotes avec leur état ) , mais, je n'ai plus du tout accès à l'interface nagios, ce message d'erreur s'écrit:


    Whoops!
    Error: Could not read host and service status information!

    The most common cause of this error message (especially for new users), is the fact that Nagios is not actually running. If Nagios is indeed not running, this is a normal error message. It simply indicates that the CGIs could not obtain the current status of hosts and services that are being monitored. If you've just installed things, make sure you read the documentation on starting Nagios.

    Some other things you should check in order to resolve this error include:


    Check the Nagios log file for messages relating to startup or status data errors.
    Always verify configuration options using the -v command-line option before starting or restarting Nagios!
    Make sure you've compiled the main program and the CGIs to use the same status data storage options (i.e. text file or database). If the main program is storing status data in a text file and the CGIs are trying to read status data from a database, you'll have problems.

    Make sure you read the documentation on installing, configuring and running Nagios thoroughly before continuing. If all else fails, try sending a message to one of the mailing lists. More information can be found at http://www.nagios.org.



    j'ai du mal a comprendre et j'ai très peu de temps pour corriger cette erreur.
    quelqu'un aurait-il une idée svp?

    Leave a comment:


  • netzuko
    replied
    je suis en train de m'occuper d'une autre chose là. je serais là demain matin , donc, je te redemanderai surement d'autres choses demain, si t'es là, et surtout si ca ne te dérange pas.
    merci beaucoup. a demain

    Leave a comment:


  • clementthersiquel
    replied
    T'as bien mis un slash a la fin du chemin?
    Est ce que tu as exporte correctement tes configurations depuis que t'as change le nagios.cfg?

    Leave a comment:


  • netzuko
    replied
    il était déjà initialisé sur /etc/nagios et pourtant, il ne modifie rien dans /etc/nagios. j'ai énormément de mal a comprendre

    Leave a comment:


  • clementthersiquel
    replied
    Dans Oreon tu vas dans Configuration=>Nagios CFG et la t'as un champs au debut qui s'appelle Object Configuration Directory que tu modifies en /etc/nagios/ et ca devrait marcher

    Leave a comment:


  • netzuko
    replied
    aucune idée svp?

    Leave a comment:


  • netzuko
    replied
    lorsque je réalise l'export, mes fichiers de configuration s'enregistrent dans /usr/local/nagios/etc. comment faire pour qu'au lieu de s'enregistrer à cet endroit, ils soient sauvegardés dans /etc/nagios ?
    merci d'avance
    Last edited by netzuko; 28 May 2007, 11:41.

    Leave a comment:


  • netzuko
    replied
    l'option est déjà désactivée en fait.

    Leave a comment:


  • NoS
    replied
    je pense que c'est un probleme avec ODS.

    desactive l'option Lecture rapide des status pour voir :

    Options > Options générales > OreondataStarage > lecture rapide des status

    Leave a comment:


  • netzuko
    replied
    dans la barre de resumé en haut et aussi dans l'interface de monitoring, je n'ai aucun hote.
    où pourrait être le problème?

    Leave a comment:


  • NoS
    replied
    Tu veux dire dans la barre de resumé en haut ou alors quand tu va dans l'interface de monitoring ?

    Leave a comment:


  • netzuko
    replied
    je viens de trouver mon erreur qui était dans les droits pour /usr/local/nagios/ j'ai appliqué un "chmod 777 etc".

    Nagios 2.7
    Copyright (c) 1999-2007 Ethan Galstad (http://www.nagios.org)
    Last Modified: 01-19-2007
    License: GPL

    Reading configuration data...

    Running pre-flight check on configuration data...

    Checking services...
    Checked 275 services.
    Checking hosts...
    Checked 80 hosts.
    Checking host groups...
    Checked 5 host groups.
    Checking service groups...
    Checked 0 service groups.
    Checking contacts...
    Checked 1 contacts.
    Checking contact groups...
    Checked 1 contact groups.
    Checking service escalations...
    Checked 0 service escalations.
    Checking service dependencies...
    Checked 0 service dependencies.
    Checking host escalations...
    Checked 0 host escalations.
    Checking host dependencies...
    Checked 0 host dependencies.
    Checking commands...
    Checked 68 commands.
    Checking time periods...
    Checked 5 time periods.
    Checking extended host info definitions...
    Checked 80 extended host info definitions.
    Checking extended service info definitions...
    Checked 275 extended service info definitions.
    Checking for circular paths between hosts...
    Checking for circular host and service dependencies...
    Checking global event handlers...
    Checking obsessive compulsive processor commands...
    Checking misc settings...

    Total Warnings: 0
    Total Errors: 0

    Things look okay - No serious problems were detected during the pre-flight check

    cgi.cfg - déplacement OK
    checkcommands.cfg - déplacement OK
    contactgroups.cfg - déplacement OK
    contacts.cfg - déplacement OK
    dependencies.cfg - déplacement OK
    escalations.cfg - déplacement OK
    hostextinfo.cfg - déplacement OK
    hostgroups.cfg - déplacement OK
    hosts.cfg - déplacement OK
    misccommands.cfg - déplacement OK
    nagios.cfg - déplacement OK
    resource.cfg - déplacement OK
    serviceextinfo.cfg - déplacement OK
    servicegroups.cfg - déplacement OK
    services.cfg - déplacement OK
    timeperiods.cfg - déplacement OK


    ca a l'air de marcher, mais, j'ai l'impression que les services ne sont pas en route. 0 up, 0 down, 0 inaccessible, 0 en attente. tous les états sont a 0. une petite idée?

    Leave a comment:

Working...
X