Announcement

Collapse
No announcement yet.

problème au niveau de la base de données

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • problème au niveau de la base de données

    je viens d'installer nagios sur un serveur dédié a la supervision réseau.
    j'ai configuré donc nagios 2.7.
    Par la suite, j'installe donc oreon 1.4, mais plusieurs problèmes persistent au niveau de la base de données.
    lorsque sur oreon, je vais dans options/database, le message suivant s'affiche : "Problème avec la base Perfparse : DB Error: no such database"

    je suis débutant dans l'informatique et j'ai du mal quand même à comprendre là.
    si quelqu'un pourrait me renseigner, ce serait cool

    second problème : les bases de données crées par oreon sont les suivantes :
    +--------------------+
    | Database |
    +--------------------+
    | information_schema |
    | oreon |
    +--------------------+

    comment cela se fait-il que je n'ai que deux bases?

    La derniere question que je me pose est la suivante : comment faire pour faire fonctionner oreon avec la configuration de nagios déjà existante sur le serveur.

    bcp de questions, je suis désolé, mais, j'ai vraiment besoin d'une réponse.
    je vous remercie d'avance.
    ++
    Jérôme
    Last edited by netzuko; 21 May 2007, 12:27.

  • #2
    Salut,

    On va essayer de trouver les reponses à tes questions. Premier point pauvais pour toi, ton pseudo ne sugere pas que tu sois blonde à forte poitrine :grin:

    1-lorsque sur oreon, je vais dans options/database, le message suivant s'affiche : "Problème avec la base Perfparse : DB Error: no such database"

    Perfparse est un module supplementaire de nagios qui permet de "parser" les données pour faire des graphiques (un peu comme cacti).
    Destactive le dans : Options > Oreon > Options Générales > Nagios > utilisation de PerfParse > Non
    puis sauvegarde et ça devrait marcher.

    2-second problème : les bases de données crées par oreon sont les suivantes
    Jusque là tout est normal, ton utilisateur a un acces limité à ces bases. par contre regarde avec le compte root si tu n'a pas une base qui s'apelle ODS aussi.

    3-comment faire pour faire fonctionner oreon avec la configuration de nagios déjà existante sur le serveur.
    Tu peux importer la conf dun nagios qui tourne dans oreon par le menu configuration > importer
    Il se peut qu'il y ait quelques problemes sur cette fonction.

    bonne config ;D
    ..()_() .°("who | grep -i blonde | date; cd ~; unzip;")
    =(o_0)=
    *(() () Nicolas Verriest, France

    Comment


    • #3
      merci beaucoup pour ta réponse, c'est sympathique de ta part
      a propos de la blonde, a forte poitrine, c'est pas moi, t'avais pas tord.
      mais, cependant, je possède surement des connaissances en informatique très proches des siennes.lol
      d'ailleurs, je bute encore sur une chose.
      mon utilisateur root possède un compte avec tous les privillèges.
      comment cela se fait il qu'il n'ai pas la base ods?

      au niveau de l'import, pourquoi ça pose pb en fait ?

      j'ai un autre souci en fait, et je sais que vous allez me trouver chiant.
      dans fiches d'indentité, lorsque je fais une mise a jour manuelle, ça m'affiche ça : DB Error: syntax error

      merci bcp d'avance
      ++

      Jérôme
      Last edited by netzuko; 21 May 2007, 15:38.

      Comment


      • #4
        me revoilà :
        sous le compte root, j ai acces aux trois bases suivantes :
        information_schema( 17 )
        mysql( 18 )
        oreon( 90 )
        rien d'autre .

        Comment


        • #5
          j attend votre réponse, je suis vraiment bloqué.
          merci

          Comment


          • #6
            salut,

            pour tes bases :

            Alors si tu as installé oreon 1.3.x c'est normal.
            Si tu as installé 1.4.x c'est pas normal.

            pour les fiches d'identité c'est étrange et je crois pas avoir vue un post sur le forum qui parlait de ça.

            Le plus simple plutot que de chercher des poils aux oeufs je pense que c'est que tu suprimme ta base oreon et que tu reinstalles oreon1.4.
            Quand tu va faire l'install verifie bien que tu n'aies pas d'erreurs, surtout au niveau de l'insterface web. Normalement l'install va creer tout ce qu'il faut ou il faut, il y aura peut etre quelques petit problemes mais on verra ensuite.

            Pour l'import tu peux essayer, mais certaines personnes ont des problemes (cf posts sur le forum), donc si tu as de la chance ça marche .
            ..()_() .°("who | grep -i blonde | date; cd ~; unzip;")
            =(o_0)=
            *(() () Nicolas Verriest, France

            Comment


            • #7
              merci, je vais donc refaire tout l'install
              j aurais surement besoin d'un coup de main par la suite
              j'ai effectivement installé la oreon 1.4 donc, il y a un réel souci.
              a tte

              Comment


              • #8
                install refaite, je suis a l'import qui est délicat

                Comment


                • #9
                  pourquoi ce message quant je fais l'import?

                  cgi.cfg - déplacement KO
                  checkcommands.cfg - déplacement KO
                  commands.cfg - déplacement KO
                  contactgroups.cfg - déplacement KO
                  contacts.cfg - déplacement KO
                  dependencies.cfg - déplacement KO
                  escalations.cfg - déplacement KO
                  hostextinfo.cfg - déplacement KO
                  hostgroups.cfg - déplacement KO
                  hosts.cfg - déplacement KO
                  meta_commands.cfg - déplacement KO
                  meta_contact.cfg - déplacement KO
                  meta_contactgroup.cfg - déplacement KO
                  meta_dependencies.cfg - déplacement KO
                  meta_escalations.cfg - déplacement KO
                  meta_host.cfg - déplacement KO
                  meta_hostgroup.cfg - déplacement KO
                  meta_services.cfg - déplacement KO
                  meta_timeperiod.cfg - déplacement KO
                  misccommands.cfg - déplacement KO
                  nagios.cfg - déplacement KO
                  perfparse.cfg - déplacement KO
                  resource.cfg - déplacement KO
                  serviceextinfo.cfg - déplacement KO
                  servicegroups.cfg - déplacement KO
                  services.cfg - déplacement KO
                  timeperiods.cfg - déplacement KO

                  ca fait 2 fois ke je l'envoie sur ce forum et que personne ne me répond.

                  si quelqu'un qui sait passe ici, ce serait cool
                  merci d'avance.

                  Comment


                  • #10
                    Je n'ai jamais vue ça comme ça.

                    As tu essayé de debuguer le truc en mettant tes fichiers que tu veux importer en 777, je pense que c'est l'user apache qui doit les deplacer mais il ne doit pas avoir les droits de le faire.
                    ..()_() .°("who | grep -i blonde | date; cd ~; unzip;")
                    =(o_0)=
                    *(() () Nicolas Verriest, France

                    Comment


                    • #11
                      les drois sont bien en 777 avec l'utilisateur apache mais, j'ai toujours le meme résultat

                      Comment


                      • #12
                        il a bel et bien le chown a 777, mais, il y a toujours le meme message.
                        il a bien crée les fichiers dans /usr/local/oreon/filesGeneration/nagiosCFG.
                        mais, l'erreur est toujours présente :

                        cgi.cfg - déplacement KO
                        checkcommands.cfg - déplacement KO
                        contactgroups.cfg - déplacement KO
                        contacts.cfg - déplacement KO
                        dependencies.cfg - déplacement KO
                        escalations.cfg - déplacement KO
                        hostextinfo.cfg - déplacement KO
                        hostgroups.cfg - déplacement KO
                        hosts.cfg - déplacement KO
                        misccommands.cfg - déplacement KO
                        nagios.cfg - déplacement KO
                        resource.cfg - déplacement KO
                        serviceextinfo.cfg - déplacement KO
                        servicegroups.cfg - déplacement KO
                        services.cfg - déplacement KO
                        timeperiods.cfg - déplacement KO

                        avez vous une proposition?
                        merci d'avance

                        Comment


                        • #13
                          Essaie de voire avec ce post qui ressemble à ton probleme :

                          http://forum.oreon-project.org/showthread.php?t=3576

                          Peut etre que vous trouverez une solution commune.
                          ..()_() .°("who | grep -i blonde | date; cd ~; unzip;")
                          =(o_0)=
                          *(() () Nicolas Verriest, France

                          Comment


                          • #14
                            merci beaucoup

                            Comment


                            • #15
                              mon gros problème est que chacun des hotes a ses services associés mais, dans reporting, les résultats sont undeterminated. comment ca se fait?

                              Comment

                              Working...
                              X