Announcement

Collapse
No announcement yet.

PHP-WeatherMap-1.2 Available

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #46
    Oui malheureusement ...

    Une précision me manque ... Avez-vous des choses dans la catégorie Image ou alors ce ne sont que les images que l'on ajoute manuellement qui apparaissent ici ?

    Comment


    • #47
      les listebox Background Image Filename et icone filename pointe vers mon repertoire nagios/share/images.

      Par contre, je viens de m'apercevoir que presque tout mes liens ont pris les meme valeurs (%) et ces valeurs ne correspondent pas aux graphx associés ??

      Etrange ...
      .-=NiTroZ=-. http://www.pmartin.net
      <!---
      CentOs
      Centreon 2.2RC2
      Nagios 3.2.1
      Nagvis 1.4.7
      ---!>

      Comment


      • #48
        problème de 0% :

        piste 1 :
        c'est peut être que php-weatherMap n'arrive pas à lire vos rrd !!!
        -> donner droits en lecture à apache sur vos rrd dans .../oreon/OreonDataStorage

        piste 2:
        c'est peut être que php-weathermap n'arrive pas à reconnaitre les seuls DS qu'il est capable de lire dans les rrd à savoir :
        - 'traffic_in'
        - 'traffic_out'
        (en minuscule avec le underscore)
        pour savoir si vos rrd sont OK au niveau des DS :
        - ouvrir le fichier .../www/modules/php-weathermap/configuration/pwr-??/configs/(le nom de ta weathermap)
        - chercher les infor TARGET dans les objets LINK
        on doit trouver :
        Code:
        LINK node1187019441-node1187019467
                INFOURL LINKINFOURLTOCHANGE_668
                OVERLIBGRAPH LINKHOVERURLTOCHANGE_generateODSImage.php?host_id=66&svc_id=250
                TARGET (path_oreon)/oreon/OreonDataStorage/1344.rrd (path_oreon)/oreon/OreonDataStorage/1345.rrd
                NODES node1187019441 node1187019467
        laisser tomber tous les numéros, yen a 2 d'importants ici en gras

        faire un :
        Code:
        rrdtool fetch (path_oreon)/oreon/OreonDataStorage/1344.rrd AVERAGE --start now-200
                             traffic_in
        
        1187100200: 1.3116518462e+04
        1187100330: 1.1916290769e+04
        et un
        Code:
        rrdtool fetch (path_oreon)/oreon/OreonDataStorage/1345.rrd AVERAGE --start now-200
                            traffic_out
        
        1187100330: 5.1288845538e+06
        -> vérifier que vous avez bien les metrics 'traffic_in' et 'traffic_out' et que la base rrd est normalement remplie par ODS !!!
        (
        si vous avez du
        Code:
        1187100330: nan
        normalement pas de graphs -> pas plus de calculs
        )

        -> si vous avez autre chose que ces deux metrics, c'est normal que vous n'ayez pas de traffic dans la weathermap
        -> si par malheur vous avez 'metric' : appliquer le script renameDS.pl dans les utilitaires du tarball d'install de centreon (sous script)

        sinon, je ne vois pas trop d'ou ca pourrait venir ??

        Gaé

        Comment


        • #49
          Merci de ton aide,

          Mais voila : j'ai des nan et pourtant mes graphes fonctionnent ...

          Edit ^1 : Les droits sur les .rrd doivent etre donné a apache (www-data dans mon cas) ou a l'utilisateur nagios ??
          Last edited by Grosminus; 14th August 2007, 16:25.

          Comment


          • #50
            Pourtant à chaque generation de ma map , mes % de charges reseaux varient et ne sont pas nul

            Apparemment mes liens prennent tous la valeur du dernier lien edité en configuration. Par contre les graph qui apparaissent en survol sont correcte
            A savoir que ces liens partent en "etoile" depuis un meme switch
            .-=NiTroZ=-. http://www.pmartin.net
            <!---
            CentOs
            Centreon 2.2RC2
            Nagios 3.2.1
            Nagvis 1.4.7
            ---!>

            Comment


            • #51
              Je n'i pas de graphs au survol des liens ...

              Je pense qu'il n'arrive pas a faire le lien entre mes .rrd et weathermap.

              Comment


              • #52
                Originally posted by Grosminus View Post
                Merci de ton aide,

                Mais voila : j'ai des nan et pourtant mes graphes fonctionnent ...
                quelques petits 'nan' (Not A Number) de temps en temps, ce n'est pas genant, si ce n'est que ca fait des trous dans les graphs +/- gros suivant le nombre de nan à la suite.
                essaye de mettre --start=now-800 ou -1600
                (ca veux dire que tu demandes les données entrées dans les rrd entre maintenant et il y a 800/1600 secondes)

                si les graphs sont bons, regarde quand même sur le graph en question si c'est bien le même rrd
                sous Oreon -> vues Oreon -> ton graph de traffic -> grossisement max -> clé à molette -> ???
                avant on pouvait voir le nom des fichiers rrd des courbes mais plus maintenant :-(



                sinon, regarde la date du fichier, (ls -l le fichier), si il n'a pas été mis à jour depuis longtemps, c'est que tu as un problème avec ODS !!

                autre piste un peu + hard, dans le fichier ../modules/php-weathermap/config../pwr../weathermap.php, tu peux essayer de mettre temporairement l'option debug à 1 et jeter un coup d'oeil aux fichiers générés -> tu aura peut être des infos !

                bon courrage

                Gaé

                Comment


                • #53
                  Originally posted by Grosminus View Post
                  Je n'i pas de graphs au survol des liens ...

                  Je pense qu'il n'arrive pas a faire le lien entre mes .rrd et weathermap.
                  jette un coup d'oeil au code source de la page pour voir les liens
                  ils sont derrière les options html 'onmouseover ... src=(ton lien);'

                  moi, j'ai eu un problème maintenant résolu après qq menus corrections car il essayait de charger les pages en http:// ... alors qu'elles sont en https !!

                  enfin, le meilleur moyen de tester le lien, c'est de le copier et de faire une requête directe dans ton navigateur.

                  si ca marche, tu dois avoir une page avec plein de caractères bizards du style :
                  Code:
                  �PNG  ��� IHDR������������%����ItEXtSoftware�RRDtool, Tobias Oetiker , http://tobi.oetiker.ch�\a��� �IDATx�]�����/F�i�hԈ�&�X���F��,��Fh�"F�'�c�ĂH�([email protected]��*�>x�W�U�o�s�ٝ;o�����^8���;e�9sΙ��̖�kڴi���������7�|S��F+,����^������,_�n���}�}�}�}�} �>� �-|��>�>�>�>P�>� ^���+��_!���F����qq�g```(P`/P�������}�}�} �>� � �W�����)�/��R���矻�颊APTT$�"����ȑ#�c5�8���1��E�h�+����@�>0y�d1~�x�d� �g�6��V ��W_������8����������/~�� :?n�8_:[��������W�am�*_>_�,ۿ0���-��X�ˆU�~S��[�n$��DI���bc�ĉ�:��G�æ�K/� $�?�xy�p�a���={崩�D�� �g?�'�7a„��ћdOS����amڴ?��O��,��ެ�S;Z�n- F�!�9��}��b���?���E�ƍŢE���a�]v���/~Q0����?j^�S�L����˫�%L�0�L�4I�~���?�`����d=��-LP�8�1z��,�/_.���J���X���w�-�f��K<���Q���a}�~t~�S�Zl�kp?'�Ǐ��1c���~|����E�ڵ�رce�7o�x��:b�x$�w?>~�,~���u�N�y�M7�f͚�U�V ���c���.3|�����D�N�����b��_�R<��#�2����W,\�0=�x��E߾}�_�%-� ��EF�ѫW/q�i��[email protected]�)�la�Y�l��9s����������z����������I'����۷�^z�X�z��?�8���[email protected]��d6��9SտM���ӏ��)?�m�t�k��F�H �/�Z��3����g⮻�r����O��3 �&�6J��H�2�,��ֈ���߿��U��,s�-��u``<��3�(�X����x���(�13&�T:����Gy�x��dVˇՏ����͍7�Xe���W�x��S���3gN�,a��<������Q���x� 7�Yf���&��s?�7�o� ����СC]��1�V�t�Rq�Gȼv�� Ȋ��~�يZ^���S9j'��a�E�M�E=Q���o�cO�z�dy��xٟ��s��^x��V2���: h(O����W͇=��y�������J��8�Ai�p͚5��@�2:Vq��g�~�>f��S͐�V=uzO?Y�տ�xD�7���S�'�0���K���g� t�Sy����G�#�$/��.��O>��}� �G�F��ds���:�,9h�l�R�z�n�.�@\q�b�ʕ�*�w�q�Q�X���sݺu���o��$LXH|L��gVpL�2Ay�����e�;w��ׯR?�0�G��� ���G�00i<�@y�0H>\y� [�3 A�!�=z��W]u���.���)�w�/��(�+G�A�����͛�X0���x�����G�����ӧK{̚5K�R+f�XZ�2��B�?���{���'��,�c&5h� ���S~���0̿��I�����m۶�n�w�}�dǹ �k��V��q� ���/8����f3f̐���I?Or���3)��������n�0�9���/.�;���X�/��hT���F�o? Z�G��#�Z�����_X�}�嗥��-���0����a�#��o��ҸM���7�x�}� �p!Fe� �+H��?v�kp� N�e�D�J �p�^ R������9�w2�W�p%����J9⡖U㹞ӏZ�)���@8g�lRo��|�̠���>�@�Mu!O��U� :=���)�w��1h�?�8�#~R��!9�Q�y���?tΆ�Z�@!�}���g��Y��Gp�+�󨣎rۂ���c mmذ��ئ:��<�S����_�ۤ_��0������o?�P9��Ǥ*���_��WRǶ��w���c���p����M�E I����CӦM�m�ݖ%?�f�X1��{���O�G�?S����ԋ�T�:�N��J�Vp>l&nzH� >$;B�aT���7ɤ��':�?l��ot�~q?������/�a\6l����(�o�L.��F]-6�T:=�� ��3�� �,�F��X*�A,�\Auч�'��t����$�)�t%�+>����g�?L?ė�T�GQ�u~�"Š��x�N������(���O~��GO��zO���r,�x.Ј�r�q�_�YBTz�]*��x��6�w\��L �%�L:o=M��Bۙ�_������ ?�#fOT&J�]�?J`j��j(M�0�D\�'��/��ħN�*�u��)��=̿��7�3�7��oA�EeU��:��G��� �|�p��0"V�N9����W�-�/��" �x�Ԁ-Z�{�x�OȪ�� ��x�M!)�/�p�sz����1�B����:K T6��؜�����N8�} ��w߭҆ �`��ݻ�{ڸ��:A�~�/�xE��=q�$�M�(��~��#>Q�M�� ��h5C�_ ի���(�e���9<}�{�~O���x�e�,^�㇋�'�x���=]�G}�#�
                  (remarque au début : PNG et l'adresse du créateur de rrdtool !!)

                  si c'est ça, il faut attendre 1 peu les correctifs

                  Gaé
                  Last edited by gae; 14th August 2007, 16:42.

                  Comment


                  • #54
                    Merci Gae,

                    Je reprend tout ça dés Jeudi matin !!
                    Bon 15 Aout a tous !!

                    Comment


                    • #55
                      Bonjour,

                      De retour sur ce module PHP-Weathermap.
                      Je rencontre encore quelques petits problèmes aprés son installation.

                      1er : Pas de représentation du graphe de traffic lorsque je passe ma souris sur le lien reliant deux nodes.
                      Il me marque juste LINK: nodexxxxxxxxxx-nodexxxxxxxxxxxx

                      2ième : Dés que l'on reedite un node pour modifier un paramètre ( nom,image.... ), le lien qui permettait lorsque l'on cliquait dessus d'aller directement vers le node ne fonctionne plus.on se retrouve avec le lien https://10.1.XX.XX/oreon/NODEINFOURLTOCHANGE_

                      J'ai trouvé pour la 2ième question : il faut reentrer tous les paramètres de définitions du node.........:rolleyes:

                      Peut être quelqu'un a la solution pour la première question..... ?

                      Cordialement

                      Comment


                      • #56
                        Bonjour à tous !!!

                        Je me posait la question :

                        Comment se fait-il que sur la WeatherMap, j'ai un lien chargé à 30% <-> 20% environ alors que quand je clique sur le graph, tout est à 0 !!!!!!!!!!!

                        -> il y a un bug dans la requete SQL pour la récupération des numéros des fichiers rrd !!!!, ce ne sont pas les bons qui sont utilisés pour tracer les weathermaps !!!!!!
                        -> pour le pb des 0% gris : possible que tous vos liens pointent vers des fichiers rrd de graphs vides !!! alors que quand on clique sur le lien pour voir les graphs, on va sur la bonne page !!


                        /!\ ATTENTION, n'effectuez ces corrections que si vous savez ce que vous faites, n'oubliez surtout pas de faire une copie du fichier original avant de modifier

                        /!\ ATTENTION /!\ en suivant ces instructions, vous modifiez le code du module, le projet Oreon n'y est pour rien du tout !!!!!!!!! -> pas de remarques vers les développeurs !!!

                        pour corriger :
                        Code:
                        cd .../modules/php-weathermap/configuration/pwr ... /
                        cp editor.php editor.php.back (une petite sauvegarde de l'original peut toujours servir)
                        vi editor.php
                        :204 (aller ligne 204)
                        effectuer les corrections suivantes :
                        les # sont à rajouter pour commenter les lignes d'une requete SQL inutile
                        la dernière ligne est la nouvelle requête SQL à ajouter

                        Code:
                        # mod
                        #                       $DBRESULT =& $pearDBO->query("SELECT id FROM `index_data` WHERE service_id = '".$_REQUEST['svc_id']."' LIMIT 1");
                        #                       if (PEAR::isError($DBRESULT))
                        #                               print "DB Error : ".$DBRESULT->getDebugInfo()."<br>";
                        #                       $DBRESULT->fetchInto($index_data);
                        
                        #                       $DBRESULT =& $pearDBO->query("SELECT metric_id FROM `metrics` WHERE index_id = '".$index_data['id']."' ORDER BY metric_name");
                                                $DBRESULT =& $pearDBO->query("SELECT metric_id FROM `metrics` WHERE index_id = '".$index['id']."' ORDER BY metric_name");
                        # end mod
                        si ca ne marche pas bien chez vous :
                        revenez en arrière !!!

                        suis intéressé par d'éventuels remarques/ retours..

                        REMARQUE :
                        si votre fichier rrd ne contient que des 0.0000000000e0 => le graph sera en gris
                        si vous voulez un beau lien blanc 0% corriger le code suivant
                        /!\ ATTENTION, vous corrigez du code et de plus, perso, je ne conseille pas cette modif !!!!!!!!!!!!!!!!!!! (si le lien est up, il y a toujours un tout petit peu de traffic dessus (au moins les checks_host_alive de Nagios qui vérifie que votre équipement derrière est bien en vie ) !!!
                        Code:
                        cd ...même repertoire
                        cp Weathermap.class.php Weathermap.class.php.back
                        vi Weathermap.class.php
                        : 1874 (aller à la ligne 1874)
                        corriger pour lire :
                        Code:
                                        // you'll only get grey for a COMPLETELY quiet link if there's no 0 in the SCALE lines
                                        if ($percent < 0) { return $this->grey; }
                        #                if ($percent == 0) { return $this->grey; }

                        pour je ne sais plus qui voulait avoir ses % en bits/s et non en bytes/s !!
                        aller lignes 1655 du fichier Weathermap.class.php
                        corriger les 2 lignes
                        Code:
                                                if (preg_match("/<\!-- cuin d (\d+) -->/", $buffer, $matches)) { $inbw=$matches[1] * 8; }
                        
                                                if (preg_match("/<\!-- cuout d (\d+) -->/", $buffer, $matches)) { $outbw=$matches[1] * 8; }
                        la encore, ne corrigez que si vous savez ce que vous faites!! ne mettez pas le bocson dans votre weathermap !!

                        voilà voilà

                        Gaé
                        Last edited by gae; 16th August 2007, 13:10.

                        Comment


                        • #57
                          Originally posted by lindusfree View Post
                          Bonjour,

                          De retour sur ce module PHP-Weathermap.
                          Je rencontre encore quelques petits problèmes aprés son installation.

                          1er : Pas de représentation du graphe de traffic lorsque je passe ma souris sur le lien reliant deux nodes.
                          Il me marque juste LINK: nodexxxxxxxxxx-nodexxxxxxxxxxxx

                          2ième : Dés que l'on reedite un node pour modifier un paramètre ( nom,image.... ), le lien qui permettait lorsque l'on cliquait dessus d'aller directement vers le node ne fonctionne plus.on se retrouve avec le lien https://10.1.XX.XX/oreon/NODEINFOURLTOCHANGE_

                          J'ai trouvé pour la 2ième question : il faut reentrer tous les paramètres de définitions du node.........:rolleyes:

                          Peut être quelqu'un a la solution pour la première question..... ?

                          Cordialement
                          regarde les qq postes d'avant on en parle !!

                          Comment


                          • #58
                            Originally posted by Grosminus View Post
                            Je n'i pas de graphs au survol des liens ...

                            Je pense qu'il n'arrive pas a faire le lien entre mes .rrd et weathermap.
                            si tu as un "nodeXXX-nodeXXX" sans graph, c'est un pb de lien vers les graphs
                            si tu n'as rien
                            -> va dans config, clique sur "style"
                            -> mes HTML style" sur "overlib .."
                            -> clique sur "submit"
                            (si tu as déjà HTML style" sur "overlib .." clique quand même sur "submit")
                            je pense qu'il y a un problème au niveau du set par defaut !!!
                            j'ai créer une map sans toucher à ce menu, je n'avais pas les graphs -> après grosse recherche dans le code, je me suis appercu que html style était sur "static" -> dc normal si j'avais pas les overlibgraphs !!
                            mais quand je suis allé dans le menu style pour la première fois, j'avais bien la paramètre réglé sur "overlib" mais il n'était pas pris en compte
                            -> un "submit" dans ce menu et tout est rentré dans l'ordre

                            => je reconnais, c'est pas très intuitif !!

                            Gaé

                            Comment


                            • #59
                              Originally posted by gae View Post
                              jette un coup d'oeil au code source de la page pour voir les liens
                              ils sont derrière les options html 'onmouseover ... src=(ton lien);'

                              moi, j'ai eu un problème maintenant résolu après qq menus corrections car il essayait de charger les pages en http:// ... alors qu'elles sont en https !!

                              enfin, le meilleur moyen de tester le lien, c'est de le copier et de faire une requête directe dans ton navigateur.

                              si ca marche, tu dois avoir une page avec plein de caractères bizards du style :
                              Code:
                              �PNG  ��� IHDR������������%����ItEXtSoftware�RRDtool, Tobias Oetiker , http://tobi.oetiker.ch�\a��� �IDATx�]�����/F�i�hԈ�&�X���F��,��Fh�"F�'�c�ĂH�([email protected]��*�>x�W�U�o�s�ٝ;o�����^8���;e�9sΙ��̖�kڴi���������7�|S��F+,����^������,_�n���}�}�}�}�} �>� �-|��>�>�>�>P�>� ^���+��_!���F����qq�g```(P`/P�������}�}�} �>� � �W�����)�/��R���矻�颊APTT$�"����ȑ#�c5�8���1��E�h�+����@�>0y�d1~�x�d� �g�6��V ��W_������8����������/~�� :?n�8_:[��������W�am�*_>_�,ۿ0���-��X�ˆU�~S��[�n$��DI���bc�ĉ�:��G�æ�K/� $�?�xy�p�a���={崩�D�� �g?�'�7a„��ћdOS����amڴ?��O��,��ެ�S;Z�n- F�!�9��}��b���?���E�ƍŢE���a�]v���/~Q0����?j^�S�L����˫�%L�0�L�4I�~���?�`����d=��-LP�8�1z��,�/_.���J���X���w�-�f��K<���Q���a}�~t~�S�Zl�kp?'�Ǐ��1c���~|����E�ڵ�رce�7o�x��:b�x$�w?>~�,~���u�N�y�M7�f͚�U�V ���c���.3|�����D�N�����b��_�R<��#�2����W,\�0=�x��E߾}�_�%-� ��EF�ѫW/q�i��[email protected]�)�la�Y�l��9s����������z����������I'����۷�^z�X�z��?�8���[email protected]��d6��9SտM���ӏ��)?�m�t�k��F�H �/�Z��3����g⮻�r����O��3 �&�6J��H�2�,��ֈ���߿��U��,s�-��u``<��3�(�X����x���(�13&�T:����Gy�x��dVˇՏ����͍7�Xe���W�x��S���3gN�,a��<������Q���x� 7�Yf���&��s?�7�o� ����СC]��1�V�t�Rq�Gȼv�� Ȋ��~�يZ^���S9j'��a�E�M�E=Q���o�cO�z�dy��xٟ��s��^x��V2���: h(O����W͇=��y�������J��8�Ai�p͚5��@�2:Vq��g�~�>f��S͐�V=uzO?Y�տ�xD�7���S�'�0���K���g� t�Sy����G�#�$/��.��O>��}� �G�F��ds���:�,9h�l�R�z�n�.�@\q�b�ʕ�*�w�q�Q�X���sݺu���o��$LXH|L��gVpL�2Ay�����e�;w��ׯR?�0�G��� ���G�00i<�@y�0H>\y� [�3 A�!�=z��W]u���.���)�w�/��(�+G�A�����͛�X0���x�����G�����ӧK{̚5K�R+f�XZ�2��B�?���{���'��,�c&5h� ���S~���0̿��I�����m۶�n�w�}�dǹ �k��V��q� ���/8����f3f̐���I?Or���3)��������n�0�9���/.�;���X�/��hT���F�o? Z�G��#�Z�����_X�}�嗥��-���0����a�#��o��ҸM���7�x�}� �p!Fe� �+H��?v�kp� N�e�D�J �p�^ R������9�w2�W�p%����J9⡖U㹞ӏZ�)���@8g�lRo��|�̠���>�@�Mu!O��U� :=���)�w��1h�?�8�#~R��!9�Q�y���?tΆ�Z�@!�}���g��Y��Gp�+�󨣎rۂ���c mmذ��ئ:��<�S����_�ۤ_��0������o?�P9��Ǥ*���_��WRǶ��w���c���p����M�E I����CӦM�m�ݖ%?�f�X1��{���O�G�?S����ԋ�T�:�N��J�Vp>l&nzH� >$;B�aT���7ɤ��':�?l��ot�~q?������/�a\6l����(�o�L.��F]-6�T:=�� ��3�� �,�F��X*�A,�\Auч�'��t����$�)�t%�+>����g�?L?ė�T�GQ�u~�"Š��x�N������(���O~��GO��zO���r,�x.Ј�r�q�_�YBTz�]*��x��6�w\��L �%�L:o=M��Bۙ�_������ ?�#fOT&J�]�?J`j��j(M�0�D\�'��/��ħN�*�u��)��=̿��7�3�7��oA�EeU��:��G��� �|�p��0"V�N9����W�-�/��" �x�Ԁ-Z�{�x�OȪ�� ��x�M!)�/�p�sz����1�B����:K T6��؜�����N8�} ��w߭҆ �`��ݻ�{ڸ��:A�~�/�xE��=q�$�M�(��~��#>Q�M�� ��h5C�_ ի���(�e���9<}�{�~O���x�e�,^�㇋�'�x���=]�G}�#�
                              (remarque au début : PNG et l'adresse du créateur de rrdtool !!)

                              si c'est ça, il faut attendre 1 peu les correctifs

                              Gaé
                              bon, au point ou j'en suis, je balance la modif de code qui a corrigé mon problème :

                              /!\ ATTENTION, cette modif n'est pas officielle, vous effectuez une correction de code qui n'engage que vous et pas les développeurs du module !!

                              pensez bien à sauvegarder les fichiers originaux avant de faire des modifs dedans !!!

                              Code:
                              cd .../modules/php-weathermap/views/
                              cp showMap.php showMap.php.back
                              sudo vi showMap.php
                              en tout début du fichier, : ajouter la ligne :
                              Code:
                                      if ($pwm_id && $pwm_name)       {
                              # added
                              $my_server_url_path = preg_replace("/(.*)oreon.php?.*/", "\\1", $_SERVER["HTTP_REFERER"], -1);
                              # end added
                              
                              
                                              $rq = "SELECT * FROM pwm_maps WHERE pwm_id = ".$pwm_id."";
                                              $DBRESULT =& $pearDB->query($rq);
                              ...
                              puis, commentez les 2 lignes suivantes
                              Code:
                              # mod
                              #                       $protocol = preg_replace("/([0-9\.\/\\\:\_\-]+)/", "", $_SERVER["SERVER_PROTOCOL"], -1);
                              #                       $protocol = strtolower($protocol);
                              #$protocol="https";
                              # end mod
                              enfin, modifiez la ligne un tout petit peu en dessous : (la ligne originale est commentée)
                              Code:
                              # mod
                              #                       $contents = preg_replace ("/(LINKHOVERURLTOCHANGE_)/", $protocol."://".$_SERVER["SERVER_NAME"].$oreon->optGen["oreon_web_path"]."modules/php-weathermap/views/", $contents, -1);
                                                      $contents = preg_replace ("/(LINKHOVERURLTOCHANGE_)/", $my_server_url_path."modules/php-weathermap/views/", $contents, -1);
                              # end mod
                              et voilà, ca devrait mieux fonctionner

                              bon courage à tous

                              Gaé

                              Comment


                              • #60
                                MERCI ........gae
                                Bravo pour cette modification sur la partie HTTPS
                                Maintenant ca marche

                                Pour le coup du overlib j'avais trouvé entre temps qu'il fallait revalider les paramètres.

                                Il ne me reste plus qu'un seul problème
                                les paramètres du menu Map Style.
                                Les fonts ne changent pas et j'ai pas de previsualisation de la font dans le menu.

                                Cordialement

                                Comment

                                Working...
                                X