Announcement

Collapse
No announcement yet.

Centreon 2.8.5 / Poller not running

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Centreon 2.8.5 / Poller not running

    Message en français plus bas

    Hi everybody,

    Due to an overloaded central server, I tried to install a new poller but this last stays as "not running".

    I followed the official documentation (https://documentation.centreon.com/d...iguration.html)) and the sugarbug one, without success.

    Central versions :
    - Centreon Web 2.8.5
    - Centreon Engine 1.7.1
    - Centreon Broker 3.0.4

    The poller has been installed with the Centreon poller 3.4.1 ova and a 'yum update' has been performed.
    Poller version :
    - Centreon Engine 1.7.1
    - Centreon broker 3.0.4

    Services start correctly on both sides (central and poller)

    [root@XXXXX centreon-broker]# service cbd status
    cbwd (pid 15729) is running...

    [root@XXXXX centreon-broker]# service centengine status
    centengine status: running [ OK ]

    Central can access the poller with a ssh key, without a password

    I notice the following error in the centcore.log : "Engine configuration file is empty for poller ID. Please check nagios.cfg file."
    The engine configuration exist. I duplicated the central's configuration and mdify the linked poller (files tab) and the xml module name (data tab)

    No firewall between both machines.

    What should I check ? Thank you !

    Best regards


    David




    ​​​​​​​Bonjour à tous,

    J'ai actuellement un central un peu trop chargé et j'ai donc voulu installé un poller mais ce dernier reste en "not running".

    J'ai suivi la documentation officielle afin d'ajouter le poller (https://documentation.centreon.com/d...iguration.html) et également celle sur sugarbug mais rien n'y fait.

    Versions du central :
    - Centreon Web 2.8.5
    - Centreon Engine 1.7.1
    - Centreon Broker 3.0.4

    Installation du poller depuis l'OVA Centreon Poller 3.4.1. + yum update.
    Version du poller :
    - Centreon Engine 1.7.1
    - Centreon broker 3.0.4


    Les services sont correctement démarrés des deux côtés (central et poller) :
    [root@XXXXX centreon-broker]# service cbd status
    cbwd (pid 15729) is running...

    [root@XXXXX centreon-broker]# service centengine status
    centengine status: running [ OK ]

    Le central se connecte sans soucis via SSH avec une clé, sans mdp.

    J'avoue ne pas trop savoir où regarder. Je constate néanmoins sur le central qu'il y a des erreurs dans centcore.log :
    Engine configuration file is empty for poller ID. Please check nagios.cfg file.

    Or, J'ai dupliqué l'engine configuration du central et ai modifié le nom du xml dans Data >multiple broker module, de même que le Files > linked poller afin qu'il pointe sur mon poller.

    Pas de firewall entre les deux machines.

    Que puis-je vérifier ? Merci d'avance de votre aide,

    Cordialement,

    David





  • #2
    Bonjour,
    Est ce que vous avez pu trouver la solution à ce problème parce que j'ai le même soucis.

    Comment


    • #3
      Hi,
      I got problem on running my poller on a distributed architecture with a deported DB, fresh install.
      The poller communicates with the central

      192.168.10.4:56924 192.168.10.2:5669 ESTABLISHED 1630/centengine
      192.168.10.2:5669 192.168.10.4:56924 ESTABLISHED 3996/cbd

      here is my poller-module.xml



      [root@SRVSUPREC3 centreon-engine]# cat /etc/centreon-broker/poller-module.xml

      Thank you in advance if you can help
      Attached Files

      Comment

      Working...
      X