Announcement

Collapse
No announcement yet.

Web Interface very slow

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Web Interface very slow

    I have installed CES 3.2 in a octa-core machine with 8 gb ram. At the beginning, everything was working fine, but times after configure 50 hosts and 250 services the speed of certain things are going very slow. While one page is generating nothing else will generate either, so I am forced to wait for one page at a time while configuring hosts/services/ACL.
    Clicking any host: Generated in 35 seconds
    Clicking any Service: Generated in 32 seconds
    Clicking any ACL: Generated in 33 seconds
    I have the centreon web on this octa-core machine and a poller on a dual core 2gb of ram.
    I've already removed ib_logfile1 and ib_logfile0 files and configured innodb_buffer_pool_size = 1000M but still not success. Anyone have some clue?

  • #2
    Hi,
    I installed CES3.2 in a VM. 4 core machine with 6 gb of ram.
    I have 272 hosts and 7419 servers and all is perfectly fast.

    Dunno why its slow like that.

    What about the load and the command top on your machine ?

    Comment


    • #3
      Looks all fine.. The monitoring it's all fine too, but it's very slow when i try to add new host/service or check a existing host/server..

      top - 12:03:00 up 21:27, 2 users, load average: 0.03, 0.08, 0.05
      Tasks: 200 total, 1 running, 199 sleeping, 0 stopped, 0 zombie
      Cpu(s): 0.8%us, 0.2%sy, 0.0%ni, 99.0%id, 0.0%wa, 0.0%hi, 0.0%si, 0.0%st
      Mem: 8060848k total, 1413280k used, 6647568k free, 125952k buffers
      Swap: 8208380k total, 0k used, 8208380k free, 482556k cached

      PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
      30113 apache 20 0 407m 19m 4248 S 2.7 0.3 0:00.69 httpd
      30114 apache 20 0 407m 20m 4284 S 2.0 0.3 0:00.77 httpd
      1748 mysql 20 0 1926m 401m 6904 S 1.7 5.1 25:45.49 mysqld
      1933 centreon 20 0 999m 43m 7772 S 1.3 0.5 13:38.17 cbd
      1903 centreon 20 0 555m 16m 7108 S 0.7 0.2 6:23.91 cbd
      25 root 20 0 0 0 0 S 0.3 0.0 0:00.96 ksoftirqd/5
      30176 root 20 0 15036 1296 936 R 0.3 0.0 0:00.07 top
      1 root 20 0 19364 1548 1232 S 0.0 0.0 0:01.68 init
      2 root 20 0 0 0 0 S 0.0 0.0 0:00.03 kthreadd
      3 root RT 0 0 0 0 S 0.0 0.0 0:00.23 migration/0
      4 root 20 0 0 0 0 S 0.0 0.0 0:01.13 ksoftirqd/0
      5 root RT 0 0 0 0 S 0.0 0.0 0:00.00 stopper/0
      6 root RT 0 0 0 0 S 0.0 0.0 0:00.18 watchdog/0
      7 root RT 0 0 0 0 S 0.0 0.0 0:00.27 migration/1
      8 root RT 0 0 0 0 S 0.0 0.0 0:00.00 stopper/1
      9 root 20 0 0 0 0 S 0.0 0.0 0:00.79 ksoftirqd/1
      10 root RT 0 0 0 0 S 0.0 0.0 0:00.14 watchdog/1

      Comment


      • #4
        Those times increased to more than 1 minute and i figured out on page requests that ajaxStatusCounter.js.php is the file that is consuming all those time to get load...

        Comment


        • #5
          Problem solved. The LDAP configuration was pointing to the old server (offline server), when i changed to the new server (online server) everything worked fine.

          Comment


          • #6
            Hi,
            I have the same exact issue. It is only when I go to the description of hosts / services / reload a config that it is super slow and one page blocks another. How did you find out that it was that ajax script being slow and got to the LDAP configuration pointing to the wrong server ?
            Thanks

            Comment


            • #7
              OMG Nevermind. The old domain controller got shutdown a while back. Never disabled it on centreon. You da Man xSlayper. One hell of a find. Still curious how you got from slow to the ajax page to the ldap if you can spare the time

              Comment


              • #8
                I have the same issue but the domain controller is reachable in my LDAP config...

                Comment

                Working...
                X