No announcement yet.

[NEWBIE] No templates, no check commands in fresh install

  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    anyone any advice on this? Still can't install the plugins.



    • #17

      I had the same problem.
      I found that you need to enable 'centreon-license-manager' extension too.

      Go to 'Administration - Extensions'
      Install 'centreon-license-manager' and install 'centreon-pp-manager' too.
      Then go to 'Configuration - Plugin Pack' to install generic pack for exemple...


      • #18

        I will have succeeded doing these things:
        to 'Administration - Extensions' install 'centreon-license-manager' and install 'centreon-pp-manager'
        and then doing the procedure has to be done when the configuration changes:
        go to Configuration ==> Poller
        click on Export

        and after I have appeared plugins !!!!

        Best Regards


        • #19
          What a joke, this isn't available on free version that I can see. From the looks of this post, it's commercial installations that have the plugin pack manager.
          I've had to go back to an old 2.7.8 server and use the centreon CLAPI to export the config and copy out the CMD: lines and import it into the new server. Like this would be available to a first time installation user.
          Either they are pushing to commercialize the product or have forgotten to put this plugin manager as a download for the free installations, I think the former due to the license required.

          Update: For those with fresh installs, use the centreon API import command and you can load my commands attached. I have tried to remove my personal checks and don't think I've broken the format so should load with the Web UI CLAPI command as per example below (your web ui path will be different if not compiled from source).

          # /usr/local/centreon/bin/centreon -uadmin -padmin -i centreon_commands_export.txt

          Attached Files
          Last edited by djtremors; 3 April 2017, 01:52.


          • #20
            Hello Sirs,
            Then, can we say that Support Subscription is mandatory to have plugins?


            • #21
              Hi all,
              I'm encountering the same issues, I am running on a distant server (on Debian Jessie) and had to download all packages/rebuild (fix tonnes of stuff) to get my Centreon up and running and see the same issue with the plugins. I don't have the plugin manager, it's not available for download, so my installation is pretty much unusable. Looks like I've wasted my time. If anyone has an idea I'd be very grateful!


              • #22
                With a Debian installation you cannot install the plugins pack, you have to configure it manually. On my website you will find some configuration examples (chapter 8.4 sorry in french
                Visiter mon site perso


                • #23
                  Administration > Extensions > Modules > centreon-pp-manager
                  Configuration > Plugin Packs > Manager
                  Install :
                  Linux SNMP
                  Windows SNMP

                  CentOS 5.5 x64 / Nagios 3.2.2 / Centreon 2.1.10
                  Monitoring: 467 Hosts / 2109Services 16th Server
                  NdoUtils 1.49,NagiosPlugins 1.4.14, NagVis 1.5.1, Distributed Architeture(howto)

                  Nagios/Centreon Custom Scripts / Troubleshooting


                  • #24
                    Hi, I am also trying to set up Centreon on a allready running CentOS, without internet connection, using only the ISO. But I can't "activate any plugin. I've already tried all the method I saw on this post but none of them is working for me.