Announcement

Collapse
No announcement yet.

Version 2.8.5 - Hostgroup and Servicegroup

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Version 2.8.5 - Hostgroup and Servicegroup

    Hello Upgraded to 2.8.5.

    Since then, If I add a Hostgroup or a Servicegroup, the name field is getting mangled. Example "This is a long name" gets mangled to "his_is__n_ne".

    I have many existing ones and if I edit them, the same happens.

    Is there a fix for this?

  • #2
    I have been doing some digging...

    It looks like there is an issue with a function called checkIllegalChar().


    There are three versions of this function:

    ./class/centreonService.class.php
    public function checkIllegalChar($name)
    ./class/centreon.class.php
    public function checkIllegalChar($name)
    ./class/centreonHost.class.php
    public function checkIllegalChar($host_name, $poller_id = null)

    If I comment the call in './include/configuration/configObject/hostgroup/DB-Func.php', everything for hostgroup now works as expected.
    I am sure this is a bad way to correct the issue. It was just a test to find it.

    I will check the code for these functions against an older release to see if they changed, but my guess is the data in the table is incorrect. It is certainly
    inconsistent.

    Any help or guidance that someone can supply would be great.

    Comment


    • #3
      After digging, I did the following to fix...

      update cfg_nagios set illegal_object_name_chars="~!$%^&*"|&#039 ;<>?,()=" where nagios_id > 1;

      It looks like the illegalChar fix #4931 is either wrong or incomplete for release 2.8.5

      Comment


      • #4
        Hello,

        Got something very similar with 2.8.4

        https://forum.centreon.com/forum/cen...saved-in-forms

        Finaly not only in templates form. I have just tried hostgroup form with the same result

        Same problem if I edit existing reccords

        Comment

        Working...
        X