Announcement

Collapse
No announcement yet.

Ghost Entries

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Ghost Entries

    Hello!

    I have a problem, that some hosts and services after deleting and recreating (same name) but with another poller still stay visible an are generating error messages. How can I completely remove these entries?
    When I try to open up an service or host through the interface, I geht this message:
    centreon_error.PNG
    And my configuration has already been reloaded uncounted times because I have another hosts and services which are added nearly every day.

    Is anyone able to help me.

    Thank you very much!


    Best regards
    Michael

  • #2
    Me too!!

    Services Returning from the Dead!

    First I thought I was going crazy but I confirmed it today!

    To reproduce the problem I did:
    1. Delete a service
    2. Check the DB service is gone
    3. Check in the web interface service is gone
    4. after about 5m, service shows up again in the web!!! But not in the database.
    5. Restarted the Pooler (service is gone)
    6. After about 5m, service shows up again in the web!!! But not in the database.

    I know its not a brower cache because its even sending e-mails!
    I tried with centreon CLAPI and its not there!

    What is going on here? PLEASE HELP US OUT



    Centos 6 x64
    centreon-2.7.11-8.el6.noarch
    centreon-base-config-centreon-engine-2.7.11-8.el6.noarch
    centreon-broker-2.11.8-2.el6.x86_64
    centreon-broker-cbd-2.11.8-2.el6.x86_64
    centreon-broker-cbmod-2.11.8-2.el6.x86_64
    centreon-broker-core-2.11.8-2.el6.x86_64
    centreon-broker-storage-2.11.8-2.el6.x86_64
    centreon-clib-1.4.2-1.el6.x86_64
    centreon-common-2.7.11-8.el6.noarch
    centreon-connector-1.1.2-1.el6.x86_64
    centreon-connector-perl-1.1.2-1.el6.x86_64
    centreon-connector-ssh-1.1.2-1.el6.x86_64
    centreon-engine-1.5.3-1.el6.x86_64
    centreon-engine-daemon-1.5.3-1.el6.x86_64
    centreon-engine-extcommands-1.5.3-1.el6.x86_64
    centreon-nagvis-1.1.1-3.el6.noarch
    centreon-perl-libs-2.7.11-8.el6.noarch
    centreon-plugin-meta-2.7.11-8.el6.noarch
    centreon-plugins-2.7.11-8.el6.noarch
    centreon-trap-2.7.11-8.el6.noarch
    centreon-web-2.7.11-8.el6.noarch
    centreon-widget-graph-monitoring-1.3.0-3.el6.noarch
    centreon-widget-hostgroup-monitoring-1.5.0-1.el6.noarch
    centreon-widget-host-monitoring-1.5.2-1.el6.noarch
    centreon-widget-servicegroup-monitoring-1.5.0-2.el6.noarch
    centreon-widget-service-monitoring-1.5.3-2.el6.noarch
    ________________________________________
    CentOS 5.5 x64 / Nagios 3.2.2 / Centreon 2.1.10
    Monitoring: 467 Hosts / 2109Services 16th Server
    NdoUtils 1.49,NagiosPlugins 1.4.14, NagVis 1.5.1, Distributed Architeture(howto)

    Nagios/Centreon Custom Scripts / Troubleshooting
    www.felipeferreira.net

    Comment


    • #3
      I confirm, the ghosts come and go! Really scared now
      ________________________________________
      CentOS 5.5 x64 / Nagios 3.2.2 / Centreon 2.1.10
      Monitoring: 467 Hosts / 2109Services 16th Server
      NdoUtils 1.49,NagiosPlugins 1.4.14, NagVis 1.5.1, Distributed Architeture(howto)

      Nagios/Centreon Custom Scripts / Troubleshooting
      www.felipeferreira.net

      Comment


      • #4
        i just updated to latest 2.8.14 seems that ghosts are dead now
        ________________________________________
        CentOS 5.5 x64 / Nagios 3.2.2 / Centreon 2.1.10
        Monitoring: 467 Hosts / 2109Services 16th Server
        NdoUtils 1.49,NagiosPlugins 1.4.14, NagVis 1.5.1, Distributed Architeture(howto)

        Nagios/Centreon Custom Scripts / Troubleshooting
        www.felipeferreira.net

        Comment


        • #5
          its still doing it...
          I change a service, restart and it does not take the change!

          what could it be?

          please help me
          ________________________________________
          CentOS 5.5 x64 / Nagios 3.2.2 / Centreon 2.1.10
          Monitoring: 467 Hosts / 2109Services 16th Server
          NdoUtils 1.49,NagiosPlugins 1.4.14, NagVis 1.5.1, Distributed Architeture(howto)

          Nagios/Centreon Custom Scripts / Troubleshooting
          www.felipeferreira.net

          Comment


          • #6
            i restarted from command line all services then it seem to take the change.. but i cannot go on like this.
            ________________________________________
            CentOS 5.5 x64 / Nagios 3.2.2 / Centreon 2.1.10
            Monitoring: 467 Hosts / 2109Services 16th Server
            NdoUtils 1.49,NagiosPlugins 1.4.14, NagVis 1.5.1, Distributed Architeture(howto)

            Nagios/Centreon Custom Scripts / Troubleshooting
            www.felipeferreira.net

            Comment


            • #7
              Restarting manually all servies did the trick. BUT there is still one ghost host left. Before there has been 3. Now there is one left.

              Comment

              Working...
              X