Announcement

Collapse
No announcement yet.

Widgets version 18.10.0 not working (no results returned)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Widgets version 18.10.0 not working (no results returned)

    Hello,

    I've just performed a deployment of CES 3.4 in it's latest version from sources and after downloading and configuring widgets, they return no information even there are some services down.

    My Centreon version:
    Webinterface : 2.8.26
    Centengine: 1.8.1

    I found some error in apache logs regarding this issue:

    For tactical overview, here are the errors shown:
    Code:
    [Wed Oct 31 04:59:07.392088 2018] [:error] [pid 83258] [client x.x.x.x:21764] PHP Fatal error:  Class 'Smarty' not found in /usr/share/centreon/www/widgets/hostgroup-monitoring/index.php on line 63, referer: http://x.x.x.x/centreon/main.php?p=103
    [Wed Oct 31 04:59:07.395387 2018] [:error] [pid 127651] [client x.x.x.x:21766] PHP Fatal error:  Class 'Smarty' not found in /usr/share/centreon/www/widgets/hostgroup-monitoring/index.php on line 63, referer: http://x.x.x.x/centreon/main.php?p=103
    Here are errors raised for service-monitoring:
    Code:
    [Wed Oct 31 05:00:08.428746 2018] [:error] [pid 2713] [client x.x.x.x:21837] PHP Warning:  require_once(/usr/share/centreon/bootstrap.php): failed to open stream: No such file or directory in /usr/share/centreon/www/widgets/service-monitoring/index.php on line 37, referer: http://x.x.x.x/centreon/main.php?p=103
    [Wed Oct 31 05:00:08.428776 2018] [:error] [pid 2713] [client x.x.x.x:21837] PHP Fatal error:  require_once(): Failed opening required '/usr/share/centreon/bootstrap.php' (include_path='.:/usr/share/pear:/usr/share/php') in /usr/share/centreon/www/widgets/service-monitoring/index.php on line 37, referer: http://x.x.x.x/centreon/main.php?p=103
    [Wed Oct 31 05:00:08.429099 2018] [:error] [pid 127651] [client x.x.x.x:21836] PHP Warning:  require_once(/usr/share/centreon/bootstrap.php): failed to open stream: No such file or directory in /usr/share/centreon/www/widgets/service-monitoring/index.php on line 37, referer: http://x.x.x.x/centreon/main.php?p=103
    [Wed Oct 31 05:00:08.429123 2018] [:error] [pid 127651] [client x.x.x.x:21836] PHP Fatal error:  require_once(): Failed opening required '/usr/share/centreon/bootstrap.php' (include_path='.:/usr/share/pear:/usr/share/php') in /usr/share/centreon/www/widgets/service-monitoring/index.php on line 37, referer: http://x.x.x.x/centreon/main.php?p=103
    And these are for host-monitoring:
    Code:
    [Wed Oct 31 05:02:41.648894 2018] [:error] [pid 83258] [client x.x.x.x:22008] PHP Warning:  require_once(/usr/share/centreon/bootstrap.php): failed to open stream: No such file or directory in /usr/share/centreon/www/widgets/host-monitoring/index.php on line 37, referer: http://x.x.x.x/centreon/main.php?p=103
    [Wed Oct 31 05:02:41.648930 2018] [:error] [pid 83258] [client x.x.x.x:22008] PHP Fatal error:  require_once(): Failed opening required '/usr/share/centreon/bootstrap.php' (include_path='.:/usr/share/pear:/usr/share/php') in /usr/share/centreon/www/widgets/host-monitoring/index.php on line 37, referer: http://x.x.x.x/centreon/main.php?p=103
    Has anyone faced this issue already or have a clue about a missing dependency I might have forgot to deploy during installation?

    Please note that the rest of the application is working properly from my tests so far.

    Thanks in advance for your help

  • #2
    Hi everyone,

    Any idea or suggestion regarding this issue?

    I face a similar issue also with GLPI/Centreon plugin which trying to access a bootstrap.php which is not existing.
    Code:
    require_once(/usr/share/centreon/bootstrap.php)
    One of my thought when seeing such similar issue for several components which are identified as working is the package version of Centreon is missing a dependency or part of the installation.

    And to be clear, I cannot use Centreon ISO as I'M working on a network isolated environments.

    Any help would be welcome.

    Thanks.

    Comment


    • #3
      Ok, finally figured out the version of the modules are for latest version of centreon.

      My bad, I though I had performed latest upgrades.

      Comment

      Working...
      X