Announcement

Collapse
No announcement yet.

Reporting and timezone => No data if the user is ahead of the server

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Reporting and timezone => No data if the user is ahead of the server

    Hi;

    I got the following issue:
    - The dashboard builder runs everyday at 06:00am (default Cron setting)
    - The servers and the multiple pollers are all set to GMT regardless of their real timezone
    - the user trying to access the reporting us also set to GMT in centreon settings but is really working at GMT+11 (Australia)

    As a result, the reporting is consistent until 11am GMT+11 every day (12am GMT) and the displays no data until the dashboard builder has run (6 hours later). On the next day It's displayed as expected.
    I am considering changing the cron to tun at 00:01am GMT (ans shortening the window during which the reporting is blank) but when I changed the timezones on the poller I ended up with availability ratings over 100% (as the data was integrated twice).

    I need some guidance regarding the best practice when your pollers and central are in different timezones. In Australia we are ahead of GMT by almost half a day so that might not be the best choice. Any documentation on that?

    How can I "clean" the dashboard on the day I changed the timezone (dual sets of values resulting in some weird negative percentages)?


    Regards;
    Jeremie


    PS: vous pouvez aussi me repondre en francais.
    Last edited by sanmoi; 1 week ago.
Working...
X