Announcement

Collapse
No announcement yet.

Centreon web 18.10.3 - No output returned from plugin

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Centreon web 18.10.3 - No output returned from plugin

    Bonjour,

    J'ai installé un nouveau serveur en 18.10.3, et je veux monitorer des AS400 via un plugin nommé check_as400 (déjà utilisé sur CES 3.3 et 3.4)

    Lorsque je teste le plugin en ligne de commande, il fonctionne correctement (en root, centreon et centreon-engine)

    sudo -u centreon-engine /usr/lib64/nagios/plugins/check_as400 -H 192.168.2.109 -v DISK
    OK - ACTIVE:0, FAILED:No, BUSY:No, DEGRADED:No, HDW FAIL:No, PWR-LOSS:No


    Lorsque je crée le service dans Centreon Web et que je teste, ça fonctionne également

    centreon2.jpg

    Lorsque j'applique la configuration du poller, j'ai systématiquement le message "No outpout returned from plugin"


    centreon1.jpg

    plugin check_as400

    USER=`cat /usr/lib64/nagios/plugins/.as400 |grep -e USER | cut -d = -f 2`
    PASS=`cat /usr/lib64/nagios/plugins/.as400 |grep -e PASS | cut -d = -f 2`
    java -cp /usr/lib64/nagios/plugins check_as400 -u $USER -p $PASS $*

    Exemple du plugin Check_as400 sur un Centreon 2.8.26

    centreon3.jpg


    Les droits sur le plugin sont identiques sur les 2 serveurs. Reste JAVA???

    Je ne sais plus quoi regarder.
    Attached Files

  • #2
    Bonjour,

    Je viens de migrer sur Centreon 18.10.3 et le j'ai le même problème avec le check_as400.

    1) Le check fonctionne très bien en mode de commande user root ou centreon

    /usr/lib/nagios/plugins/check_as400/check_as400 -H 192.168.1.110 -v DISK -w 85 -c 95 --help
    OK - ACTIVE:0, FAILED:No, BUSY:No, DEGRADED:No, HDW FAIL:No, PWR-LOSS:No


    2) Le test de la sonde fonctionne correctement via l'interface web

    centreon_as400_problem_1_20190306.jpg

    3) Une fois le plugin généré dans le poller on reçoit l'erreur "No output returned from plugin"

    centreon_as400_problem_2_20190306.jpg





    Attached Files

    Comment


    • #3
      Bonjour à tous,
      j'ai le même problème avec check_ilo2_health écrit en perl...

      Comment

      Working...
      X