Announcement

Collapse
No announcement yet.

Installation de centreon broker par le package

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Installation de centreon broker par le package

    Bonjour,

    J'essaye d'installer centreon broker par le package mais lors de la recherche des dépendances de tombe sur cette erreur

    [[email protected] install]# yum install centreon-broker centreon-broker-core centreon-broker-cbd centreon-broker-cbmod centreon-broker-storage
    Loaded plugins: fastestmirror, security
    Loading mirror speeds from cached hostfile
    * base: mirror.in2p3.fr
    * extras: centos.mirror.crcrepairs.com
    * updates: mirror.ovh.net
    Setting up Install Process
    Resolving Dependencies
    --> Running transaction check
    ---> Package centreon-broker.x86_64 0:2.6.2-1.el5.centos will be installed
    --> Processing Dependency: qt4-mysql >= 4.7.4 for package: centreon-broker-2.6.2-1.el5.centos.x86_64
    --> Processing Dependency: qt4 >= 4.7.4 for package: centreon-broker-2.6.2-1.el5.centos.x86_64
    --> Processing Dependency: centreon-common >= 2.4.5 for package: centreon-broker-2.6.2-1.el5.centos.x86_64
    ---> Package centreon-broker-cbd.x86_64 0:2.6.2-1.el5.centos will be installed
    ---> Package centreon-broker-cbmod.x86_64 0:2.6.2-1.el5.centos will be installed
    ---> Package centreon-broker-core.x86_64 0:2.6.2-1.el5.centos will be installed
    --> Processing Dependency: compat-gnutls2 for package: centreon-broker-core-2.6.2-1.el5.centos.x86_64
    --> Processing Dependency: openssl-devel for package: centreon-broker-core-2.6.2-1.el5.centos.x86_64
    ---> Package centreon-broker-storage.x86_64 0:2.6.2-1.el5.centos will be installed
    --> Processing Dependency: librrd.so.4()(64bit) for package: centreon-broker-storage-2.6.2-1.el5.centos.x86_64
    --> Running transaction check
    ---> Package centreon-common.noarch 0:2.5.1-1.el5.centos will be installed
    --> Processing Dependency: nagios-plugins for package: centreon-common-2.5.1-1.el5.centos.noarch
    ---> Package compat-gnutls2.x86_64 0:2.8.5-2.1.el5.art will be installed
    ---> Package openssl-devel.x86_64 0:1.0.1e-16.el6_5.14 will be installed
    --> Processing Dependency: openssl = 1.0.1e-16.el6_5.14 for package: openssl-devel-1.0.1e-16.el6_5.14.x86_64
    --> Processing Dependency: zlib-devel for package: openssl-devel-1.0.1e-16.el6_5.14.x86_64
    --> Processing Dependency: krb5-devel for package: openssl-devel-1.0.1e-16.el6_5.14.x86_64
    ---> Package qt4.x86_64 0:4.7.4-0 will be installed
    ---> Package qt4-mysql.x86_64 0:4.7.4-0 will be installed
    --> Processing Dependency: libmysqlclient_r.so.15(libmysqlclient_15)(64bit) for package: qt4-mysql-4.7.4-0.x86_64
    --> Processing Dependency: libcrypto.so.6()(64bit) for package: qt4-mysql-4.7.4-0.x86_64
    --> Processing Dependency: libmysqlclient_r.so.15()(64bit) for package: qt4-mysql-4.7.4-0.x86_64
    --> Processing Dependency: libssl.so.6()(64bit) for package: qt4-mysql-4.7.4-0.x86_64
    ---> Package rrdtool.x86_64 0:1.4.7-1.el5.rf will be installed
    --> Processing Dependency: perl(RRDp) for package: rrdtool-1.4.7-1.el5.rf.x86_64
    --> Processing Dependency: ruby for package: rrdtool-1.4.7-1.el5.rf.x86_64
    --> Processing Dependency: perl(RRDs) for package: rrdtool-1.4.7-1.el5.rf.x86_64
    --> Processing Dependency: libdbi.so.0()(64bit) for package: rrdtool-1.4.7-1.el5.rf.x86_64
    --> Running transaction check
    ---> Package krb5-devel.x86_64 0:1.10.3-15.el6_5.1 will be installed
    --> Processing Dependency: krb5-libs = 1.10.3-15.el6_5.1 for package: krb5-devel-1.10.3-15.el6_5.1.x86_64
    --> Processing Dependency: libselinux-devel for package: krb5-devel-1.10.3-15.el6_5.1.x86_64
    --> Processing Dependency: libcom_err-devel for package: krb5-devel-1.10.3-15.el6_5.1.x86_64
    --> Processing Dependency: keyutils-libs-devel for package: krb5-devel-1.10.3-15.el6_5.1.x86_64
    ---> Package libdbi.x86_64 0:0.8.3-4.el6 will be installed
    ---> Package mysqlclient15.x86_64 0:5.0.67-1.el5.remi will be installed
    ---> Package nagios-plugins.x86_64 0:1.4.16-6.el5.centos will be installed
    --> Processing Dependency: perl(Net::SNMP) for package: nagios-plugins-1.4.16-6.el5.centos.x86_64
    --> Processing Dependency: libmysqlclient.so.18(libmysqlclient_16)(64bit) for package: nagios-plugins-1.4.16-6.el5.centos.x86_64
    --> Processing Dependency: nagios-plugins-perl for package: nagios-plugins-1.4.16-6.el5.centos.x86_64
    --> Processing Dependency: libldap-2.3.so.0()(64bit) for package: nagios-plugins-1.4.16-6.el5.centos.x86_64
    --> Processing Dependency: liblber-2.3.so.0()(64bit) for package: nagios-plugins-1.4.16-6.el5.centos.x86_64
    --> Processing Dependency: libpq.so.4()(64bit) for package: nagios-plugins-1.4.16-6.el5.centos.x86_64
    --> Processing Dependency: libmysqlclient.so.18()(64bit) for package: nagios-plugins-1.4.16-6.el5.centos.x86_64
    ---> Package openssl.x86_64 0:1.0.1e-15.el6 will be updated
    ---> Package openssl.x86_64 0:1.0.1e-16.el6_5.14 will be an update
    ---> Package openssl098e.x86_64 0:0.9.8e-18.el6_5.2 will be installed
    ---> Package perl-rrdtool.x86_64 0:1.4.7-1.el5.rf will be installed
    ---> Package ruby.x86_64 0:1.8.7.352-13.el6 will be installed
    --> Processing Dependency: ruby-libs = 1.8.7.352-13.el6 for package: ruby-1.8.7.352-13.el6.x86_64
    --> Processing Dependency: libruby.so.1.8()(64bit) for package: ruby-1.8.7.352-13.el6.x86_64
    ---> Package zlib-devel.x86_64 0:1.2.3-29.el6 will be installed
    --> Running transaction check
    ---> Package compat-openldap.x86_64 1:2.3.43-2.el6 will be installed
    ---> Package keyutils-libs-devel.x86_64 0:1.4-4.el6 will be installed
    ---> Package krb5-libs.x86_64 0:1.10.3-10.el6_4.6 will be updated
    --> Processing Dependency: krb5-libs = 1.10.3-10.el6_4.6 for package: krb5-workstation-1.10.3-10.el6_4.6.x86_64
    ---> Package krb5-libs.x86_64 0:1.10.3-15.el6_5.1 will be an update
    ---> Package libcom_err-devel.x86_64 0:1.41.12-18.el6 will be installed
    ---> Package libselinux-devel.x86_64 0:2.0.94-5.3.el6_4.1 will be installed
    --> Processing Dependency: libsepol-devel >= 2.0.32-1 for package: libselinux-devel-2.0.94-5.3.el6_4.1.x86_64
    --> Processing Dependency: pkgconfig(libsepol) for package: libselinux-devel-2.0.94-5.3.el6_4.1.x86_64
    ---> Package mysql-libs.x86_64 0:5.1.71-1.el6 will be updated
    --> Processing Dependency: libmysqlclient.so.16()(64bit) for package: 2ostfix-2.6.6-2.2.el6_1.x86_64
    --> Processing Dependency: libmysqlclient.so.16(libmysqlclient_16)(64bit) for package: 2ostfix-2.6.6-2.2.el6_1.x86_64
    ---> Package mysql-libs.x86_64 0:5.5.34-1.el5.remi will be an update
    --> Processing Dependency: mysql = 5.5.34-1.el5.remi for package: mysql-libs-5.5.34-1.el5.remi.x86_64
    ---> Package nagios-plugins.x86_64 0:1.4.16-6.el5.centos will be installed
    --> Processing Dependency: libpq.so.4()(64bit) for package: nagios-plugins-1.4.16-6.el5.centos.x86_64
    ---> Package nagios-plugins-perl.x86_64 0:1.4.16-6.el5.centos will be installed
    ---> Package perl-Net-SNMP.noarch 0:5.2.0-1.2.el5.rf will be installed
    --> Processing Dependency: perl(Socket6) >= 0.19 for package: perl-Net-SNMP-5.2.0-1.2.el5.rf.noarch
    --> Processing Dependency: perl(Digest::HMAC) for package: perl-Net-SNMP-5.2.0-1.2.el5.rf.noarch
    --> Processing Dependency: perl(Crypt:ES) for package: perl-Net-SNMP-5.2.0-1.2.el5.rf.noarch
    --> Processing Dependency: perl(Digest::SHA1) for package: perl-Net-SNMP-5.2.0-1.2.el5.rf.noarch
    ---> Package ruby-libs.x86_64 0:1.8.7.352-13.el6 will be installed
    --> Processing Dependency: libreadline.so.5()(64bit) for package: ruby-libs-1.8.7.352-13.el6.x86_64
    --> Running transaction check
    ---> Package compat-readline5.x86_64 0:5.2-17.1.el6 will be installed
    ---> Package krb5-workstation.x86_64 0:1.10.3-10.el6_4.6 will be updated
    ---> Package krb5-workstation.x86_64 0:1.10.3-15.el6_5.1 will be an update
    ---> Package libsepol-devel.x86_64 0:2.0.41-4.el6 will be installed
    ---> Package mysql.x86_64 0:5.5.34-1.el5.remi will be installed
    ---> Package nagios-plugins.x86_64 0:1.4.16-6.el5.centos will be installed
    --> Processing Dependency: libpq.so.4()(64bit) for package: nagios-plugins-1.4.16-6.el5.centos.x86_64
    ---> Package perl-Crypt-DES.x86_64 0:2.05-3.2.el5.rf will be installed
    ---> Package perl-Digest-HMAC.noarch 0:1.01-22.el6 will be installed
    ---> Package perl-Digest-SHA1.x86_64 0:2.12-2.el6 will be installed
    ---> Package perl-Socket6.x86_64 0:0.23-4.el6 will be installed
    ---> Package postfix.x86_64 2:2.6.6-2.2.el6_1 will be updated
    ---> Package postfix.x86_64 2:2.6.6-6.el6_5 will be an update
    --> Finished Dependency Resolution
    Error: Package: nagios-plugins-1.4.16-6.el5.centos.x86_64 (ces-standard-deps)
    Requires: libpq.so.4()(64bit)
    You could try using --skip-broken to work around the problem
    You could try running: rpm -Va --nofiles --nodigest


    Que dois je faire pour solutionner ce problème ?

    Merci

  • #2
    Bonjour,


    Peux tu faire un yum repolist pour voir les dépôts présents et actifs sur ton serveur ?

    Tu peux utiliser aussi la commande yum whatprovides */libpq.so.4 pour voir si yum trouve un paquet avec ce fichier dans les dépôts.


    Cordialement

    Comment

    Working...
    X