Announcement

Collapse
No announcement yet.

missing servicegroups.cfg and services.cfg only containing header in one poller

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • missing servicegroups.cfg and services.cfg only containing header in one poller

    I did a mass change to simply associate a different command on a set of services. Now when I generate nagios configuration files under filesGenerated/1 it manages to create all files except for servicegroups.cfg and the services.cfg file what was 620k is now only 1k containing just the header. I have two other pollers and the services.cfg file are generating just fine there in directories 2/ and 3/.

    When I select the option to generate files from Configuration->Monitoring Engines it gets as far as:

    Preparing environment... OK
    Generating files...

    And no further. No NOK or OK. Does anyone know how to troubleshoot this or cure it?
    Last edited by art96; 7 January 2015, 01:34.

  • #2
    Originally posted by art96 View Post
    I did a mass change to simply associate a different command on a set of services. Now when I generate nagios configuration files under filesGenerated/1 it manages to create all files except for servicegroups.cfg and the services.cfg file what was 620k is now only 1k containing just the header. I have two other pollers and the services.cfg file are generating just fine there in directories 2/ and 3/.

    When I select the option to generate files from Configuration->Monitoring Engines it gets as far as:

    Preparing environment... OK
    Generating files...

    And no further. No NOK or OK. Does anyone know how to troubleshoot this or cure it?
    I think my issue was due to:

    #5924: Generation of service configuration files does not work when “service_inherit_contacts_from_host” is not enabled

    Upgrading to 2.5.4 resolved the issue.

    Comment

    Working...
    X