Announcement

Collapse
No announcement yet.

Nagios 2.6 & Oreon 2.3.3

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Nagios 2.6 & Oreon 2.3.3

    Bonjour tout le monde, je vous explique mon problème.
    J'ai installé sous Debian ETCH nagios 2.6 via apt-get install
    Nagios fonctionne, j'arrive à accéder, la passerelle apparait dans les hosts donc j'en conclu que ca fonctionne.
    Ensuite j'ai décidé d'installer Oreon 2.3.3 , l'install se passe tres bien , j'arrive à me loger.
    Puis je crée des users, groupusers, host et viens le moment de générer remplacer et rédémarrer nagios via Oreon.

    Mais j'ai un souci , Oreon dit qu'il y a pas de probleme. Mais quand je vais sous la console , j'arrive pas à redémarre le service init.d/nagios2 .

    Selon vous, c'est quoi le problème que j'ai?

    Nagios 2.6 compatible avec Oreon 2.3.3 hock: hock:

  • #2
    peut être que cela est du au '2' de ton /etc/init.d/nagios2

    je dis ca comme ca j'en sais pas plus mais c'est peut etre une piste, essai de le renomer en nagios...

    Oreon-DevTeam

    Comment


    • #3
      Nous avons cette commande ecrite en dur "/etc/init.d/nagios restart", le prob est que toi c nagios2.

      La solution revient a modifier le fichier :
      oreon/www/include/configuration/configGenerate/formGeneratefiles.php aux lignes 171 et 173.
      Romain Le Merlus
      Centreon Forge
      MERETHIS

      Comment


      • #4
        Merci , j'ai trouvé le problème alors:
        - La configuration de CGI.CFG sous Oreon ne prend pas en compte la commande check_nagios (quand je faisais /etc/init.d/nagios2 restart, ca disait que ca manquer dans le fichier CGI.CFG) , c'est pour cela il faut aller modifier manuellement le fichier et ajouter à la mano cette ligne:

        nagios_check_command=/usr/lib/nagios/plugins/check_nagios
        /var/cache/nagios2/status.dat 5 '/usr/sbin/nagios2'

        PS: Si ca peut aider une personne!!

        J'ai un autre souci, c'est que j'ai un problème avec la base PERFPARSE, ca me dit : "Problème avec la base Perfparse : DB Error: connect failed"


        Quelqu'un a déja eu ce problème????

        Comment


        • #5
          Originally posted by LAW
          Merci , j'ai trouvé le problème alors:
          - La configuration de CGI.CFG sous Oreon ne prend pas en compte la commande check_nagios (quand je faisais /etc/init.d/nagios2 restart, ca disait que ca manquer dans le fichier CGI.CFG) , c'est pour cela il faut aller modifier manuellement le fichier et ajouter à la mano cette ligne:

          nagios_check_command=/usr/lib/nagios/plugins/check_nagios
          /var/cache/nagios2/status.dat 5 '/usr/sbin/nagios2'

          PS: Si ca peut aider une personne!!
          Tu devrais ouvrir un bugtrack ici et là ça aidera des gens :wink: :
          http://bugs.oreon-project.org/
          Intel(R) Xeon(TM) CPU 3.4GHz - MemTotal : 1034476 kB
          Centreon 2.4.1 - Nagios 3.2.1 - Nagios Plugins 1.4.15 - Manubulon Plugins tuné
          Fedora Core 5 - 2.6.20-1.2320

          Comment

          Working...
          X