Announcement

Collapse
No announcement yet.

probleme oreon + nagios + nagvis

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • probleme oreon + nagios + nagvis

    Bonjour,

    Un petit problème avec l'utilisation de Nagvis.
    J'utilise Nagvis basé sur un HTML Backend.

    Au niveau d'oreon et de nagios, tous mes hosts dépendent du template généric_host.

    Dans generic_host , dans la partie "Status de l'Host", j'ai mis une commande de check : check-host-alive.

    Ensuite j'exporte pour Nagios, pas de probleme, sauf que j'ai les Warning qui me disent que j'ai pas de service associé à mes hosts.

    Coté monitoring (nagios et oreon), pas de probleme, mes host sont bien checké en temps et en heure.

    C'est coté Nagvis qu'il y a un probleme. le status de mes host n'arete pas de changer entre UP et ERROR (message : HTML-Backend GOT NON DATA From Cgi while tring to parse a host!)

    Vous me direz, ca n'a rien a faire sur un forum oreon. Mais la ou je comprend pas, c'est que lorsque j'ai un host avec un service associé (au hasard check_smtp), au niveau de Nagvis il capte toujours le status du host comme UP, tout bien comme il faut quoi.

    Donc le probleme, c'est qu'apperement Nagvis a du mal à récupéré les infos du status de l'host, lorsque ces infos ne viennent pas d'un service, mais de la partie "Status de l'Host".

    Est ce que quelqu'un peu m'aider s'il vous plait? Je trouverai dommage de devoir associer à chaque host un service check-host-alive, alors que c'est si bien fait dans le status de l'host.

    Merci d'avance

  • #2
    un petit up

    Comment


    • #3
      alors, personne ne peut me donner un petit coup de main? Ou au moins me donner une explication du probleme...

      Comment


      • #4
        Originally posted by kuroro View Post
        Bonjour,

        Un petit problème avec l'utilisation de Nagvis.
        J'utilise Nagvis basé sur un HTML Backend.

        Au niveau d'oreon et de nagios, tous mes hosts dépendent du template généric_host.

        Dans generic_host , dans la partie "Status de l'Host", j'ai mis une commande de check : check-host-alive.

        Ensuite j'exporte pour Nagios, pas de probleme, sauf que j'ai les Warning qui me disent que j'ai pas de service associé à mes hosts.

        Coté monitoring (nagios et oreon), pas de probleme, mes host sont bien checké en temps et en heure.

        C'est coté Nagvis qu'il y a un probleme. le status de mes host n'arete pas de changer entre UP et ERROR (message : HTML-Backend GOT NON DATA From Cgi while tring to parse a host!)

        Vous me direz, ca n'a rien a faire sur un forum oreon. Mais la ou je comprend pas, c'est que lorsque j'ai un host avec un service associé (au hasard check_smtp), au niveau de Nagvis il capte toujours le status du host comme UP, tout bien comme il faut quoi.

        Donc le probleme, c'est qu'apperement Nagvis a du mal à récupéré les infos du status de l'host, lorsque ces infos ne viennent pas d'un service, mais de la partie "Status de l'Host".

        Est ce que quelqu'un peu m'aider s'il vous plait? Je trouverai dommage de devoir associer à chaque host un service check-host-alive, alors que c'est si bien fait dans le status de l'host.

        Merci d'avance
        Selon la version de Nagios, tu peux aussi te baser sur NDO (version 2 uniquement).
        Raphaël 'SurcouF' Bordet
        Je ne teste pas mes plugins en root, tu ne testes pas tes plugins en root...
        Dons Paypal

        Comment


        • #5
          J'y ai réfléchi, et je ne souhaitais pas passer par NDO.
          Pas assez de documentation, et le fait d'avoir 2 BDD (1 oreon, 1 ndo) qui contienne les mêmes données me dérange un peu.
          Par ailleurs, en passant par du file ça fonctionne très bien, sauf ce petit problème...

          Comment

          Working...
          X