Announcement

Collapse
No announcement yet.

Impossible d'envoyer des mails

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Impossible d'envoyer des mails

    Bonjour je sais que le sujet à été traité de nombreuses fois mais je ne parvient pas à régler mon problème.

    Je suis sous nagios 2.5 et oreon et à la base le tout est installé sur une debian.

    J'ai configuré un serveur postfix à la place d'un serveur sendmail. L'envoi de mail marche très bien pour tous les utilisateurs de mon système: nagios, root ou autre.

    J'ai créé via oreon des utilisateurs avec des adresses emails valides, j'ai autorisé la notification via les commandes:host-notify-by-email-ng1 et notify-by-email-ng1

    J'ai coché dans l'utilisateur: pour les hosts: down, Unreachable, recovery.
    Période de notification pour les Hosts: 24*7

    De même pour les services: Critical et warning pour une période de 24*7

    Maintenant dans les hosts: sur le host choisi j'ai activé la notification. j'ai mis l'utilisateur dans le groupe qui sera notifié et j'ai coché down pour une période de 24*7 pour un intervalle de 5*60secondes

    Ensuite les services: de même que pour les host: activé la notification pour le groupe oü est présent mon utilisateur, coché critical et warning, durée: 1*60secondes, période de 24*7

    Je vérifie le tout, le copie dans les bons fichiers, relance nagios. Aucune erreur ne m'est communiquée sauf que lorsque le service devient "warning" je ne recois aucun mail. il n'est même pas indiqué dans mes logs de mail. Je suppose que la commande de notification ne marche pas

    host-notify-by-email-ng1:

    /usr/bin/printf "%b" "***** Oreon *****Notification\nType:$NOTIFICATIONTYPE$\n Host: $HOSTNAME$\nState: $HOSTSTATE$Address: $HOSTADDRESS$\nInfo: $OUTPUT$\nDate/Time: $DATETIME$" | @[email protected] -s "Host $HOSTSTATE$ alert for $HOSTNAME$!" $CONTACTEMAIL$

    dois-je mettre /usr/bin/mail plutôt que printf?

    Merci d'avance

  • #2
    Non , c'est plutot la config' de ton postfix qui est defaillante, je pense.
    Ci-dessous, une config opérationelle pour Postfix vers Microsoft Exchange

    /etc/postfix/main.cf
    Code:
    # See /usr/share/postfix/main.cf.dist for a commented, more complete version
    
    smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
    biff = no
    
    # appending .domain is the MUA's job.
    append_dot_mydomain = no
    
    # Uncomment the next line to generate "delayed mail" warnings
    #delay_warning_time = 4h
    
    myhostname = ma_machine.mon_domaine
    mydomain = mon_domaine
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    myorigin = /etc/mailname
    mydestination = $myhostname, localhost.$mydomain, $mydomain
    relayhost = [@IP-exchange]
    relay_domains = $mydomain
    transport_maps = hash:/etc/postfix/transport
    mynetworks = @IP_de_mon_réseau 127.0.0.0/8
    mailbox_command = procmail -a "$EXTENSION"
    mailbox_size_limit = 0
    recipient_delimiter = +
    inet_interfaces = all
    /etc/postfix/transport
    Code:
    mon_domaine      smtp:[@IP-exchange]

    Comment


    • #3
      Je ne possede pas de serveur exchange sur mon reseaux ( enfin je crois pas je suis stagiaire dans l'entreprise depuis 2jours) mais a ce que je vois dans les paramètres outlook des autres ordinateurs, ils se connectent directement chez le FAI pour récuperer les emails... donc je sais pas trop.

      Comment


      • #4
        je rectifie les messages passent bien dans mon postfix et voila ce que ca marque:
        Processus en cours:
        nagios 3281 0.3 0.8 2324 1060 ? S 11:12 0:00 sh -c /usr/bin/printf "%b" "***** Oreon *****\n\nNotification Type: PROBLEM\n\nService: user\nHost: Local\nAddress: 127.0.0.1\nState: WARNING\nDate/Time: $DATETIME$\n\nAdditional Info:\n\n$OUTPUT$" | /usr/bin/mail -s "** PROBLEM alert - Local/user is WARNING **" [email protected]
        nagios 3283 0.4 0.4 1616 592 ? S 11:12 0:00 /usr/bin/mail -s ** PROBLEM alert - Local/user is WARNING ** [email protected]
        nagios 3284 0.2 0.8 2952 1060 ? S 11:12 0:00 send-mail -i -- [email protected]

        Ou [email protected] est mon adresse!

        Dans les logs:

        Apr 11 11:36:33 localhost postfix/local[4607]: CF1745A7AF: to=<[email protected]>, relay=local, delay=0, status=sent (delivered to command: procmail -a "$EXTEN SION")
        Apr 11 11:36:33 localhost postfix/qmgr[4141]: DD1525A7B1: from=<>, size=2202, nr cpt=1 (queue active)
        Apr 11 11:36:33 localhost postfix/qmgr[4141]: 182C55A7B6: removed
        Apr 11 11:36:33 localhost postfix/qmgr[4141]: CF1745A7AF: removed
        Apr 11 11:36:33 localhost postfix/local[4278]: DD1525A7B1: to=<[email protected]>, relay=local, delay=0, status=sent (delivered to command: procmail -a "$EXTEN SION")
        Apr 11 11:36:34 localhost postfix/qmgr[4141]: DD1525A7B1: removed
        Apr 11 11:36:41 localhost postfix/local[4633]: 2B1135A7B8: to=<[email protected]>, relay=local, delay=8, status=sent (delivered to command: procmail -a "$EXTEN SION")
        Apr 11 11:36:41 localhost postfix/qmgr[4141]: 2B1135A7B8: removed


        Je viens de comprendre qu'il envoi le mail a l'utilisateur [email protected] et non aux adresses email indiquées des utilisateurs comme je l'ai dis precedemment.

        Comment


        • #5
          J'aurais une autre question, je teste en ce moment sur une debian virtuelle que je coupe assez souvent, lorsd du redemmarage de la machine tout se lance sauf que nagios ne se refraichie pas, il attend avant de reverifier, peut t on changer le temps entre chque rafraichissement?

          Comment


          • #6
            Bonjour,

            J'ai le meme probleme :
            Code:
            Apr 20 12:34:01 srv55 postfix/local[15871]: 6A6875E807C: to=<[email protected]>, orig_to=<nagios>, relay=local, delay=0.05, delays=0.03/0/0/0.01, dsn=2.0.0, status=sent (delivered to command: procmail -a "$EXTENSION")
            Apr 20 12:34:01 srv55 postfix/qmgr[15692]: 6A6875E807C: removed
            Pourtant mon utilisateur admin a qui les notifications sont normalement envoyée n'a pas cette adresse e-mail de configurée.

            Help me pleaze

            Merci

            Comment


            • #7
              Voici ma commande :
              Code:
              /usr/bin/printf  "%b" "*****Oreon*****Notification\nType:$NOTIFICATIONTYPE$\n Host: $HOSTNAME$\nState: $HOSTSTATE$Address: $HOSTADDRESS$\nInfo: $OUTPUT$\nDate/Time: $DATETIME$" | /usr/bin/mail -s "Host $HOSTSTATE$ alert for $HOSTNAME$!" [email protected]
              Et si sur en ssh je tape :
              Code:
              ./printf "%b" "toto" | /usr/bin/mail -s "tata" [email protected]
              Eh bien cette commande fonctionne et je reçoit bien le mail

              je ne comprend pas tout :cry:

              Comment


              • #8
                j'ai le même problème.

                Au début j'ai pensé que pour une raison inconu il envoyait ces mail à une mauvaise addresse qui était [email protected]omaine. J'ai alors modifier la commande de notification en remplacant la variable $CONTACTEMAIL$ par mon adresse mail. Ainsi si il appliquait la commande, il devrait l'envoyé à la bonne addresse, mais aucun changement, j'en deduis que les mails envoyé, ne sont pas des mail de notification.

                et sinon, vous aussi vous avez une quantité affolante de mail sur l'utilisateur nagios pour lui dire :
                "/bin/sh: line 1: /usr/local/oreon/log/ods_parsing_status: Permission non accordée"

                Dans /usr/local/oreon/log/ je n'ai trouver qu'un seul fichier qui s'appelle install_oreon.log

                Je ne sais pas ce qu'il faut faire pour la resoudre ...

                Comment


                • #9
                  Bonjour,

                  As tu trouvé une solution à ce problème ? Il faut absolument que je le résolve ...

                  Comment


                  • #10
                    Pour al notification j'ai utilisé ssmtp qui ai deja utilisé pour GLPI. Ya trois ligne config sur ssmtp c'est beacoup moin lourd que postfix qui selon moi est une usine a gaz...
                    Etudiant bts en alternance 2eme année option admin reseaux.
                    Nagios2.7, oreon 1.4, php5, apache2, mysql5, Perfparse 106.2
                    Fedora core 5

                    Comment


                    • #11
                      Code:
                      /usr/bin/printf "%b" "***** Oreon *****Notification\nType:$NOTIFICATIONTYPE$\n Host: $HOSTNAME$\nState: $HOSTSTATE$Address: $HOSTADDRESS$\nInfo: $OUTPUT$\nDate/Time: $DATETIME$" | @[email protected] -s "Host $HOSTSTATE$ alert for $HOSTNAME$!" $CONTACTEMAIL$
                      Au fait, dans la ligne, le "!" aprés le hostname etait la cause d'un probleme chez moi

                      Comment


                      • #12
                        Originally posted by Sangocen View Post
                        j'ai le même problème.

                        Au début j'ai pensé que pour une raison inconu il envoyait ces mail à une mauvaise addresse qui était [email protected]omaine. J'ai alors modifier la commande de notification en remplacant la variable $CONTACTEMAIL$ par mon adresse mail. Ainsi si il appliquait la commande, il devrait l'envoyé à la bonne addresse, mais aucun changement, j'en deduis que les mails envoyé, ne sont pas des mail de notification.

                        et sinon, vous aussi vous avez une quantité affolante de mail sur l'utilisateur nagios pour lui dire :
                        "/bin/sh: line 1: /usr/local/oreon/log/ods_parsing_status: Permission non accordée"

                        Dans /usr/local/oreon/log/ je n'ai trouver qu'un seul fichier qui s'appelle install_oreon.log

                        Je ne sais pas ce qu'il faut faire pour la resoudre ...
                        C'est un problème de droits d'utilisateur. Vérifie avec

                        ls -l /usr/local/oreon

                        A mon avis, le répertoire log devrait appartenir à l'utilisateur nagios, pour qu'il puisse écrire.
                        Regards,
                        Florin

                        Comment

                        Working...
                        X