Announcement

Collapse
No announcement yet.

mauvaise génération des fihchier de conf

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • aways
    replied
    juste les droits 777 ne serve a rien a part une faille de securiter applique les bon droits en gros c'est a dire
    Code:
    chown www-data:nagios tonfichier
    chmod 755 voir 744 ton fichier

    Leave a comment:


  • Tor
    replied
    chelou... mais bon le principale ç que ça marche ^^
    sinon vérifie que les droits pour le fichier nagios/etc/ son bon
    encore une victiore de canard

    Leave a comment:


  • flox
    replied
    trouver!

    copier une premiere fois à la main tous les fichiers de config

    Code:
    cp /etc/oreon/fileGeneration/nagioCFG/* /etc/nagios
    puis appliqué les bon droits:

    Code:
    chmod 777 /etc/nagios/*.cfg
    et pi c bon et bé...

    Leave a comment:


  • Tor
    replied
    les fichiers qu'il a déplacé sont-il bien dans le rep nagios/etc/ ?
    les fichiers non déplacé sont-il dans le rep filegene ??
    lors de la génération y ta pas mi de message d'erreur ???

    Leave a comment:


  • flox
    replied
    lol,
    Si évidement sinon je n'aurais pas le message d'erreur tous est cocher exactement pareil que sur la capture:

    Code:
    cgi.cfg - déplacement OK
    checkcommands.cfg - déplacement KO
    contactgroups.cfg - déplacement KO
    contacts.cfg - déplacement KO
    dependencies.cfg - déplacement KO
    escalations.cfg - déplacement KO
    hostextinfo.cfg - déplacement KO
    hostgroups.cfg - déplacement KO
    hosts.cfg - déplacement KO
    misccommands.cfg - déplacement KO
    nagios.cfg - déplacement OK
    resource.cfg - déplacement OK
    serviceextinfo.cfg - déplacement KO
    servicegroups.cfg - déplacement KO
    services.cfg - déplacement KO
    timeperiods.cfg - déplacement KO

    Leave a comment:


  • Tor
    replied
    bin ouai ta pas cocher tout ce qu'il faut
    voila voila!
    http://www.evox.fr.nf/uploads/05285810011788016561.JPG

    Leave a comment:


  • flox
    replied
    Sa marche,
    merci je n'étais tous simplment pas dans la bonne section, je ne pensais pas qu'il fallais repréciser le chemin.

    La génération crée donc des fichiers conrrect cependant, le déplacement ne fonctionne toujours pas des idées ?

    Merci

    Leave a comment:


  • Tor
    replied
    bon il est vrai que la on peu pas être plus clair ^^

    Leave a comment:


  • aways
    replied
    C'est normal donc que tu es tjrs le mauvais chemin
    Attached Files
    Last edited by aways; 10 May 2007, 14:06.

    Leave a comment:


  • Tor
    replied
    ah ba non la t pas au bonne endroit!!

    les fichiers de configuration concernant NAgios peuvent être modifié dans:
    configuration
    la tu a l'ongelt host, service, ...

    pour modifier le fichier nagios.cfg il faut que tu aille dans:
    configuration >> nagios >> nagios CFG

    La ce que tu modifie c'est les option pour faire fonctionné Oreon
    en gros tu lui indique ou ce trouve les rép. pour qu'il puisse bien exporter les fichiers et éxecuter Nagios
    j'esper que c'est clair sinon ba di le j'essairai de faire quelque chose de mieu

    Leave a comment:


  • flox
    replied
    Dans l'interface d'oreon dans la section information de nagios voila la configuration:

    Code:
     Informations sur Nagios
    Répertoire	/etc/nagios2/
    Répertoire + Binaire	/usr/sbin/nagios2
    Init Script	/etc/init.d/nagios2
    Répertoire Images	/usr/share/nagios2/htdocs/images/logos/
    Répertoire Sondes	/usr/share/nagios2/plugins/eventhandlers/
    Version de Nagios	2
    Répertoire + Binaire du Mailer	/usr/bin/mail
    Utilisation de PerfParse	( )Oui (x)Non
    Dans tous les fichiers présent dans le repertoire /etc/oreon/fileGeneration, les chemin fesant reféréance à nagios sont du type " /usr/local/nagios/etc".

    bug de Oreon doit-je réinstaller ?

    Leave a comment:


  • aways
    replied
    Salut alors je ne voit pas trop ce qui pose probleme, mais reverifie tout les chemin dans le nagiosCFG CGI CFG et option general nagios.Un chemin doit etre rester par defaut, un petit oublie.
    Tiens moi au courant.
    Aways

    Leave a comment:


  • flox
    replied
    Je vient d'essayé la suppression des fichier généré puis relancer la génération sans option de déplacement.
    il recrée bien les fichiers, mais garde toujours le meme nom de repertoire.

    Leave a comment:


  • Tor
    replied
    alors tu a bien rempli les champs dans le fichier de nagios.cfg
    tu génére les fichiers de conf...
    et tu a tjrs des chemins érronné
    essaye de supprimer d'abord les fichiers présent dans le rep filegeneration et de refaire la manip pour voir si il les génére bien!

    sinon le fait de ne pas les déplacer (les fichiers de conf) permet juste de vérifier que les fichiers générer sont OK c tout.
    Nagios ne les prend pas en compte

    Leave a comment:


  • flox
    replied
    ok,
    cependant le fait de généré sans déplacé les fichiers ne change rien dans les fichier généré. il garde toujours leur meme chemin erronés

    Leave a comment:

Working...
X