Announcement

Collapse
No announcement yet.

Cpu & mémoire utilisé à 100% sur mon nagios

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cpu & mémoire utilisé à 100% sur mon nagios

    je voulais savoir comment, ou quelles sont les astuces pour que Nagios ne consomment pas 100% de son cpu et pareil pour la mémoire, car du coup ca rame un peu ...
    Merci de votre aide

  • #2
    Décrits déjà le matériel qui compose ta station de supervision.
    Et quel distrib ? Environnement basique (console only) ou graphique ?
    NMS avec Nagios 2.9 - Nagios-Plugins 1.4.8 - Oreon 1.4-p5

    Comment


    • #3
      Alors j'ai une red hat ES 4 avec Oréon 1.4 et Nagios 2.5
      la machine : Dell optiplex GX520 Intel Pentuim 4 CPU 2.80Ghz avec 1Go de Ram.
      50 hosts et 350 services supervisés.
      et il y a l'environnement KDE de lancé sur la machine.

      Comment


      • #4
        hum ..... tu n'as pas un autre problème ??? perso la nagios "n'en fou pas une"
        34 host, 150 services, et pourtant le machines est une VM xen...
        Centreon 2.x

        Comment


        • #5
          j'ai fais un ps -aux, et pour la ligne d'ods j'obtiens :

          USER PID %CPU %MEM VSZ RSS TTY STAT START TIME COMMAND
          root 3371 108 0.7 36584 8084 ? Sl May22 1605:04 ods.pl

          ya un pb au nivo de ca, 108% conso cpu, ca fait mal ... surtout ke ca graph pas bien, il faut faire koi pour ce pb ?

          Comment


          • #6
            Vouais moi aussi...
            Ma station de supervision est un PIII 1GHz (256ko de cache...) avec 512 Mo de RAM... et y'a aucun problème.
            En fait mon apache2 bouffe plus que nagios.
            Bon par contre environnement texte seulement héhé.

            Je te conseille de faire un "top" en console, et regarde ce qui bouffe... Tu peux aussi regarder par user ("u nagios" par exemple...)

            Avec ps, vérifies aussi que t'as qu'un seul nagios qui tourne.

            Mais à mon avis c'est autre chose qui bouffe. Pour la RAM, 90% d'usage c'est normal sur un Linux. Par contre pour le CPU...

            EDIT : grilled par ta réponse... t'as ptet plusieurs ods qui tournent... :
            Code:
            /etc/init.d/ods status
            NMS avec Nagios 2.9 - Nagios-Plugins 1.4.8 - Oreon 1.4-p5

            Comment


            • #7
              j'ai apparement 2 ods, c normal ?

              [[email protected] /]# ps -aux | grep ods

              root 3371 108 0.7 36584 8084 ? Sl May22 1627:08 /usr/bin/perl -w /usr/local/oreon/ODS/ods.pl
              root 3370 0.7 0.9 39076 9672 ? Sl May22 9:52 /usr/bin/perl -w /usr/local/oreon/ODS/ods.pl
              root 21546 0.0 0.0 5380 736 pts/3 S+ 15:25 0:00 grep ods

              Comment


              • #8
                Bah nan c'est pas normal. C'est le premier qui déconne...
                Un kill -9 ??
                NMS avec Nagios 2.9 - Nagios-Plugins 1.4.8 - Oreon 1.4-p5

                Comment

                Working...
                X