Announcement

Collapse
No announcement yet.

no more graph ODS / plus de graph ODS

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • no more graph ODS / plus de graph ODS

    Bonjour,

    J'ai adopté Oreon depuis quelques mois dans ma boite.
    Ca marche bien, les wikis sont bien fait
    (j'attends les prochains modules avec impatience !)
    j'ai la derniere version officiel d'Oreon (1.4) avec la serie de 5 patch appliqués.

    je suis sur une Gentoo et voici mon souci :

    Ce matin en arrivant j'ai une croix a la place de mes graph ODS !
    mes rrd se remplissent bien dans le dossier rrd et dans le dossier OreonDataStorage mais les seuls graph qui marchent sont mes
    "Graph par Plugins" mais pas "Oreon Graphs" !

    je n'ai pas d'erreur indiquée sur ma page web.

    j'ai essayé de remettre des droits différent sur OreonDataStorage mais rien n'y fait ! j'ai tout redemarrer, et reverifier avec le wiki ODS: tout parait bon.
    Mes disques ne sont pas saturés.

    je ne veut pas reinstaller tout pour une histoire de droit ou chemin ...

    Quelqu'un a une idée ?

    merci !
    Debian Lenny / Nagios 3.0.6 / Centreon 2.1.4

  • #2
    Le processus ODS tourne-t-il ?

    Comment


    • #3
      Oui !

      server ~ # /etc/init.d/ods status
      PID TTY TIME CMD
      32365 ? 00:00:05 ods.pl


      Je n'ai aucune erreur dans les logs nagios, oreon, rrd, apache.
      quand je fais un rrdtool --version
      ca me renvoi :
      rrdtool: /usr/local/lib/libpng12.so.0: no version information available (required by /usr/lib/librrd.so.2)

      j'ai l'impression que ca vient de le libpng.
      les garphs ODS sont bien en png ? non ?
      Debian Lenny / Nagios 3.0.6 / Centreon 2.1.4

      Comment


      • #4
        Yes, essaye d'installer/de réinstaller libpng pour voire, ca concorderai avec le fait que tu arrive pas a afficher les images de rrdtools.

        Comment


        • #5
          j'ai fait un

          "emerge -D rrdtool"


          puis un :

          "emerge -D libpng" (-D = deep)

          toujours pas de graph et l'erreur sur libpng12.so.0

          (
          Debian Lenny / Nagios 3.0.6 / Centreon 2.1.4

          Comment


          • #6
            essaye de réinstaler libpng pr voire !

            Comment


            • #7
              c'est fait.
              Toujours le souci .... grrrr
              Debian Lenny / Nagios 3.0.6 / Centreon 2.1.4

              Comment


              • #8
                j'ai desinstallé rrdtool, libpng, puis reinstallé.
                rien y fait.
                serait-ce un autre souci ?
                Debian Lenny / Nagios 3.0.6 / Centreon 2.1.4

                Comment


                • #9
                  Ce que je trouve bizarre c'est que les sonde grafique marchent !
                  et pas les oreon graphs ...
                  Debian Lenny / Nagios 3.0.6 / Centreon 2.1.4

                  Comment


                  • #10
                    maintenant je n'ai plus aucun graph, mais j'ai des camenbers !

                    entre temps j'ai fais un emerge system ...
                    Debian Lenny / Nagios 3.0.6 / Centreon 2.1.4

                    Comment


                    • #11
                      par contre l'emerge world ne marche pas.
                      ca bloque sur cups avec des erreur style :
                      ../filter/libcupsimage.so: undefined reference to `[email protected]_0'


                      Je crois que celà n'a plus rien a voir avec Oreon ... je pense c'est un pb linux et libpng ...

                      Merci, je vous tiendrai au courant.
                      Debian Lenny / Nagios 3.0.6 / Centreon 2.1.4

                      Comment


                      • #12
                        j'ai tout supprimé et tout reinstallé ,
                        je peux pas reinstallé la gentoo car elle est en prod avec d'autres trucs dessus.
                        je suis passé de la version nagios 2.5 a la 2.9, avec les derniers plugs stables
                        j'ai tout recompilé .

                        les rep rrd se remplissent (rrd et OreonDataStorage)
                        la base aussi
                        aucune erreur dans les logs apache ...grrrr

                        ------> aucun graphique affiché

                        a part recomplier les lib graphique (qui n'a rien changé) je ne vois pas ....

                        une idée ?
                        Last edited by magic_swamp; 31 May 2007, 19:39.
                        Debian Lenny / Nagios 3.0.6 / Centreon 2.1.4

                        Comment


                        • #13
                          Contournemtn Du Pb / Resolu

                          Impossible de faire marcher rrdtool 1.2.
                          La gentoo date trop je pense et elle doit etre pas si net.

                          J'ai retrogradé en version rrdtool 1.0 ---> tout est OK
                          Debian Lenny / Nagios 3.0.6 / Centreon 2.1.4

                          Comment

                          Working...
                          X