Announcement

Collapse
No announcement yet.

pb oreon

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • pb oreon

    Salut,

    j'ai un problème avec oreon je ne voit plus rien dans monitoring (hôtes et services)
    Pourtant ils apparaissent dans la configuration !
    J'ai ce problème depuis que j'ai importer un fichier avec des hôtes et même les anciens n'apparaissent plus !
    Que dois-je faire ?
    merci






    http://city-max.miniville.fr/

  • #2
    salut !
    tu as exporter ta configuration vers nagios ?
    si oui as tu vérifier si il n'y avait as d'erreur?
    si il y a des erreurs oreon n'envoi pas sa configuration vers nagios, donc cela ne fonctionne plus.

    dans Configuration -> nagios
    il faut cocher
    Lancer le debug de Nagios (-v) oui
    Déplacer les fichiers oui
    Recharger Nagios oui et restart tu fais générer et tu regarde si il ya des erreurs de configuration en dessous
    voila !
    Master Sécurité des Systèmes d' Information
    Nagios v2.9 ||Nagios-plugins 1.4.9 || snmp v2c || Oreon 1.4 INside || ODS || 59 hosts && 128 services
    || Nagios Checker


    [email protected] vs Jonhbob le choc des GDR ^^

    Comment


    • #3
      Oui j'ai régénérer nagios il n'y a pas d'erreur.
      Par contre je vient de voir que dans monitoring>>> gestionnaire d'évènements >>events logs > erreurs/avertissements il y a pas mal de problèmes :
      par exemple :
      Code:
      Attempting to execute the command "/usr/local/nagios/libexec/process-service-perfdata "1183447141" "@IP.mhsnetworks.net" "Service_Alive_Swi" "PING OK - Paquets perdus = 0%, RTA = 2.17 ms" "OK" """ resulted in a return code of 127. Make sure the script or binary you are trying to execute actually exists...
      La commande Service_Alive_Swi correspond au check_host_alive pour les switchs.

      Quel à la procédure à suivre pour régler le problème ?
      Une idée ?


      http://city-max.miniville.fr/
      Last edited by max-lb; 3 July 2007, 10:56.

      Comment


      • #4
        tu as les bon droits sur le fichier ??? il est executable ?
        Master Sécurité des Systèmes d' Information
        Nagios v2.9 ||Nagios-plugins 1.4.9 || snmp v2c || Oreon 1.4 INside || ODS || 59 hosts && 128 services
        || Nagios Checker


        [email protected] vs Jonhbob le choc des GDR ^^

        Comment


        • #5
          Originally posted by [email protected] View Post
          tu as les bon droits sur le fichier ??? il est executable ?
          lequel fichier ??

          Comment


          • #6
            le process-service-perfdata
            Master Sécurité des Systèmes d' Information
            Nagios v2.9 ||Nagios-plugins 1.4.9 || snmp v2c || Oreon 1.4 INside || ODS || 59 hosts && 128 services
            || Nagios Checker


            [email protected] vs Jonhbob le choc des GDR ^^

            Comment


            • #7
              normalement on doit le trouver dans .../libexec avec les autres plugins non ? parce que je le trouve pas !

              Comment


              • #8
                non c pas un plugins par défautl, mais t'en a pas besoin si tu utilise pas ODS pour générer ds graphes.
                alors... je ne vois pas d'ou peut venir le probleme...
                tu n'aurai pas activé les performance dans un de tes services ? il essairai de recuperer les données de performance de se service et il ne peu pas car le plugins perfdata n'existe pas.
                Regarde dans la configuration de tes services dans l'onglet traitement de données, si Traitement des données de performance est sur défaut ou non et pas sur oui.
                Ca peut peut etre venir de la sinon j'en ai aucune idée.
                Last edited by [email protected]; 3 July 2007, 11:36.
                Master Sécurité des Systèmes d' Information
                Nagios v2.9 ||Nagios-plugins 1.4.9 || snmp v2c || Oreon 1.4 INside || ODS || 59 hosts && 128 services
                || Nagios Checker


                [email protected] vs Jonhbob le choc des GDR ^^

                Comment


                • #9
                  J'ai ods et perfparse mais apparemment il faut mieux ods car les plugins sont dévéléoppés pour ods et donc pas besoin de les modifierpour perfparse.

                  Seulement je n'ai toujours aucun hôte ni service dans monitoring, alors qu'il sont bien présent dans reporting et dans configuration !!!!
                  Pourquoi ?

                  Est que çà pourrait etre un bug d'oreon ?
                  Il me reste plus que 2 jours pour corriger ce problème et çà fait également 2 jours que je suis dessus sans avoir la moindre piste pour le régler !

                  Donc merci de m'aider ! SVP !!!



                  http://city-max.miniville.fr/

                  Comment


                  • #10
                    Après avoir générer nagios et redémarer mes différents services (nagios, httpd mysql), dans l'interface d'oreon, mes hôtes et services refusent d'apparaitres dans l'onglet monitoring, alors qu'il sont présent dans reporting ou dans configuration !!!!
                    Je n'est donc qu'une chose à dire c'est quoi ce bordel !!!
                    Aidez moi SVP !










                    http://city-max.miniville.fr/

                    Comment


                    • #11
                      Toujours pas de solution ...:cry:
                      Plus que 2 jours pour réussir à voir mes hôtes dans monitoring et mes cammenberts à l'accueil !!!
                      A l'aide !!!




                      http://city-max.miniville.fr/ind

                      Comment


                      • #12
                        Ben si il sont présent dans reporting et configuration et pas dans monitoring, c'est que tu as pas exporter tes fichiers los de la génération du fichier de cong de nagios.

                        configuration > nagios
                        Mettre "déplacer les fichiers" à oui !

                        Tu peux vérifier, mais dans ton fichier /usr/local/nagios/etc/hosts.cfg , tu ne dois pas avoir tes hôtes.
                        Sir
                        -------
                        Red Hat 5.4.::. Nagios 3.1.2 .::. Centreon 2.1.8.::.2500 hosts.::.10000 services

                        Comment


                        • #13
                          Originally posted by Sir View Post
                          Ben si il sont présent dans reporting et configuration et pas dans monitoring, c'est que tu as pas exporter tes fichiers los de la génération du fichier de cong de nagios.

                          configuration > nagios
                          Mettre "déplacer les fichiers" à oui !

                          Tu peux vérifier, mais dans ton fichier /usr/local/nagios/etc/hosts.cfg , tu ne dois pas avoir tes hôtes.
                          Ben si le problème c'est que les hosts sont bien présents dans le fichier hosts.cfg !!!!
                          Eh ça ne marche pas !!!





                          http://city-max.miniville.fr/ind

                          Comment


                          • #14
                            Alors, tes hotes sont présents dans Nagios ?

                            As tu activé la lecture rapide des fichiers dans :
                            Options > Options générales > OreonDataStorage. Il ne faut pas l'activer.
                            Sir
                            -------
                            Red Hat 5.4.::. Nagios 3.1.2 .::. Centreon 2.1.8.::.2500 hosts.::.10000 services

                            Comment


                            • #15
                              Yes c'était ça !!! lecture rapide des status !!! à la vache çà faisait 2 jours que je cherchais pourquoi ça ne marchait pas et c'était a cause de cette .... de case de m... !!!!
                              Merci beaucoup !!!






                              http://city-max.miniville.fr/ind

                              Comment

                              Working...
                              X