Announcement

Collapse
No announcement yet.

No graphs

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • No graphs

    Hi there,

    I got centreon up and running, the ods server is running ok, the service-perfdata file in nagios is being updated, in oreonīs view I have the list of hosts, but when I try to generate the graphs, no image appears. Iīve followed the instructions in http://wiki.oreon-project.org/index.php/Graphs , but no [0-9]*.rrd files are stored in my /usr/local/oreon/ODS/ folder. Please, thatīs the only thing missing.

    Thanks in advance.

  • #2
    What kind of install did you make ?

    If it's a 1.4.1 from scratch, your graph should be in /var/lib/ods/database

    If you came from 1.4, your graphs should be in /usr/local/oreon/OreonDataStorage

    For more information on what can be wrong, go in :
    oreon/ODS/var
    Try to see if ods is running :
    # ps aux | grep ods
    if not :
    /etc/init.d/ods start
    and :
    tail -f ods.log

    The error should appear. We can better help you then.
    Romain Le Merlus
    Centreon Forge
    MERETHIS

    Comment


    • #3
      graphing problem

      Originally posted by rom View Post
      What kind of install did you make ?

      If it's a 1.4.1 from scratch, your graph should be in /var/lib/ods/database

      If you came from 1.4, your graphs should be in /usr/local/oreon/OreonDataStorage

      For more information on what can be wrong, go in :
      oreon/ODS/var
      Try to see if ods is running :
      # ps aux | grep ods
      if not :
      /etc/init.d/ods start
      and :
      tail -f ods.log

      The error should appear. We can better help you then.
      Thanks a lot for the reply,

      I made centreon from scratch, version 1.4.1, the /var/lib/ods/database has no files in it, just a folder called 'backup'. ods is running, and thatīs the output of ods.log:
      1186578956 - Starting ODS engine...
      1186578956 - PID : 27932

      and thatīs the one from ods_demon.log:
      thread failed to start: Can't call method "prepare" on an undefined value at /usr/local/oreon/ODS/lib/getServiceData.pm line 84, <PFDT> line 1.
      thread failed to start: Can't call method "prepare" on an undefined value at /usr/local/oreon/ODS/lib/getServiceData.pm line 84, <PFDT> line 7.
      thread failed to start: Can't call method "prepare" on an undefined value at /usr/local/oreon/ODS/lib/getServiceData.pm line 84.

      Thanks in advance.

      Comment


      • #4
        solved

        Thanks for the replies, and sorry I canīt write the posts in french. I just changed the source from RRDTOOL & MySQL to only RRDTOOL. Now the folder /usr/local/oreon/ODS have the rrd files and the graphics works. Iīve just noticed sometimes the IN or OUT Traffic comes with 0 value. So the graphs are no quite right.... Gonna check if its a snmp problem or what.... If I find myself unable to find why, Iīll post another topic.

        Thanks a lot for the help.

        Comment


        • #5
          Don't think it's a problem due to the storage type...
          Did you install perl-DBI & perl-DBD-MySQL ?
          Romain Le Merlus
          Centreon Forge
          MERETHIS

          Comment


          • #6
            perl packages

            Rom,

            All the perl dependencies are installed. But when I change the storage type to MySQL && RRDTOOL the graphs stop working. Iīm short in time, so I canīt afford to find where the problem is, but as soon as things here slow down a little bit Iīll check whatīs wrong. Iīm using ubuntu 6.06.

            Iīm just having problems getting the values from the hosts via check_centreon_snmp_traffic. Sometimes values return as 0. I have no perl skills, but Iīm googling for a solution. If anyone can help, or if thereīs a patch to solve this issue, please let me know.

            Comment

            Working...
            X