Announcement

Collapse
No announcement yet.

check_centreon_nt Graphs + COUNTER

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • check_centreon_nt Graphs + COUNTER

    I have posted this else where, and I apologize for posting it in this forum as I think it is a bit out of place but I have yet to get a response and from what I have read through the forums other are having the same issue and no one has responded to them either.

    If this no longer works, it would be great for someone to just say it doesn't and I can drop it.

    My post from http://forum.oreon-project.org/showthread.php?t=4477


    J'ai vu que quelques poteaux au sujet de check_centreon_nt avec le COMPTEUR et moi n'ont vu aucune résolution. Si tout va bien quelqu'un peut au moins énoncer si cela fonctionne ou pas.

    Pour atteindre une plus grande assistance j'ai traduit mon poteau au Français avec le google, si désolé pour l'abattage de la langue française.

    J'ai un groupe de contrôles installés en utilisant le check_centreon_nt qui fonctionnent l'amende juste. Cependant, j'ai 1 qui vérifie l'amende juste, mais le graphique correctement.

    Mon contrôle est un contre- contrôle (du CLI) :
    ./check_centreon_nt - H 192.168.1.100 - v PARENT - l « \ services terminaux \ sessions totales » - W 75 - c 80

    Renvoie une valeur de :
    34 |counter=1

    Dans Centreon les travaux de contrôle et dans les expositions de surveillance 34 de vue. Quand je vais au graphique il montre que juste le 1 cependant (la présomption de lui vient du compteur) la base de données d'ODS a la valeur :
    ÉTAT INITIAL DE SERVICE : servername ; Utilisateurs ; OK ; DUR ; 1 ; 28

    J'ai essayé déranger avec les différents points d'émission et est-ce que je suis juste ne l'obtenant pas, pensées n'importe qui ?

    En tant que toujours mercis de l'aide.

    Je devrais me mentionner ai créé un calibre de graphique pour ce contrôle assigné il au service dans l'information prolongée.

    ----------------------English---------------

    I have seen a few posts about check_centreon_nt with COUNTER and I haven't seen any resolutions. Hopefully someone can at least state if it should work or not.

    To reach a larger audience I have translated my post to French with google, so sorry for the butchering of the French language.

    I have a bunch of checks setup using check_centreon_nt which are working just fine. However, I have 1 that is checking just fine, but not graphing correctly.

    My check is a counter check (from the CLI):
    ./check_centreon_nt -H 192.168.1.100 -v COUNTER -l "\Terminal Services\Total Sessions" -w 75 -c 80

    Returns a value of:
    34 |counter=1

    In Centreon the check works and in the monitoring view shows 34. When I go to the graph it shows just the 1 though (presuming it is coming from the counter) The ODS database has the value:
    INITIAL SERVICE STATE: servername;Users;OK;HARD;1;28

    I have tried messing around with the different data sources and I am just not getting it, thoughts anyone?

    As always thanks for the help.

    I should mention I created a graph template for this check an assigned it to the service in the extended info.

  • #2
    I didn't look long at this because I don't use NSClient but I see a 'normal' performance-output when you use a description.
    Maybe the 'counter' is just the number of values returned, and the 'description' is needed for performance output.

    No description:
    # ./check_centreon_nt -H 10.1.1.1 -v COUNTER -l "\System\System Up Time"
    8225 |counter=1

    With description added:
    # ./check_centreon_nt -H 10.1.1.1 -v COUNTER -l "\System\System Up Time","%.0f"
    8238 | pct.0f=8238.000000 pct;0.000000;0.000000; |counter=1

    Just a hint..

    Regards
    Menno van Bennekom

    Comment


    • #3
      Thanks for the reply, I have tried adding the description and what I end up with is a graph that has 2 data sources:

      Counter (always 1)
      pct-0 (no data)

      I have tried adding a description and just with the %.0f and get the same results.

      Are you using something else to pull counters from windows boxes or do you not do that?

      Comment


      • #4
        Originally posted by sgrynd View Post
        Thanks for the reply, I have tried adding the description and what I end up with is a graph that has 2 data sources:
        Counter (always 1)
        pct-0 (no data)
        I have tried adding a description and just with the %.0f and get the same results.
        But what are you getting as result in the unix prompt..
        Originally posted by sgrynd View Post
        Are you using something else to pull counters from windows boxes or do you not do that?
        I'm happy with the parameters I can monitor via SNMP or other clientless checks. Only on a few systems I installed NRPE.

        Regards
        Menno

        Comment


        • #5
          Using the following command :

          ./check_centreon_nt -H 192.168.1.10 -v COUNTER -l "\Terminal Services\Active Sessions","Active Sessions %.0f"

          returns:
          Active Sessions 26 | 'Active Sessions pct.0f '=26.000000 pct;0.000000;0.000000; |counter=1

          Alternately the command:
          ./check_centreon_nt -H 192.168.1.10 -v COUNTER -l "\Terminal Services\Active Sessions","%.0f "

          returns:
          26 | ' pct.0f '=26.000000 pct;0.000000;0.000000; |counter=1

          The first part is not getting graphed the 26 or Active sessions. pct.0f and counter are all that get graphed.

          Comment


          • #6
            I have found the solution for this and will post it in the morning.

            Comment


            • #7
              After beating my head against a wall for some time I came upon the solution, it was simple and right in front of me all along as is typical.
              For my example I was attempting to graph via check_centreon_nt the Terminal Service Active Sessions counter. I needed this so I could track visualy the CPU/Memory usage as the session counter elevated. Which worked well with an older version of Oreon.

              As mentioned above I was only getting counter=1, however the nagios display message was correct (which ODS does not look at) adding the %.0f resulted on it adding a data source of pct.0f which was of no use.

              My original check was:
              ./check_centreon_nt -H 192.168.1.10 -v COUNTER -l "\Terminal Services\Active Sessions","Active Sessions %.0f"

              which returned:
              Active Sessions 26 | 'Active Sessions pct.0f '=26.000000 pct;0.000000;0.000000; |counter=1

              The graph would show data sources of counter and pct.0f, the value for counter was always 1 and pct.0f would always show 0.

              So the solution was the layout of the check and the fact that I had spaces in the description before the float parameter.

              The check I ended up using is:

              check_centreon_nt -H 192.168.1.10 -v COUNTER -l "\Terminal Services\Active Sessions","%.f Active_Sessions" -w 75 -c 80

              which returns:
              41 Active_Sessions | ' pct.f Active_Sessions'=41.000000 pct;75.000000;80.000000; |counter=1

              my graphs now show Active_Sessions and Counter as the data source. The pct.f is dropped because there is a space in between it and Active.

              I did delete my service data for the service and let it recreate to get it cleaned up.

              A mod might want to edit the title of this thread to [SOLVED].
              Last edited by sgrynd; 30th August 2007, 20:48.

              Comment


              • #8
                I have also started a wiki entry for this command.

                http://wiki.oreon-project.org/index....ck_centreon_nt

                Comment


                • #9
                  After 7 years of your post, it helped me a lot.

                  Now my Centreon shows graphs for Active and Inactive RDP and ICA sessions.

                  Thanks sgrynd for the info.
                  Regards from a friend in Sao Paulo, Brazil.
                  TND Brasil

                  Comment

                  Working...
                  X