Announcement

Collapse
No announcement yet.

Migration 1.4 - 1.4.1 et images des graphes disparues

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Migration 1.4 - 1.4.1 et images des graphes disparues

    Je pense que j'ai tout dit dans le titre
    J'ai migré mon Oreon v1.4 vers Centreon 1.4.1 conf readme dans l'archive
    J'ai installé SOAP après la migration (un oubli).
    J'ai appliqué les patch update oreon db et celui dans l'archive pour ods (conf doc).
    J'ai redémarré les services (nagios, ods, même apache, okù).

    Résultats négatifs:

    1. dans l'onglet commandes, je click sur une commande, je veux vérifier l'aide et y'a rien (voir images)
    2. dans vues oreon, je ne vois pas les graphes, alors qu'ods semble faire son boulot (voir images).

    Sinon, tout semble OK. RAS dans les logs, si ce n'est le log d'apache, qui me dit:
    [Fri Sep 14 15:26:32 2007] [error] [client 127.0.0.1] File does not exist: /usr/local/oreon/www/include/javascript, referer: http://localhost/oreon/install/upgrade.php
    [Fri Sep 14 15:26:37 2007] [error] [client 127.0.0.1] File does not exist: /usr/local/oreon/www/include/javascript, referer: http://localhost/oreon/install/upgrade.php
    [Fri Sep 14 15:26:43 2007] [error] [client 127.0.0.1] File does not exist: /usr/local/oreon/www/include/javascript, referer: http://localhost/oreon/install/upgrade.php
    [Fri Sep 14 15:27:06 2007] [error] [client 127.0.0.1] File does not exist: /usr/local/oreon/www/include/javascript, referer: http://localhost/oreon/install/upgrade.php
    [Fri Sep 14 15:27:11 2007] [error] [client 127.0.0.1] File does not exist: /usr/local/oreon/www/include/javascript, referer: http://localhost/oreon/install/upgrade.php
    [Fri Sep 14 15:30:12 2007] [error] [client 127.0.0.1] File does not exist: /usr/local/oreon/www/include/javascript, referer: http://localhost/oreon/install/upgrade.php
    [Fri Sep 14 15:30:16 2007] [error] [client 127.0.0.1] File does not exist: /usr/local/oreon/www/include/javascript, referer: http://localhost/oreon/install/upgrade.php
    [Fri Sep 14 15:30:22 2007] [error] [client 127.0.0.1] File does not exist: /usr/local/oreon/www/include/javascript, referer: http://localhost/oreon/install/upgrade.php
    [Fri Sep 14 15:30:37 2007] [error] [client 127.0.0.1] File does not exist: /usr/local/oreon/www/include/javascript, referer: http://localhost/oreon/install/upgrade.php
    [Fri Sep 14 15:30:52 2007] [error] [client 127.0.0.1] File does not exist: /usr/local/oreon/www/include/javascript, referer: http://localhost/oreon/install/upgrade.php
    [Fri Sep 14 15:31:16 2007] [error] [client 127.0.0.1] File does not exist: /usr/local/oreon/www/include/javascript, referer: http://localhost/oreon/install/upgrade.php
    [Fri Sep 14 15:31:22 2007] [error] [client 127.0.0.1] File does not exist: /usr/local/oreon/www/include/javascript, referer: http://localhost/oreon/install/upgrade.php
    sh: --help: command not found
    sh: --help: command not found
    sh: --help: command not found
    sh: --help: command not found
    sh: --help: command not found
    sh: --help: command not found
    [Fri Sep 14 17:21:39 2007] [error] [client 127.0.0.1] File does not exist: /usr/local/oreon/www/include/configuration/changetab.js, referer: http://localhost/oreon/oreon.php?p=40204&o=c&graph_id=2
    Pour ces 2 erreurs, avez-vous une suggestion?

    Merci d'avance.
    Attached Files
    Last edited by fgrosu; 17 September 2007, 08:54. Reason: découverte d'une erreur dans le log apache
    Regards,
    Florin

  • #2
    Bug ou pas?

    Avant de partir en week-end, j'ai trouvé d'où vient l'erreur javascript:
    fichier centreon-1.4.1/www/include/install/step_upgrade/functions.php lignes 36, 37:

    <SCRIPT language='javascript' src='../include/javascript/functions.js'></SCRIPT>
    <SCRIPT language='javascript'>

    A priori, le répertoire "include" a été renommé en "common"

    A vous de me dire si c'est un bogue ou pas et si c'est ça qui m'empêche de voir mes graphes

    Bon weekend.
    Last edited by fgrosu; 14 September 2007, 18:46.
    Regards,
    Florin

    Comment


    • #3
      A priori c ça

      Bon, j'ai copié (au cas où il y a d'autres réferences à lui) le répertoire common dans include, et petit à petit tout rentre dans l'ordre.
      J'ai regénéré CDS car j'avais 15 services "unable to update", j'espère que ça va resoudre ce problème.

      Allez, bon weekend, cette fois je pars pour de vrai.
      Regards,
      Florin

      Comment


      • #4
        Sinon, pour l'affichage des images des graphes après une install propre, il s'agissait d'une erreur d'accès au répertoire des bases rrd (dans mon cas, /usr/local/oreon/rrd).

        Julien a rapidement résolu le problème en faisant:
        Code:
        chown nagios:nagios /usr/local/oreon/rrd
        chmod 755 /usr/local/oreon/rrd
        Grand merci, Julien

        A bientôt.:cool:
        Regards,
        Florin

        Comment

        Working...
        X