Announcement

Collapse
No announcement yet.

NEWBIE Just after installation problems

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • NEWBIE Just after installation problems

    In Configuration / Commands / Plugins I have error message:

    Warning: opendir(/usr/lib/nagios/plugins/) [function.opendir]: failed to open dir: No such file or directory in /usr/local/centreon/www/include/configuration/configPlugins/DB-Func.php on line 28
    Warning: readdir(): supplied argument is not a valid Directory resource in /usr/local/centreon/www/include/configuration/configPlugins/DB-Func.php on line 29
    Warning: closedir(): supplied argument is not a valid Directory resource in /usr/local/centreon/www/include/configuration/configPlugins/DB-Func.php on line 36
    Where this comes from ? I dont have such dir as /usr/lib/nagios/plugins/ . All my plugins are installed in /usr/local/nagios and this path was given in Centreon installation.

    Regards,
    Centreon v1.4.2.2 (no graphs)
    Nagios v2.10 + plugins v1.4.10
    ubuntu v7.04 VM vmware

  • #2
    goto Options > Oreon > General Options > Nagios to make things right !

    Comment


    • #3
      @xspoon
      Thx for your help. It works now .


      Another problem
      Why after installation I have no check_graph command ? I looked into centreon install archive and I didnt see any check_graph commands into /Plugins/src dir ...
      Centreon v1.4.2.2 (no graphs)
      Nagios v2.10 + plugins v1.4.10
      ubuntu v7.04 VM vmware

      Comment


      • #4
        Originally posted by SlyT View Post
        Why after installation I have no check_graph command ? I looked into centreon install archive and I didnt see any check_graph commands into /Plugins/src dir ...
        Can anyone answer me why I dont have check_graph* commands available ? Did I miss something during installation process ?

        I have these plugins in another Virtual Alliances Machine. Can it be directly moved to my system ?
        Centreon v1.4.2.2 (no graphs)
        Nagios v2.10 + plugins v1.4.10
        ubuntu v7.04 VM vmware

        Comment


        • #5
          the check_graph_xxx plugins are now known as check_centreon_xxx

          Comment


          • #6
            Hmm,
            so why I can't generate any graph ? I followed up wiki / graphs (http://wiki.oreon-project.org/index.php/Graphs), have service defined using centreon_ping, in /var/lib/ods/database I have 1 - 3.rrd files (which suggest that everything is working OK). But when I try to generate graph using centreon_ping I get message "No graph associated to this service.". Besides in Centreon' views I have no hosts in pull-down list ... .
            Centreon v1.4.2.2 (no graphs)
            Nagios v2.10 + plugins v1.4.10
            ubuntu v7.04 VM vmware

            Comment


            • #7
              check your ODS configuration. There are some post about that.

              Comment


              • #8
                I've checked my ODS configuration and it seems to be OK but graph creation doesnt work. May someone guide me what could I missed ?
                Centreon v1.4.2.2 (no graphs)
                Nagios v2.10 + plugins v1.4.10
                ubuntu v7.04 VM vmware

                Comment


                • #9
                  Does your centreon_ping return performance data? Run it at command line and see if there are numbers separated by semi-colons at the end.

                  Comment


                  • #10
                    Yes, it does.
                    For example:

                    ./check_centreon_ping -H 10.1.1.1 -n 3
                    GPING OK - rtt min/avg/max/mdev = 1.891/1.941/1.973/0.035 ms|time=1.941ms;20;40;; ok=1
                    Centreon v1.4.2.2 (no graphs)
                    Nagios v2.10 + plugins v1.4.10
                    ubuntu v7.04 VM vmware

                    Comment


                    • #11
                      I think I solved that problem.
                      I checked Configuration / Nagios / Perfparse CFG and noted there was no password for user who has access to perfparse DB ... All other settings were correct. Why it is hidden so deep ?
                      Centreon v1.4.2.2 (no graphs)
                      Nagios v2.10 + plugins v1.4.10
                      ubuntu v7.04 VM vmware

                      Comment


                      • #12
                        Has anybody confirmed if PerfParse even works with Centreon in version 1.4.1? The config page is there, but last time I installed it, my graphs didn't work. The reporting page did work that time around, though. Does the reporting page work off of the perfparse db somehow?

                        Comment


                        • #13
                          Until I completed db user password in .../Perfparse CFG centreon had been unable to create any graph. So ...
                          Centreon v1.4.2.2 (no graphs)
                          Nagios v2.10 + plugins v1.4.10
                          ubuntu v7.04 VM vmware

                          Comment

                          Working...
                          X