Announcement

Collapse
No announcement yet.

check_cpu_load et divers problème...

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • check_cpu_load et divers problème...

    Bonjour a tous,

    Voila je vous explique le problème...

    voila ma commande de check_cpu_load
    $USER1$/check_nt -H $HOSTADDRESS$ -v CPULOAD -l $ARG1$ -s "public" -p 12489
    avec comme argument !1!90!95

    Quand je test depuis mon serveur nagios, la commande marche correctement et me renvoie la charge, par contre dans oreon le service CPU est vert mais avec comme erreur "pas assez de valeur pour l'argument -l". J'ai cherché partout mais la je me remet a vous.
    Autre question, j'ai mis en place hobbit avant et il me renvoyait l'observateur d'evenement de mon serveur. Je voulai savoir si c'etait possible avec nagios?(j'imagine que oui)

    Sinon j'ai ce message dans le statusmap

    Warning: file_get_contents(http://[email protected]/nagios/cgi-bin/...out=4&host=all) [function.file-get-contents]: failed to open stream: HTTP request failed! HTTP/1.1 401 Authorization Required in /usr/local/oreon/www/modules/statusmap/statusmapproxy.php on line 114

    Problème d'autorisation a priori mais quand je vais sur http://@IP/nagios/cgi-bin/statusmap.cgi ca marche, j'ai la carte et j'ai 777 sur statusmapproxy.

    Et dernier problème, quand je clique sur le graph, j'ai ce message "Ce service n'a pas de graph associé."
    Voila pas mal de soucis mais je vais faire un bon en avant si vous m'aider..
    @+
    Last edited by gregorybel; 20 November 2007, 20:30.

  • #2
    Originally posted by gregorybel View Post
    voila ma commande de check_cpu_load
    $USER1$/check_nt -H $HOSTADDRESS$ -v CPULOAD -l $ARG1$ -s "public" -p 12489
    avec comme argument !1!90!95
    Bon, pour ton premier problème:
    j'aurais mis comme argument : !1,90,95
    Ce qu'il y a derrière ton ! c'est tout ton $ARG1$ de ta commande

    Sinon, tu peux faire comme ça:
    $USER1$/check_nt -H $HOSTADDRESS$ -v CPULOAD -l $ARG1$,$ARG2$,ARG3$ -s "public" -p 12489
    Et la tu peux mettre comme argument !1!90!95

    en gros tes arguments se passent comme ceci: !$ARG1$!ARG2$!$ARG3$!$ARGn$
    Guigui

    > PAS DE SUPPORT VIA MP <

    "Ce n'est qu'en essayant continuellement que l'on finit par réussir. En d'autres termes, plus ça rate et plus on a de chances que ça marche !!" (Shadoks)

    Comment


    • #3
      1er problème résolu!!! Yes merci beaucoup, a ce rythme la ce soir tous marche... lol
      merci

      Comment


      • #4
        Après une journée de plus de boulot, ca y'est j'ai des graphs... Grace au wiki sur les graph très bien fait d'ailleurs.
        Ma foi il me mank quelque truc mais ca fait plaisir d'avancer!

        Deux autres petite question:

        Le check_nt pour Windows Xp ca marche pas au niveau de la Ram?

        Tous les caractères spéciaux style é è sont transformer en @^. Problème utf8 mais comment le modifier?

        Comment

        Working...
        X