Announcement

Collapse
No announcement yet.

Apparition et disparition d'hosts

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Apparition et disparition d'hosts

    Bonjour à tous.

    Je viens (enfin) d'installer Oreon 1.4.1 (Nagios 2.9). Je stagnais jusqu'alors avec la 1.2.2...lol
    Je commence à mettre des hôtes, tout va bien mes 4 premières machines sont en supervision (avec 16 services au total).
    Je décide alors d'ajouter 10 autres machines.
    Tout va bien aussi, nagios redémarre et me dit qu'il y a bien 14 hôtes au total avec 66 services.

    Mais là sans rien faire de temps en temps dans la petite barre en haut (là où l'on voit 2 petits tableaux affichant "Status des hôtes" et "Status des services") le nombre de machines retombe de temps en temps à 4 (et le nombre de services à 16) puis ça revient à 14 hôtes et 66 services et ainsi de suite...quelqu'un a déjà eu ce problème?

    Je suis un peu perplexe...à votre bon coeur et merci d'avance.

    Pour infos :
    HARDWARE : IBM x346, 2 CPU Intel(R) Xeon(TM) CPU 3.20GHz, 2 * 2Go RAM
    SOFTWARE : Red Hat Linux Entreprise 4 Update 5 mise à jour hebdomadaire

  • #2
    Il n'y aurait pas plusieurs process de nagios en cours d'éxécution en même temps ?
    Guigui

    > PAS DE SUPPORT VIA MP <

    "Ce n'est qu'en essayant continuellement que l'on finit par réussir. En d'autres termes, plus ça rate et plus on a de chances que ça marche !!" (Shadoks)

    Comment


    • #3
      C'est meme sur

      Problème déjà rencontré plusieurs fois
      Centreon 2.x

      Comment


      • #4
        En effet ça semble résoudre le problème, j'avais deux processus nagios qui tournaient, merci pour votre aide.
        Par contre pourquoi n'ai-je jamais eu ce problème avec mon oreon 1.2.2 (et nagios 1.2 !) ?
        Celui-ci est toujours en prod' et à l'instant même où je vous parle, il y a 47 processus nagios qui tournent simultanément, il y en a toujours eu un grand nombre mais je n'ai jamais eu le problème...quelqu'un saurait me l'expliquer ?

        Comment


        • #5
          heu ....

          Test un simple reload via l'interface d'oreon sur ton env de prod, savoir si ca passe a 48. Dans ce cas ca ne serai pas normal.

          Mais alors pourquoi tu n'as jamais eu ce probleme avant... aucune idée.
          Centreon 2.x

          Comment


          • #6
            Voici ce qu'il se passe quand je redémarre nagios (sur mon environnement de prod', donc nagios 1.2 oreon 1.2.2).

            Avant redémarrage :
            [root ~]# ps -ef | grep /usr/local/nagios/bin/nagios | grep -v grep | wc -l
            45
            [root ~]# ps -ef | grep /usr/local/nagios/bin/nagios | grep -v grep | wc -l
            45
            [root ~]# ps -ef | grep /usr/local/nagios/bin/nagios | grep -v grep | wc -l
            45
            Redémarrage
            [root ~]# ps -ef | grep /usr/local/nagios/bin/nagios | grep -v grep | wc -l
            45
            [root ~]# ps -ef | grep /usr/local/nagios/bin/nagios | grep -v grep | wc -l
            46
            [root ~]# ps -ef | grep /usr/local/nagios/bin/nagios | grep -v grep | wc -l
            45
            [root ~]# ps -ef | grep /usr/local/nagios/bin/nagios | grep -v grep | wc -l
            47
            [root ~]# ps -ef | grep /usr/local/nagios/bin/nagios | grep -v grep | wc -l
            45
            [root ~]# ps -ef | grep /usr/local/nagios/bin/nagios | grep -v grep | wc -l
            45
            [root ~]# ps -ef | grep /usr/local/nagios/bin/nagios | grep -v grep | wc -l
            46
            [root ~]# ps -ef | grep /usr/local/nagios/bin/nagios | grep -v grep | wc -l
            47
            [root ~]# ps -ef | grep /usr/local/nagios/bin/nagios | grep -v grep | wc -l
            45
            [root ~]# ps -ef | grep /usr/local/nagios/bin/nagios | grep -v grep | wc -l
            46
            [root ~]# ps -ef | grep /usr/local/nagios/bin/nagios | grep -v grep | wc -l
            45
            [root ~]# ps -ef | grep /usr/local/nagios/bin/nagios | grep -v grep | wc -l
            45
            [root ~]# ps -ef | grep /usr/local/nagios/bin/nagios | grep -v grep | wc -l
            45

            Après c'est toujours 45...conclusion ?

            Comment


            • #7
              ou alors, arrêtes Nagios, attends un peu que les derniers checks se terminent et fait un ps axu | grep nagios.

              Normalement tu ne devrais plus avoir grand chose...
              Guigui

              > PAS DE SUPPORT VIA MP <

              "Ce n'est qu'en essayant continuellement que l'on finit par réussir. En d'autres termes, plus ça rate et plus on a de chances que ça marche !!" (Shadoks)

              Comment


              • #8
                Ou, ne le fait pas car c'est de la prod
                Centreon 2.x

                Comment


                • #9
                  En meme temps moi j'ai tjrs eu ce probleme récurant via oreon, le restart reload ne me tuer pas l'ancien nagios ...
                  Donc j'en arrivais à faire /etc/init.d/nagios2 stop/start/restart/reload
                  Et voila ...
                  J'ai regarder les fichier d'oreon et j'avais trouver qqc mais de la a me souvenir de quoi ...
                  Fouille un peu je pense que tu devrais pouvoir trouver du coté de la page outu as le choix du restart/reload dans oreon et du sudoers.

                  Bonne chance

                  Comment


                  • #10
                    regarde bien la conf de ton sudo...
                    Julien Mathis
                    Centreon Project Leader
                    www.merethis.com |

                    Comment

                    Working...
                    X