Announcement

Collapse
No announcement yet.

[RESOLU] Probleme rédémarrage Nagios à partir de centreon

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [RESOLU] Probleme rédémarrage Nagios à partir de centreon

    Voila , après avoir parcouru le forum à la recherche d'une solution pour mon problème et à les essayer sans succès ,je n'ai toujours rien trouver . J'explique mon problème :

    je n'arrive pas à reloader ou a restarter nagios à partir de l'interface de centreon, par contre via l'option commande externe ca marche.

    Je tien à signaler que dans les options d'oreon ou de nagios tout est OK je n'ai pas d'erreur apparentes .

    Le déplacement de fichier vers nagios fonctionne ossi , et je précise aussi que lorsque que je restart nagios via le terminale cela fonctionne sans problème.

    J'ai vérifier tous les droits sur les fichiers ils sont OK ainsi que le fichier sudoers qui lui aussi est OK.

    Je précise la version de nagios est nagios 2.10 , centreon 1.4.1, plugin nagios 1.4.10 et l'OS c'est une CentOS 5 avec apache 2, mysql derniere version ainsi que php derniere version .

    Merci d'avance à ceux qui pourront m'aider.

    Voila un screen
    Attached Files
    Last edited by donka44; 17 December 2007, 17:24.

  • #2
    Les droits sur le fichier sudoers sont ils corrects ?
    droits -> 440 root:root
    Guigui

    > PAS DE SUPPORT VIA MP <

    "Ce n'est qu'en essayant continuellement que l'on finit par réussir. En d'autres termes, plus ça rate et plus on a de chances que ça marche !!" (Shadoks)

    Comment


    • #3
      Ouai les droits dessus sont corrects , .

      c'est pour ca c'est assez etrange comme probleme . Puisque je l'ai installer (nagios + centreon ) en test ,au début , sur une ubuntu et tous marche dessus et donc j'ai tous verifier ,tous comparer et il n'y a vraiment rien qui differe. Et sur la CENTOS ca ne passe pas

      Comment


      • #4
        Tu as quoi qui s'affiche quand tu fais visudo sous root ?
        Intel(R) Xeon(TM) CPU 3.4GHz - MemTotal : 1034476 kB
        Centreon 2.4.1 - Nagios 3.2.1 - Nagios Plugins 1.4.15 - Manubulon Plugins tuné
        Fedora Core 5 - 2.6.20-1.2320

        Comment


        • #5
          Salut alors deja je serais toi j'esayerais
          Code:
          su - nagios
          sudo /etc/init.d/nagios2 restart/reload
          Ensuite si cela ne marche pas verifie que ton sudo est bon avec du memoire l'option NOPASSWD.

          Bonne journée

          Comment


          • #6
            Mais avant de faire ca, regarde si ton user nagios a un shell
            Centreon 2.x

            Comment


            • #7
              voila le résultat de visudo:
              #Add by OREON installation script
              User_Alias OREON= apache
              ## Nagios Restart
              OREON ALL = NOPASSWD: /etc/init.d/nagios restart
              ## Nagios reload
              OREON ALL = NOPASSWD: /etc/init.d/nagios reload
              ## Snmptrapd Restart
              OREON ALL = NOPASSWD: /etc/init.d/snmptrapd restart

              donc rien d'anormal.

              kan je fais su - nagios c'est OK.

              toujours le meme probleme qu'au debut
              impossible de redemarrer nagios a partir d'oreon .
              Last edited by donka44; 13 December 2007, 16:56.

              Comment


              • #8
                Tu as essayer le sudo apres le su - nagios ?
                Code:
                su - nagios
                sudo /etc/init.d/nagios2 restart/reload
                Car que le su - marche je t'avouerais que ca ne m'aporte pas grand chose
                Sinon il va falloir te pencher sur le code php ! Rien de très difficiel dans cette partie je pense.

                Comment


                • #9
                  oau le sudo c bon

                  Comment


                  • #10
                    Bien et bas dans ce cas la, tu n'a plus qu'a regarder ton fichier php
                    Je ne sais plus lequel c'est si tu me le trouve je peux y jeter un coup d'oeil ca ne sera qu'un peut plus de code dans la journée !
                    Je pense que tu devrais chercher dans configuration => nagios.php ?
                    enfin un truc du style celui qui te permet de reload la conf !

                    Comment


                    • #11
                      Peut-être un problème de sticky bit manquant sur sudo ?

                      Comment


                      • #12
                        A priori si le sudo /etc/init.d/nagios restart marche, sous un su - nagios ...
                        Le problème vient plus du coté du code.

                        Comment


                        • #13
                          du nouveau voila:

                          quand je fais su - nagios : c'est ok
                          par contre quand ensuite je fais : sudo /etc/init.d/nagios restart/reload : fonctionne pas il me demande le mot de passe de l'utilisateur nagios or je n'ai jamais mis de mot de passe pour l'utilisateur nagios lors de sa creation , du moin je crois.

                          Comment


                          • #14
                            Nan ,j'ai rien dis quelque modif et maintenant c'est bon quand je fais :
                            su - nagios
                            sudo /etc/init.d/nagios restart ou reload

                            c'est OK il ne me demande plus de mot de passe et il executer bien la commande et nagios redémarre .


                            A présent je vais essayer sous oreon voir si cela fonctionne ou pas .Je vous tien au courant.

                            Comment


                            • #15
                              de retour :
                              sous oreon le restart ne fonctionne toujours pas , par contre via command externe ca fonctionne
                              .

                              Comment

                              Working...
                              X