Announcement

Collapse
No announcement yet.

Ancienne config non effacée

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Ancienne config non effacée

    Bonjour,

    Voilà j'ai un problème, j'ai mon interface normale, la dernère que j'ai configuré, qui me dit bien que j'ai :
    11 hosts ok
    20 services ok
    1 service critik (normal).
    Cela m'indique aussi la derniere commande que j'ai créé qui s'appelle CPU (en majuscule).

    Mais parfois mon interface est remplacé par l'ancienne configuration qui m'indique :
    12 hosts ok
    2 hosts down
    14 services ok
    1 critik
    9 inconnu
    Et la commande est est mon ancienne, cpu (en minuscule)

    Pourquoi l'ancienne configuration s'affiche de temps en temps? (voir plus souvent que la nouvelle) j'ai pourtant bien suprimer les services et hosts en questions et ils n'aparaissent plus dans la liste de configuration ou de fiche d'identité.

    J'ai été voir dans /usr/local/nagios/etc :
    il n'y a qu'un seul host.cfg, service.cfg etc.
    Et ils ne contiennent plus les anciens hosts et services!
    Ou est-ce que centreon recupère ça?

    Comment faire pour supprimer définitivement l'ancienne configuration ?
    Last edited by LG_-; 5th March 2008, 08:53.
    Conf :
    - RedHat EL 5 -
    - Nagios 2.10 - Nagios plugins 1.4.11 - NDoutils 1.4b7 - Nagvis 1.2b3
    - Centreon 1.4.2.4 - PHP Weathermap 1.2 - Nagios StatusMap 1.1 -

  • #2
    Up ? :confused:
    Personne n'a une idée?
    J'ai réinstallé centréon avec la nouvelle version et refait toute une installation, l'ancienne config (celle qui restait alors qu'elle ne devait pas) est toujours là alors que l'ancienne config (la bonne) a bien été supprimé.
    Donc maintenant j'ai ma toute nouvelle config quasiment vide et de temps en temps dans le monitoring (et dans les cases d'état en haut) l'ancienne config revient!

    PS : meme après l'installation de centreon 1.4.2.4, quand on va dans Options -> A propos de...
    c'est toujours marqué version 1.4.2.3
    Conf :
    - RedHat EL 5 -
    - Nagios 2.10 - Nagios plugins 1.4.11 - NDoutils 1.4b7 - Nagvis 1.2b3
    - Centreon 1.4.2.4 - PHP Weathermap 1.2 - Nagios StatusMap 1.1 -

    Comment


    • #3
      stop nagios voir !
      Julien Mathis
      Centreon Project Leader
      www.merethis.com |

      Comment


      • #4
        Quand je stop nagios la vieille config est toujours affichée :confused:
        Conf :
        - RedHat EL 5 -
        - Nagios 2.10 - Nagios plugins 1.4.11 - NDoutils 1.4b7 - Nagvis 1.2b3
        - Centreon 1.4.2.4 - PHP Weathermap 1.2 - Nagios StatusMap 1.1 -

        Comment


        • #5
          Y'aurait pas plusieurs instances de Nagios en même temps ?
          Guigui

          > PAS DE SUPPORT VIA MP <

          "Ce n'est qu'en essayant continuellement que l'on finit par réussir. En d'autres termes, plus ça rate et plus on a de chances que ça marche !!" (Shadoks)

          Comment


          • #6
            C'est possible pourtant j'ai bien stopé nagios avec tout ce que je peux :

            /etc/rc.d/init.d/nagios stop
            /etc/init.d/nagios stop
            service nagios stop

            Donc nagios ne tourne pas!

            Et quand je vais voir sur nagios, il m'affiche ma configuration mais c'est tout.

            Et pendant ce temps la la vieille config de centreon continue de s'afficher, mais les informations renvoyées ne sont pas du tout réactualisé (apart l'heure du dernier controle si j'actualise)


            PS : C'est la fin de la journé, faudra que je m'y replonge demain, je verrai si je peux reboot la machine on ne sait jamais (j'ai un acces vnc).
            Last edited by LG_-; 4th March 2008, 16:52.
            Conf :
            - RedHat EL 5 -
            - Nagios 2.10 - Nagios plugins 1.4.11 - NDoutils 1.4b7 - Nagvis 1.2b3
            - Centreon 1.4.2.4 - PHP Weathermap 1.2 - Nagios StatusMap 1.1 -

            Comment


            • #7
              :mrgreen:

              Il suffisait d'un reboot!
              Quand un probleme ne se résout pas, pensez au reboot ^^
              Maintenant pourquoi c'est arrivé on ne le saura pas!
              Mais au moins si quelqu'un à le même problème, tentez le reboot!

              Merci d'avoir essayé quand même de m'aider en tout cas! ;-)
              Conf :
              - RedHat EL 5 -
              - Nagios 2.10 - Nagios plugins 1.4.11 - NDoutils 1.4b7 - Nagvis 1.2b3
              - Centreon 1.4.2.4 - PHP Weathermap 1.2 - Nagios StatusMap 1.1 -

              Comment

              Working...
              X