Announcement

Collapse
No announcement yet.

Centreon suddenly stops graphing, errors executing process-service-perfdata

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Centreon suddenly stops graphing, errors executing process-service-perfdata

    Bugger! ALL graphs have stopped adding new data since about 24 hours. No idea why Centreon stopped graphing.

    I upgrade from 2.0.2 to 2.1RC6 a few days agos and the graphing worked fine.

    The nagios.log says:

    [1247818259] Warning: Attempting to execute the command "/usr/local/nagios/libexec/process-service-perfdata &quot1247818248&quot &quotezhcom03&quot &quotLinux-CPU&quot &quotOK&quot &quotOK&quot &quotavg=5% cpu0=5%&quot" resulted in a return code of 127. Make sure the script or binary you are trying to execute actually exists...

    The script exists. I changed the rights to the script to be sure it is executable for everyone:

    Code:
    # ls -al /usr/local/nagios/libexec/process-service-perfdata
    -rwxrwxrwx 1 nagios nagcmd 1282 2008-08-17 15:00 /usr/local/nagios/libexec/process-service-perfdata
    Code:
    # ls -al /usr/local/nagios/var/service-perfdata
    -rw-rw-r-- 1 nagios nagios 37 2009-07-17 10:18 /usr/local/nagios/var/service-perfdata
    I restarted the services nd02db, centstorage, centcore, nagios. No result.


    When I execute the following command on the commandline:
    Code:
    # /usr/local/nagios/libexec/process-service-perfdata "1247818248" "ezhcom03" "Linux-CPU" "OK" "OK" "avg=5% cpu0=5%"
    Then I see the result in /usr/local/nagios/var/service-perfdata
    Code:
    # tail /usr/local/nagios/var/service-perfdata
    1247818248      ezhcom03        Linux-CPU       OK      OK      avg=5% cpu0=5%
    1247818248      ezhcom03        Linux-CPU       OK      OK      avg=5% cpu0=5%
    1247818248      ezhcom03        Linux-CPU       OK      OK      avg=5% cpu0=5%
    There are no other entires in this file, and it looks to me that empty lines are added to this file constantly... no data, just empty lines. And then the file is emptied again.
    Code:
    # tail /usr/local/nagios/var/service-perfdata
    # New File #
    (you see the empty lines under #New File# ? )

    This is quite a problem and I hate it seeing my beautifull graphs getting messed up.

    Any clues?
    Last edited by mrcoffee; 17th July 2009, 11:44. Reason: solved
    Centos 6.2 - Nagios 3.4.1 - Centreon 2.3.8 - NDO 1.5.2 - Centreon Syslog 1.4.1 - nagios status map - www.r71.nl www.360viewpoint.nl
    StatusMap Module - NDO Tools Module - ImportCSV Module - SNMP-UI Module

  • #2
    The configuration of the process-service-perfdata command looks like this:

    $USER1$/process-service-perfdata &quot$LASTSERVICECHECK$&quot &quot$HOSTNAME$&quot &quot$SERVICEDESC$&quot &quot$LASTSERVICESTATE$&quot &quot$SERVICESTATE$&quot &quot$SERVICEPERFDATA$&quot

    This could be the problem. I'm going to change the &quot with "

    $USER1$/process-service-perfdata "$LASTSERVICECHECK$" "$HOSTNAME$" "$SERVICEDESC$" "$LASTSERVICESTATE$" "$SERVICESTATE$" "$SERVICEPERFDATA$"

    This seems to be the right config, now I can see output in the /usr/local/nagios/var/service-perfdata file
    Code:
    # tail /usr/local/nagios/var/service-perfdata
    # New File #
    1247821979      ezhappl27       Windows-Virtual-Memory  OK      OK      memspace_free=3494MB memspace_used=450MB memspace_total=3944MB
    1247821979      ezhappl29       Windows-Virtual-Memory  OK      OK      memspace_free=585MB memspace_used=1117MB memspace_total=1702MB
    1247821982      ezhprtcn01      Drive-space-D   OK      OK      diskspace_free=50554MB diskspace_used=4055MB diskspace_total=54609MB
    1247821983      ezhappl36       HTTP    OK      OK      time=0.008042s;5.000000;10.000000;0.000000 size=730B;;;0
    1247821983      ezhappl28       Windows-Virtual-Memory  OK      OK      memspace_free=1303MB memspace_used=399MB memspace_total=1702MB
    And there are no errors anymore in the nagios.log file. I had to wait to see if the graphs worked again... et voilá ça marche bien! It works!

    Still, really weird how this command was messed up!
    Last edited by mrcoffee; 17th July 2009, 13:08.
    Centos 6.2 - Nagios 3.4.1 - Centreon 2.3.8 - NDO 1.5.2 - Centreon Syslog 1.4.1 - nagios status map - www.r71.nl www.360viewpoint.nl
    StatusMap Module - NDO Tools Module - ImportCSV Module - SNMP-UI Module

    Comment


    • #3
      Hi mrcoffee,

      It's the same that happen to me.

      Do you know why Centreon changes the ( " ) by the code ( " ) ?

      When I modify the "process-service-perfdata" command and I export the nagios files, the files are created well, but if I access again to the command from Centreon, the Centreon have changed the ( " ) by ( " ) again.


      Regards,

      Ramses

      Comment

      Working...
      X