Announcement

Collapse
No announcement yet.

Graphiques vides !

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Graphiques vides !

    Bonjour à tous,

    Je m'arrache les cheveux avec la génération des graphs.
    Tout marchait bien depuis plus de deux ans.
    J'ais passé la mise à jour 2.2.1 et depuis mes graphs n'apparaissent plus dans "Views -> Graphs".
    J'ai fais un tour dans les logs, rien, pas d'erreur.
    Le process centstorage et centcore tourne bien.
    Les confs sont OK. (binaire rrdtool, rep pour les perf-data, etc...).
    Mon fichiier /usr/local/nagios/var/service-perfdata se rempli bien avec les infos.
    La BDD mysql CENTSTORAGE est bien alimentée.
    Mon répertoire /var/lib/centreon/metrics/ est rempli de *.rrd.
    les logs /usr/local/centreon/log/centstorage.log disent que tout va bien:
    6/7/2011 18:54:20 - DB Tuning : /var/lib/centreon/metrics/1188.rrd
    6/7/2011 18:54:20 - Rebuild Graphs for Services : 738
    6/7/2011 18:54:20 - Get Data for rebuilding /var/lib/centreon/metrics/1189.rrd
    6/7/2011 18:54:20 - Rebuild database : /var/lib/centreon/metrics/1189.rrd (interval : 1800 - Len : 8640)
    6/7/2011 18:54:20 - New Database creation successful : /var/lib/centreon/metrics/1189.rrd
    6/7/2011 18:54:20 - DB Tuning : /var/lib/centreon/metrics/1189.rrd
    6/7/2011 18:54:20 - Get Data for rebuilding /var/lib/centreon/metrics/1190.rrd
    6/7/2011 18:54:20 - Rebuild database : /var/lib/centreon/metrics/1190.rrd (interval : 1800 - Len : 8640)
    6/7/2011 18:54:20 - New Database creation successful : /var/lib/centreon/metrics/1190.rrd
    6/7/2011 18:54:20 - DB Tuning : /var/lib/centreon/metrics/1190.rrd


    Mais toujours pas de graphs !
    Si quelqu'un à une suggestion je suis prenneur car la je ne sais plus où chercher, même sur le chan irc de centreon pas de révélation.
    Merci d'avance pour toute idée.

  • #2
    Pour info mon rrdtool est fonctionnel car:

    rrdtool info /var/lib/centreon/metrics/1083.rrd
    filename = "/var/lib/centreon/metrics/1083.rrd"
    rrd_version = "0001"
    step = 1200
    last_update = 1310028545
    ds[slash_var].type = "GAUGE"
    ds[slash_var].minimal_heartbeat = 12000
    ds[slash_var].min = NaN
    ds[slash_var].max = NaN
    ds[slash_var].last_ds = "UNKN"
    ds[slash_var].value = 1.6311850000e+06
    ds[slash_var].unknown_sec = 0
    rra[0].cf = "AVERAGE"
    rra[0].rows = 12960
    rra[0].pdp_per_row = 1
    rra[0].xff = 5.0000000000e-01
    rra[0].cdp_prep[0].value = NaN
    rra[0].cdp_prep[0].unknown_datapoints = 0
    rra[1].cf = "AVERAGE"
    rra[1].rows = 12960
    rra[1].pdp_per_row = 12
    rra[1].xff = 5.0000000000e-01
    rra[1].cdp_prep[0].value = 5.9860000000e+03
    rra[1].cdp_prep[0].unknown_datapoints = 0

    Comment


    • #3
      up ! please !

      Comment


      • #4
        Salut,

        Passe en 2.2.2 car des bugs autour de Centstorage ont été corrigés.
        Ensuite tu dis que ton fichier service-perfdata se rempli bien, il est bien mangé par centstorage ? CAD il se vide régulièrement ?
        Tout les chemins qui pointent vers ton fichier de performance sont bien identique dans tout les menu du web-gui ?
        Il faut vérifier dans Administration - options - centstorage / Configuration - Centreon - Poller / Configuration - Nagios - nagios.cfg - onglet données
        Et egalement le fichier process-service-perfdata qui doit se trouver dans ton dossier de plugins nagios/centreon

        J'ai eu le même symptôme quand j'ai fait le test sur mon DEV, j'avais oublié qu'après l'installation j'avais changé l'emplacement de ce fichier et comme j'ai repris les mêmes paramètres lors de la MAJ j'ai été confronté au même souchi Il m'a fallu quelques heures pour me rappeler le problème :/

        Bon courage !
        Ubuntu Server 10.04.4 x64 - Centreon 2.1.13 - Nagios 3.2.0
        Modules : ImportCSV 0.99rc5 - OCS2Cent 1.2.1 - Centreon-Gmap 1.2 - ndotools 0.2 - Centreon-NagVis 2.2b with NagVis 1.5.10

        Comment


        • #5
          Salut !

          Merci déjà de la réponse.

          Ensuite tu dis que ton fichier service-perfdata se rempli bien, il est bien mangé par centstorage ? CAD il se vide régulièrement ?
          Oui.

          Tout les chemins qui pointent vers ton fichier de performance sont bien identique dans tout les menu du web-gui ?
          Oui.

          Il faut vérifier dans Administration - options - centstorage
          --> /usr/local/nagios/var/service-perfdata

          Configuration - Centreon - Poller
          --> /usr/local/nagios/var/service-perfdata

          Configuration - Nagios - nagios.cfg - onglet données
          --> /usr/local/nagios/var/service-perfdata

          Et egalement le fichier process-service-perfdata qui doit se trouver dans ton dossier de plugins nagios/centreon
          locate process-service-perfdata
          /usr/local/nagios/libexec/process-service-perfdata
          => OK

          C'est désespérant !
          Voilà se que çà donne sur l'interface:
          http://hpics.li/9403220

          Je sais plus quoi faire...

          Comment


          • #6
            Problème résolu !

            Hallucinant mais même si l'ancien rrdtool marchait sur des tests manuels, j'ai tenté un ultime: rpm -ivh --force rrdtool-1.2.23-0.rhel4.i386.rpm

            Et miracle les graphs sont de retour !
            Merci à tosage pour l'interet qu'il à porté à mon post.

            Comment


            • #7
              De rien, les étapes que je t'ai donné sont, selon moi, les étapes pour troubleshotter ce type de problème

              D'ailleurs pour ta dernière phrase, dans le fichier process-service-perfdata il y a un chemin vers le fichier service-perfdata, dans ton cas dans /usr/local/nagios/var/xxxxx et ici il faut obligatoirement que ça soit le bon chemin. Si tes graph refonctionne c'est que c'est le cas

              En tout cas, good découverte pour RRDTool, j'y aurais pas pensé vu que tu avais une parti qui fonctionnait :rolleyes:
              Ubuntu Server 10.04.4 x64 - Centreon 2.1.13 - Nagios 3.2.0
              Modules : ImportCSV 0.99rc5 - OCS2Cent 1.2.1 - Centreon-Gmap 1.2 - ndotools 0.2 - Centreon-NagVis 2.2b with NagVis 1.5.10

              Comment


              • #8
                c est bibi qui a pensé sur IRC
                Raphael
                --
                Bi Intel(R) Xeon(TM) CPU 3.06GHz - 3Gb ram
                Debian
                Nagios® Core™ Version 3.2.1 - Nagios Plugins 1.4.14 - NDO 1.4b9 patché
                Centreon 2.3.4 - Syslog Module 1.3.2 - StatusMap Module 2.5 - NDO Tools Module 0.4 SVN - Nagvis
                Beta tester : centreon-engine - centreon-broker

                Comment


                • #9
                  bibi c'est un champion
                  J'y pense jamais au chan IRC, bien vu en tout cas !
                  Ubuntu Server 10.04.4 x64 - Centreon 2.1.13 - Nagios 3.2.0
                  Modules : ImportCSV 0.99rc5 - OCS2Cent 1.2.1 - Centreon-Gmap 1.2 - ndotools 0.2 - Centreon-NagVis 2.2b with NagVis 1.5.10

                  Comment


                  • #10
                    Oui encore merci raphaelt !
                    IRC > Forum

                    Comment

                    Working...
                    X