Announcement

Collapse
No announcement yet.

Authentification Nagvis

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Authentification Nagvis

    Bonjour,


    je ne sais pas si je suis dans la bonne section pour mon problème, si ce n'est pas le cas veuillez m'en excuser.


    Donc, utilisant un serveur web pour Centreon et Nagvis, j'ai voulu créer une page d'index du serveur où l'on a les deux icônes permettant d'accéder à leurs interfaces web. En cliquant sur l'icone "nagvis" je suis bien redirigé vers l'interface d'authentification de nagvis. Cependant, dés que je clique sur le bouton "login" je suis renvoyé sur ma page d'index précédente au lieu d'être sur la page d'accueil nagvis.


    Je n'ai pas ce problème si je rentre directement l'URL de nagvis dans le navigateur: "http://mon_serveur_web/nagvis".


    Voici les codes sources de ma page d'index :



    Code:
    <!DOCTYPE>
    <html>
        <head>
            <meta charset="UTF-8"/>
            <title>Index</title>
            <link href="style.css" type="text/css" rel="stylesheet">
        </head>
        <body>
            <div id="header">
                
            </div>
            <div id="corps">
                <a id="gauche" href="http://mon_serveur_web/centreon" ></a>
                <a id="droite" href="http://mon_serveur_web/nagvis"></a>
            </div>
        </body>
    </html>
    J'ai donc utilisé le plugin firebug pour voir plus en détail ce qu'il se passe et j'ai remarqué qu'effectivement, dans le formulaire d’authentification, de la page nagvis, l'URL n'est pas la même dans les deux cas.

    En passant par mon index :
    Code:
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    
    
    <html lang="en-US" dir="ltr" xmlns="http://www.w3.org/1999/xhtml">
    <head>
    
    <body class="login">
    <div id="login">
    <h1>
    <a style="background-image:url(/nagvis/frontend/nagvis-js/images/internal/logo.png)" title="NagVis 1.6 › Log In" href="#">NagVis 1.6 › Log In</a>
    
    
    </h1>
    
    <form id="loginform" method="post" action="http://mon_serveur_web/" name="loginform">
    
    
    
    </div>
    
    
    <script type="text/javascript">
    
    
    </body>
    
    
    
    </html>
    Alors qu'en passant directement par l'URL :
    Code:
    <form id="loginform" method="post" action="/nagvis/frontend/nagvis-js/index.php?Mod=Overview&act=view&show=" name="loginform">
    Vous en conviendrais, je ne suis pas un grand expert du développement web...
    Mais... Que passa ?! :confused:

  • #2
    On m'a conseillé un target="blank", le fait de changer de page aurait pus régler le problème. Cependant, toujours le même soucis...

    Comment


    • #3
      Help ! Il n'y aurait pas un petit dév' web par là ? Je comprend vraiment pas pourquoi le lien du bouton "login" change sur un simple appelle URL...

      Comment


      • #4
        Bonjour,

        de mémoire, lors de l'installation ou post install dans le fichier de config de nagvis, tu ne dois pas mettre l'url de base de nagvis? si tu as mal rempli ce champ cela explique ton probleme.
        Raphael
        --
        Bi Intel(R) Xeon(TM) CPU 3.06GHz - 3Gb ram
        Debian
        Nagios® Core™ Version 3.2.1 - Nagios Plugins 1.4.14 - NDO 1.4b9 patché
        Centreon 2.3.4 - Syslog Module 1.3.2 - StatusMap Module 2.5 - NDO Tools Module 0.4 SVN - Nagvis
        Beta tester : centreon-engine - centreon-broker

        Comment


        • #5
          Bonjour,


          merci de ta réponse raphaelt.


          J'ai vérifié lors de l'installation, le seul chemin de base à spécifier est lors du "Trying to detect Apache setting" où il est demandé : "please enter the web path to NagVis" qui est par défaut "/nagvis". Il me semble l'avoir mis par défaut, dans le doute je vais refaire une installation complète de nagivs.


          Dans le fichier de configuration de Nagis "nagvis.ini.php" les lignes qui pourraient correspondres sont dans la section [paths]. j'ai donc dé-commenté ces lignes pour avoir "htmlbase="/nagvis"", toujours le même problème. Mais il me semble que ceci est utilisé pour les URL template défini plus bas dans le fichier de configuration... D'ailleurs, j'ai modifé ces lignes pour pouvoir accéder à Centreon depuis Nagvis (si ça peut avoir un lien avec mon problème, mais j'en doute).


          Comme dis, je tente une réinstallation de Nagvis, dés que possible, en prenant soin de spécifier le chemin de base et vous tiens au courant. En attendant, si d'autres idées vous viens à l'esprit, n'hésitez pas ^^.

          Comment


          • #6
            Hello,

            Tu as regardé dans ton fichier de config apache? (par ici /etc/apache2/conf.d/nagvis.conf)
            tu devrais avoir :
            RewriteEngine On
            RewriteBase /nagvis (sûrement / dans ton cas)

            il faudra aussi que tu modifies les premières lignes des RewriteCond et RewriteRule pour modifier de /frondend en /nagvis/frontend
            Raphael
            --
            Bi Intel(R) Xeon(TM) CPU 3.06GHz - 3Gb ram
            Debian
            Nagios® Core™ Version 3.2.1 - Nagios Plugins 1.4.14 - NDO 1.4b9 patché
            Centreon 2.3.4 - Syslog Module 1.3.2 - StatusMap Module 2.5 - NDO Tools Module 0.4 SVN - Nagvis
            Beta tester : centreon-engine - centreon-broker

            Comment


            • #7
              Bonjour,

              Je suis allé voir dans le fichier de conf que tu m'as conseillé raphaelt, mais je n'y vois rien à modifier. Tout à l'aire OK.
              Le voici, si jamais j'ai raté quelque chose :
              Code:
              # NagVis Apache2 sample configuration file
              #
              # #############################################################################
              
              Alias /nagvis "/usr/local/nagvis/share"
              
              <Directory "/usr/local/nagvis/share">
                Options FollowSymLinks
                AllowOverride None
                Order allow,deny
                Allow from all
              
                # To enable Nagios basic auth on NagVis use the following options
                # Just uncomment it. Maybe you need to adjust the path to the
                # Auth user file.
                #
                # If you use the NagVis internal auth mechanism based on the web
                # for you won't need this.
                #
                #AuthName "NagVis Access"
                #AuthType Basic
                #AuthUserFile /usr/local/nagios/etc/htpasswd.users
                #Require valid-user
                
                # With installed and enabled mod_rewrite there are several redirections
                # available to fix deprecated and/or wrong urls. None of those rules is
                # mandatory to get NagVis working.
                <IfModule mod_rewrite.c>
                  RewriteEngine On
                  RewriteBase /nagvis
                  
                  # Use mod_rewrite for old url redirection even if there are php files which
                  # redirect the queries itselfs. In some cases the mod_rewrite redirect
                  # is better than the php redirect.
                  #
                  # Using the php redirect seems to be better in some cases where https/http servers
                  # are mixed. For example in OMD setups where using apache own mode and https in the
                  # frontend and http in the backend apache servers.
                  #
                  # Disabling this redirect by default in the hope that the php direct works better.
                  #RewriteCond %{REQUEST_URI} ^/nagvis(/config\.php|/index\.php|/|)(\?.*|)$
                  #RewriteRule ^(.*)$ /nagvis/frontend/nagvis-js/%1%2 [R=301,L]
                  
                  # Redirect old regular map links
                  RewriteCond %{REQUEST_URI} ^/nagvis/frontend/(wui|nagvis-js)
                  RewriteCond %{QUERY_STRING} map=(.*)
                  RewriteRule ^(.*)$ /nagvis/frontend/nagvis-js/index.php?mod=Map&act=view&show=%1 [R=301,L]
              
                  # Without map= param
                  RewriteCond %{REQUEST_URI} ^/nagvis/frontend(/wui)?/?(index.php)?$
                  RewriteRule ^(.*)$ /nagvis/frontend/nagvis-js/index.php [R=301,L]
              
                  # Redirect old rotation calls
                  RewriteCond %{REQUEST_URI} ^/nagvis/frontend/nagvis-js
                  RewriteCond %{QUERY_STRING} !mod
                  RewriteCond %{QUERY_STRING} rotation=(.*)
                  RewriteRule ^(.*)$ /nagvis/frontend/nagvis-js/index.php?mod=Rotation&act=view&show=%1 [R=301,L]
                </IfModule>
              </Directory>
              Je vais réinstaller Nagvis comme dis plus haut dans la journée, je vous tiens au courant du résultat.

              Merci encore de votre aide !

              Comment


              • #8
                Après réinstallation de Nagvis, toujours rien de nouveau. Même problème...

                C'est quand même fou comme truc, j'ai toujours pensé que le fait de cliquer sur un lien ou de rentrer nous même L'URL revenait au même. Apparemment non... Il y aurait quelque chose de différent entre les deux manipulation qui changerait l'appel sur le bouton "Login" ?

                Comment se prendre la tête sur quelque chose qui est à la base très simple... :mad:

                Comment

                Working...
                X