Announcement

Collapse
No announcement yet.

[REGLE] Bug dans la sauvegarde des param des Notifications

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [REGLE] Bug dans la sauvegarde des param des Notifications

    Salut tout le monde,

    Bon, voilà mon problème ... quand je vais dans mes définitions de Notifications afin de modifier une commande de notifications par mail, je tape :
    Code:
    /usr/bin/printf "%b" "***** Nagios  *****\n\nNotification Type: $NOTIFICATIONTYPE$\nHost: $HOSTNAME$\nState: $HOSTSTATE$\nAddress: $HOSTADDRESS$\nInfo: $OUTPUT$\n\nDate/Time: $DATETIME$\n" |  /usr/bin/mail -s "Host $HOSTSTATE$ alert for $HOSTNAME$!" $CONTACTEMAIL$
    Bon, jusqu'ici tout va bien. Mais quand je sauvegarde ma commande ... alors là : SURPRISE !! Elle apparait dans ce format :
    Code:
    /usr/bin/printf \"%b\" \"***** Nagios  *****\\n\\nNotification Type: $NOTIFICATIONTYPE$\\nHost: $HOSTNAME$\\nState: $HOSTSTATE$\\nAddress: $HOSTADDRESS$\\nInfo: $OUTPUT$\\n\\nDate/Time: $DATETIME$\\n\" |  /usr/bin/mail -s \"Host $HOSTSTATE$ alert for $HOSTNAME$!\" $CONTACTEMAIL$
    Si je fais plusieurs fois la commande Modifier puis Sauvegarder sans rien changer à la ligne de commande, ça donne un truc chelou dans le genre :
    /usr/bin/printf \\\\\\\"%b\\\\\\\" \\\\\\\"***** Nagios *****\\\\\\\\n\\\\\\\\nNotification Type: $NOTIFICATIONTYPE$\\\\\\\\nHost: $HOSTNAME$\\\\\\\\nState: $HOSTSTATE$\\\\\\\\nAddress: $HOSTADDRESS$\\\\\\\\nInfo: $OUTPUT$\\\\\\\\n\\\\\\\\nDate/Time: $DATETIME$\\\\\\\\n\\\\\\\" | /usr/bin/mail -s \\\\\\\"Host $HOSTSTATE$ alert for $HOSTNAME$!\\\\\\\" $CONTACTEMAIL$
    Il y a donc un os quelque part ... je cherche, je cherche ...

    @+, Burzuum

    Info : Nagios 1.3, Oreon 1.2.2, Linux Ubuntu 5.10

  • #2
    bug ultra connu, déja vu sur le forum.

    Solution : upgrader il me semble.
    Intel(R) Xeon(TM) CPU 3.4GHz - MemTotal : 1034476 kB
    Centreon 2.4.1 - Nagios 3.2.1 - Nagios Plugins 1.4.15 - Manubulon Plugins tuné
    Fedora Core 5 - 2.6.20-1.2320

    Comment


    • #3
      Originally posted by DonKiShoot
      bug ultra connu, déja vu sur le forum.

      Solution : upgrader il me semble.
      Il me semblait pourtant corrigé justement depuis la 1.2.2...
      Raphaël 'SurcouF' Bordet
      Je ne teste pas mes plugins en root, tu ne testes pas tes plugins en root...
      Dons Paypal

      Comment


      • #4
        Originally posted by surcouf
        Originally posted by DonKiShoot
        bug ultra connu, déja vu sur le forum.

        Solution : upgrader il me semble.
        Il me semblait pourtant corrigé justement depuis la 1.2.2...
        oui mais non... on se récupére ce bug a chaque fois...
        on est dessus...
        StatusMap Module - NDO Tools Module - ImportCSV Module - SNMP-UI Module - PDFReports Module
        Dons Paypal

        Comment


        • #5
          Bon alors en fait il a fallu que j'aille trifouiller dans le fichier command.class.php et commenter dans la commande "command" la fonction addslashes qui me rajoutait des slashs à tout bout de champ ... :?

          Bon maintenant, il faut bien dire que j'ai un peu pris le calibre 12 pour corriger ce bug m'enfin bon ...

          Maintenant ca marche ...

          @+, Burzuum

          Comment

          Working...
          X