Announcement

Collapse
No announcement yet.

Envoie de mails

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Envoie de mails

    Bonjour, j'ai un soucis avec les envoies de mail de Oreon. En effet quand il y a un probleme sur l'un des service, aucun mail ne m'est envoyé.
    Pourtant j'ai bien créer un utilisateur avec mon adresse mail dans "Contact" et je l'ai affecter à un groupe "Administrateurs" dans "Contact Group".
    Mon service a les options suivantes :

    Is Volatile : Nothing
    Service Groups :
    Check_command : check_graph_ping
    Check_command_arguments :
    Max_check_attempts : 3
    Normal_check_interval : 2 * 60 secondes
    Retry_check_interval : 1 * 60 secondes
    Active_checks_enabled : Nothing
    Passive_checks_enabled : Nothing
    Check_period : workhours
    Parallelize_check : Nothing
    Obsess_over_service : Nothing
    Check_freshness : Nothing
    Freshness treshold : 0 secondes
    Event_handler :
    Event_handler_arguments :
    Event_handler enabled : Nothing
    Low flap treshold : 0 %
    High flap treshold : 0 %
    Flap_detection_enabled : Nothing
    Process_perf_data : Nothing
    Retain_status_information : Nothing
    Retain_nonstatus_information : Nothing
    Notification_interval : 5 * 60 secondes
    Notification_period : 24x7
    Notification_options : w,u,c,r
    Notification_enabled : Yes
    # Contact Groups : Administrateurs
    Stalking_options : o,w,u,c
    Etat : Activé

    Pour le contact :

    Host Notification options : d,u,r
    Service Notification options : w,u,c,r
    Host notification period : 27*7
    Host_notification_command : notify-by-email & host-notify-by-email
    Service_notification_command : notify-by-email & host-notify-by-email
    Etat : Activé



    J'ai essayer d'envoyer un mail directement de mon serveur en ligne de commande et le mail m'est bien parvenue (il n'y a donc pas de soucis au niveau de la configuration de postfix).
    Etant totalement novice en la matiere, j'ai essayer de chercher un peut dans les fichiers de logs de nagios, mais il ne m'indique aucunes erreurs concernant les mails.
    Pourtant il me remonte bien les alertes dans Oreon lorsque je regarde le status d'un service ou dans le calendrier.

    Si vous avez besoin d'informations suplémentaires je reste a votre disposition.

    Merci d'avance

  • #2
    Dans les Options d'Oreon, le binaire Mail est bien défini ?
    Dans le wiki, tu as une aide pour paramétrer Postfix
    Ubuntu 8.04
    Nagios 3.2 + nagios-plugins-1.4.14
    ndoutils-1.4b9
    Centreon 2.1.8
    centreon-syslog-frontend-1.2.1 + centreon-syslog-server-1.1

    Comment


    • #3
      autre soucis que j'ai pu rencontrer dans le définition des notifications le path dans le plugin n'était pas bon, il était /bin/mail et moi c'était /usr/bin/mail... voila sur les six plugins, j'ai du en modifier 4...

      :wink:



      PS; le path aussi à du etre modifié...

      Comment


      • #4
        j'ai bien changer le binaire mail car sur ma debian il se trouve dans "/usr/bin/mail"
        je l'avais donc changer dés le debut mais j'avoue que je n'ai pas regarder la syntaxe des commandes et a ce que je viens de regarder elel n'ai pas bonne !

        J'espere que ca va resoudre mon probléme, en tout cas merci a vous pour votre reactivitée

        Alexis

        Comment


        • #5
          Je viens de regarder, j'ai changer les notifications en remplacant "/bin/mail" par "/usr/bin/mail" mais rien n'a changer, je ne recoi toujours aucun mail.

          Y a t'il un fichier de log dans lequel je pourrais regarder pour savoir si il essaye ou non de m'envoyer ce mail, parce que je commence a avoir des doutes!

          Merci d'avance

          Comment


          • #6
            Bonjour,

            Dans le fichier nagios.log, il doit y avoir une ligne 'service notification'. De plus, tu peux regarder les logs de ton serveur de mail sur la machine Nagios.

            Comment


            • #7
              Je viens de regarder comme tu me l'a conseiller dans le fichier nagios.log
              Aucune information concernant l'envoie de mail ni de ligne avec 'service notification' o_O

              J'ai egalement regardée les logs du serveur Nagios concernant les mails (/var/log/mail.* ) aucune informations, comme si Nagios n'essayer meme pas d'envoeyr de mail

              Comment


              • #8
                Tu n'as pas cochée les cases "n" pour les contacts et le services? (n signifie "none", aucune notification)

                Comment


                • #9
                  Negatif :roll:

                  Comment

                  Working...
                  X