Announcement

Collapse
No announcement yet.

Probleme ajout service

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Probleme ajout service

    J'ai installe Oreon il y a peu de temps et je me trouve coince a la creation de service.
    Le probleme est que je ne peux pas ajouter de service sous peine de fatal error
    Je recois cette erreur aussi en effectuant un ajout de service manuellement ou meme en chargeant la config globale de mon nagios
    Fatal error: Call to a member function on a non-object in /usr/local/oreon/class/Service.class.php on line 229

    Si vous avez une idee ou un lien je suis preneur

    ps : j'ai trouve qu'un post qui en parlait

    I had the same problem. If you look in the services.cfg, it is putting "servicegroups" as a line, even though it's not specified. If this is the case, you can comment out the code in the /usr/local/oreon/include/export/services.php. There is an if statement that checks to see if you're using Nagios 2.0+. Comment out that block.

    Mais ca m'a pas aide
    Sur un clavier anglais, donc pas d'accent

  • #2
    personne a une peite idee ?
    Sur un clavier anglais, donc pas d'accent

    Comment


    • #3
      Tu as activé javascript sur ton navigateur?

      Comment


      • #4
        oui ,j ai bien javascript dessus mais je vois pas le rapport entre javascript et mon probleme ?
        Je vais tester une ancienne version stable de oreon et je vous tiens au courant

        Edit :
        erf non ca change rien j ai toujours cette erreur quand je cree manuellement mes services et j en ai une autre quand je charge la config de nagios ...
        Sur un clavier anglais, donc pas d'accent

        Comment


        • #5
          Est ce que tu as fait un import de configuration? Si oui, peut être que l'import c'est mal passé. Sinon, je ne vois vraiment pas d'où vient le problème. Essaye avec la dernière version d'Oreon.

          Comment


          • #6
            Oui, je fais bien un import de la config de nagios, tout ce passe bien pour les autres fichiers, j ai mes hosts, mes contacts enfin tout .... sauf mes amis les services ... qui me genere une
            erreur.
            ### Erreur, quand j'import tout ###
            * Fichiers uploadés avec succès

            * Extraction Complète :
            cgi.cfg
            checkcommands.cfg
            contactgroups.cfg
            contacts.cfg
            dependencies.cfg
            escalations.cfg
            hostgroups.cfg
            hosts.cfg
            minimal.cfg
            misccommands.cfg
            nagios.cfg
            resource.cfg
            services.cfg
            timeperiods.cfg


            Fatal error: Call to a member function on a non-object in /usr/local/oreon/class/NagiosConfigFile.class.php on line 949

            ### l'erreur quand je cree manuellement un service ###

            Fatal error: Call to a member function on a non-object in /usr/local/oreon/class/Service.class.php on line 229


            ps : Je suis sur un clavier anglais donc Je ne peux pas mettre d accent
            Sur un clavier anglais, donc pas d'accent

            Comment


            • #7
              Bonjour,

              Et ben voilà, tu as trouvé le problème. Je suppose que tu utilises une version 1.2.x. L'import ne fonctionne pas parfaitement sur ces versions. Essaye la nouvelle version.

              Comment


              • #8
                ha oauis.... ca c'est sur si c'est la 1.2.*
                Julien Mathis
                Centreon Project Leader
                www.merethis.com |

                Comment


                • #9
                  Originally posted by templuche
                  Bonjour,

                  Et ben voilà, tu as trouvé le problème. Je suppose que tu utilises une version 1.2.x. L'import ne fonctionne pas parfaitement sur ces versions. Essaye la nouvelle version.
                  quand tu parles de la nouvelles version c'est la beta 1.3 ?
                  Sur un clavier anglais, donc pas d'accent

                  Comment


                  • #10
                    oui
                    Julien Mathis
                    Centreon Project Leader
                    www.merethis.com |

                    Comment


                    • #11
                      Ok, je test ca
                      Sur un clavier anglais, donc pas d'accent

                      Comment


                      • #12
                        aie,
                        DB_DataObject Failed
                        Need DB_DataObject-1.8.4
                        DB_DataObject_FormBuilder Failed
                        Need DB_DataObject_FormBuilder-1.0.0RC4
                        MDB2 Failed
                        Need MDB2-2.0.0
                        Date OK
                        Numbers_Roman Failed
                        Need Numbers_Roman-1.0.1
                        Numbers_Words Failed
                        Need Numbers_Words-0.14.0
                        HTML_Common Failed
                        Need HTML_Common-1.2.2
                        HTML_QuickForm Failed
                        et j'en passe,

                        Je crois avoir trouve ce qu 'il me manquait dans la liste des prerequis, le probleme s'est que c'est tout en rpm, je tourne sur debian, il y a pas des .deb deja tout fait ?
                        Sur un clavier anglais, donc pas d'accent

                        Comment


                        • #13
                          non non ca c'est pear ca n'a rien a voir
                          Julien Mathis
                          Centreon Project Leader
                          www.merethis.com |

                          Comment


                          • #14
                            desole euh je debute,
                            j ai pas compris, c'est pear ? j arrive pas a installer le dernier oreon
                            Sur un clavier anglais, donc pas d'accent

                            Comment

                            Working...
                            X