Announcement

Collapse
No announcement yet.

Oreon 1.3 beta Aucun soucis d'install mais Message d'erreur

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • djawax
    replied
    Originally posted by pepito
    Rien ne change entre la 1.2.3 et la 1.3 à part les menus...
    Comme dirait la doc de Nagios: RTFM

    Si tu regardes dans ton menu de Configuration, est ce que tu vois des hôtes, des services?

    Sinon rajoutes au moins une machine dans tes hôtes (voir menu Configuration-> host)
    Si tu veux t'amuser à voir des graphes, rajoute un service check_graph_ce_que_tu_veux.

    Redémarre le tout, attend quelques minutes et puis tu devrais voir un peu de vie dans monitoring.
    ou j'ai ajouter un host et un service, mais je n'ai rien, mais je vais recommencer depuis le départ et relire la doc du 1.2.3 j'ai du oublier quelque chose.
    Merci

    Leave a comment:


  • pepito
    replied
    Rien ne change entre la 1.2.3 et la 1.3 à part les menus...
    Comme dirait la doc de Nagios: RTFM

    Si tu regardes dans ton menu de Configuration, est ce que tu vois des hôtes, des services?

    Sinon rajoutes au moins une machine dans tes hôtes (voir menu Configuration-> host)
    Si tu veux t'amuser à voir des graphes, rajoute un service check_graph_ce_que_tu_veux.

    Redémarre le tout, attend quelques minutes et puis tu devrais voir un peu de vie dans monitoring.

    Leave a comment:


  • djawax
    replied
    Originally posted by pepito
    Dans le menu configuration -> Nagios
    C'est d'ici que tu regénères les fichiers de conf de nagios (les fichier host, service.cfg et tout ca)

    Les 3 dernières options te permettent:
    - de vérifier que tes fichiers on une syntaxe correcte
    - de les déplacer dans le dossier de conf de nagios (...../nagios/etc/) (enfin je crois)
    - de relancer nagios

    Toutes tes modifs sont dans la base de donnée de oreon et dans des fichiers de conf mais à l'abri.
    Quand tu les génères, ils sont placés dans un dossier de oreon, bien a l'abri. (enfin ca aussi je crois )

    Si tu ne les déplace pas dans le dossier de nagios, celui-ci n'a aucune idée des modifs que tu as fais! Donc quand tu le redémarres, c'est comme si tu n'avais rien modifié...

    j'ai été clair ou je me suis noyé? ops:
    Ok je vois merci pour cette réponse, j'ai mis
    Lancer le debug de Nagios (-v) Oui
    Déplacer les fichiers Oui
    Redémarrer Nagios Oui

    je vois ensuite les fichiers de conf donc tu as répondu à ma question cet partie du problème est résolu.

    Mais après quand je regarde le status des hosts et services j'ai 0 partout dans monitoring, donc à mon avis il manque quelque chose ou que je n'ai pas bien fait.

    Si quelqu'un à un petit tutorial ou explication sur comment créer un host alive par exemple pour un pc. Pour la version 1.3 beta merci. Je n'ai pas l'impression qu'il faut faire comme dans la version 1.2.3.

    Donc un exemple de a à z pour créer un host alive pour voir si un pc est actif avec les groupes, les services.
    Ou un lien ou je puisse trouvé une piste en attendant qu'un tutorial soit fait pour la 1.3.

    Merci

    Leave a comment:


  • pepito
    replied
    Dans le menu configuration -> Nagios
    C'est d'ici que tu regénères les fichiers de conf de nagios (les fichier host, service.cfg et tout ca)

    Les 3 dernières options te permettent:
    - de vérifier que tes fichiers on une syntaxe correcte
    - de les déplacer dans le dossier de conf de nagios (...../nagios/etc/) (enfin je crois)
    - de relancer nagios

    Toutes tes modifs sont dans la base de donnée de oreon et dans des fichiers de conf mais à l'abri.
    Quand tu les génères, ils sont placés dans un dossier de oreon, bien a l'abri. (enfin ca aussi je crois )

    Si tu ne les déplace pas dans le dossier de nagios, celui-ci n'a aucune idée des modifs que tu as fais! Donc quand tu le redémarres, c'est comme si tu n'avais rien modifié...

    j'ai été clair ou je me suis noyé? ops:

    Leave a comment:


  • djawax
    replied
    Originally posted by pepito
    il ne faut pas oublier de déplacer les fichiers lorsque tu redémarres.
    Sans ça je crois que les fichiers de conf ne sont pas modifiés.
    Là j'ai louper quelque chose, déplacer quoi vers où? S'il te plait.

    Leave a comment:


  • pepito
    replied
    il ne faut pas oublier de déplacer les fichiers lorsque tu redémarres.
    Sans ça je crois que les fichiers de conf ne sont pas modifiés.

    Leave a comment:


  • Oreon 1.3 beta Aucun soucis d'install mais Message d'erreur

    Bonjour,

    Interface superbe! .

    Pour l'installation j'ai pris nagios2 et je suis en apache2 pas de soucis particulier a part:

    - le chemin de pear qui pour moi etait dans php.
    - le snmp.so qui était bien installer mais extension=snmp.so n'était pas dans php.ini pour apache2.
    -Pear et ses extension à ajouter, j'ai finit par comprendre comment ca s'installait mais j'ai mis 20 min a trouver les infos sur google et comprendre comment il fallait ajouter tous les modules de PEAR.

    - Pour le reste je ne sais pas rien n'a foncitonner pour le moment.
    J'ai creer un host, un host group, un service par host, service par hostgroup et un service group juste avec un check host alive et j'ai redémarrer nagios. Et là rien, faut-il faire comme dans la version 1.2.3 ou cela a t-il changer ou il manque quelque chose que je n'ai pas fait.

    Quelqu'un peut-il me donner un exemple complet pour pouvoir au moin faire un check_host_alive sur un pc pour voir si ca fonctionne peut etre que je ne fais pas comme il faut, pourtant je pense avoir fait la meme chose qu'avec la version 1.2.3 puisque ca fonctionnait.

    J'ai vu un seul message d'erreur dans l'interface qui se situe dans monitoring puis gestionnaire d'évenement et la j'ai ce message dans tous les logs
    "Warning: fgets(): supplied argument is not a valid stream resource in /usr/local/oreon/www/include/monitoring/log/viewLog.php on line 38"

    puis dans notifications:
    "Warning: fgets(): supplied argument is not a valid stream resource in /usr/local/oreon/www/include/monitoring/log/viewNotifyLog.php on line 44"

    et dans alertes:
    "Warning: fgets(): supplied argument is not a valid stream resource in /usr/local/oreon/www/include/monitoring/log/viewAlertLog.php on line 42"

    et erreur/avertissements:
    "Warning: fgets(): supplied argument is not a valid stream resource in /usr/local/oreon/www/include/monitoring/log/viewWarnLog.php on line 39"

    Je suis sur debian 2.6.8-2
Working...
X