Announcement

Collapse
No announcement yet.

SNMP TABLE ERROR : No response from remote host 'x.x.x.x'.

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • SNMP TABLE ERROR : No response from remote host 'x.x.x.x'.

    Hello Everybody,
    I am using FAN, since couple of days, as a starting excersize i added a new host(MY PC where i am using centreon) with 2 services ping and disk space in C: all went well.
    Today i tried to add a new host offcourse the host lies on the same network, configured SNMP exactly the same way i did for my PC(Working fine), added the new host on centreon interface , restarted the nagios from configuration.
    only service which is working is PING , rest of the services are not working and are titles as UNKNOWN with the error "SNMP TABLE ERROR : No response from remote host 'x.x.x.x'." I tried alot of things like
    uninstalling SNMP services from the host , restarting, reinstalling, re configuring but nothing helps.
    Please help me .
    My journey on centreon/nagios is very long, dont want to stop for a silly problem
    Thanx everyone

  • #2
    Hello,

    for understand where is the problem I advise you to use capture_plugin.pl

    show this site : http://www.waggy.at/nagios/capture_plugin.htm

    I think you can find your problem with this tool.

    Regards

    Comment


    • #3
      Thankyou rcaboche,
      Well i would like to add one more information
      the Host i want to monitor is a virtual machine created by VMware.
      And i configured the SNMP settings as it was a physical machine. and i have absolutely no idea how to configure a virtual machine.
      anyway OS of this virtual machine is windows server 2008 r2

      Comment


      • #4
        Solution...

        Originally posted by furqan View Post
        Thankyou rcaboche,
        Well i would like to add one more information
        the Host i want to monitor is a virtual machine created by VMware.
        And i configured the SNMP settings as it was a physical machine. and i have absolutely no idea how to configure a virtual machine.
        anyway OS of this virtual machine is windows server 2008 r2

        Hi ,
        I was having the same problem.
        You need to modify the templates related to Windows so that the Community field $USER2$ will become $_HOSTSNMPCOMMUNITY$ .
        Re-generate the service for the machine you've already configured and "Et Voilà!".:grin:

        Regards

        Comment


        • #5
          Hello,

          Thanks for your comments. How can I download the plugin with Unix commands please ?
          I have the same problem.

          Comment


          • #6
            You can find the configuration of centreon_ping :

            $USER1$/check_icmp -H $HOSTADDRESS$ $_HOSTSNMPCOMMUNITY$-n $ARG1$ -w $ARG2$ -c $ARG3$

            Any problem of configuration ?

            Comment

            Working...
            X