Announcement

Collapse
No announcement yet.

Graphique ? camenberts ?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Graphique ? camenberts ?

    Salut,

    je souhaite faire apparaitres des graphique sur l'oeron et je voulais savoir les bases pour les mettre en place.

    j'ai lu qu'il fallait artichow ou perfparse mais comment les configure t'on ?

    Lequel choisir ?

    Merci

    ps: moi aussi je veux de beaux camenbos

  • #2
    pour les caprices des dieux, il faut simplement GD apparement.

    Pour les graphiques, en passant par le menu sondes graphiques, il te faut simplement rrdtools.
    Si tu veux avoir les graphes en cliquant sur la petite icone, alors là il te faut perfparse (enfin pour l'instant, je crois que pour la prochaine beta tu ne seras plus obligé de l'installer)
    RedHat Advanced Server 4.0
    Nagios 2.3.1
    Oreon 1.3b1

    Comment


    • #3
      Pour la 1.3, les camemberts sont geres avec pear, artichow a disparu.

      Au niveau des graphs, vous avez toujours la possibilite d'utiliser les sondes graphiques et de generer des bases rrd.
      On vous propose en plus d'utiliser les infos de perfparse afin de faire du reporting de meilleur qualite, melange de courbes etc...

      Ce n'est pas du tt prevu d'integrer perfparse a l'install d'Oreon, on vous laisse le bon soin de cette etape.
      Romain Le Merlus
      Centreon Forge
      MERETHIS

      Comment


      • #4
        Bonjour,

        Pour la 1.3, les camemberts sont geres avec pear, artichow a disparu.
        Problème de licence ou choix technique?

        Comment


        • #5
          Choix technique.
          Romain Le Merlus
          Centreon Forge
          MERETHIS

          Comment


          • #6
            Salut,

            le probleme est que dans l'interface des sondes graphiques aucun de mes hosts n'apparait donc je ne vois pas comment generer ces graphs

            Ce comportement est il normal ?

            Merci

            Comment


            • #7
              j'ai eut ce problème.
              Il a disparu quand j'ai généré, déplacé les fichiers et redémarré nagios...
              RedHat Advanced Server 4.0
              Nagios 2.3.1
              Oreon 1.3b1

              Comment


              • #8
                je l'ai fait de nombreuses fois le restart/reload de nagios sans succès.



                sniff moi le probleme reste

                Comment


                • #9
                  c'est là l'astuce!
                  Le restart de nagios ne sert à rien tant que tu n'as pas généré et déplacé les fichiers par l'interface de oreon.
                  RedHat Advanced Server 4.0
                  Nagios 2.3.1
                  Oreon 1.3b1

                  Comment


                  • #10
                    c'etait bien fait aussi je ne restart jamais nagios sans avoir deplacé au prealable les fichiers

                    Comment


                    • #11
                      ben à part chercher des erreurs dans les logs...
                      RedHat Advanced Server 4.0
                      Nagios 2.3.1
                      Oreon 1.3b1

                      Comment


                      • #12
                        cela ne peutil pas venir d'un parametre a la con dans la creation du service ou du host ?

                        Comment


                        • #13
                          si tu lance la vérification par ligne de commande?

                          Code:
                          nagios -v /usr/local/nagios/etc/nagios.cfg
                          RedHat Advanced Server 4.0
                          Nagios 2.3.1
                          Oreon 1.3b1

                          Comment


                          • #14
                            si je lance cette commande tout est ok seulement 2 warning

                            Nagios 1.4
                            Copyright (c) 1999-2006 Ethan Galstad ([email protected])
                            Last Modified: 05-03-2006
                            License: GPL

                            Reading configuration data...

                            Running pre-flight check on configuration data...

                            Checking services...
                            Checked 67 services.
                            Checking hosts...
                            Warning: Host 'Meta_Module' has no services associated with it!
                            Checked 12 hosts.
                            Checking host groups...
                            Checked 7 host groups.
                            Checking contacts...
                            Checked 5 contacts.
                            Checking contact groups...
                            Warning: Contact group 'user' is not used in any hostgroup/service definitions or host/hostgroup/service escalations!
                            Checked 3 contact groups.
                            Checking service escalations...
                            Checked 0 service escalations.
                            Checking host group escalations...
                            Checked 0 host group escalations.
                            Checking service dependencies...
                            Checked 0 service dependencies.
                            Checking host escalations...
                            Checked 0 host escalations.
                            Checking host dependencies...
                            Checked 0 host dependencies.
                            Checking commands...
                            Checked 52 commands.
                            Checking time periods...
                            Checked 5 time periods.
                            Checking for circular paths between hosts...
                            Checking for circular service execution dependencies...
                            Checking global event handlers...
                            Checking obsessive compulsive service processor command...
                            Checking misc settings...

                            Total Warnings: 2
                            Total Errors: 0

                            J'ai regardé un peu sur le forum US et j'ai vu ceci

                            path du RRDs.pm n'etait pas bon sur ma config, je m'explique :

                            emacs /usr/lib/nagios/plugins/oreon.pm

                            origine
                            use lib qw(/usr/local/rrdtool/lib/perl ../lib/perl);

                            ma modif
                            use lib qw(/usr/lib/perl5/RRDs.pm /usr/bin/perl);

                            cela vous semble t'il mieux ?

                            sachant que :

                            srv-sup-rs:/etc/oreon/rrd# whereis perl
                            perl: /usr/bin/perl /etc/perl /usr/lib/perl /usr/share/perl /usr/share/man/man1/perl.1.gz

                            srv-sup-rs:/etc/oreon/rrd# locate RRDs.pm
                            /usr/lib/perl5/RRDs.pm

                            Vos retours

                            Comment


                            • #15
                              ah oui encore une chose ?

                              les oscillations ? il faut comprendre cette option de quelle maniere ?

                              cela a t'il a voir avec les graphes ?

                              Merci

                              Comment

                              Working...
                              X