Announcement

Collapse
No announcement yet.

Pb de graph et de remontée de diag

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Pb de graph et de remontée de diag

    Bonjour à tous,

    Voilà j'ai installer nagios 2.4 et oreon 1.3RC1
    Nagios fonctionne parfaitement mais oreon me fait des erreurs.
    Le 1er pb est que j'ai configuré un service pour qu'il me graph le traffic et dans l'onglet Monitoring qd je clique sur le service ca me sort cette erreur ci :
    (Return code of 13 is out of bounds)
    En ligne de commande par contre il n'y a aucun pb le check _graph me remonte bien les info :
    $ /usr/local/nagios/libexec# ./check_graph_traffic.pl -H 10.xxx.xxx.xxx -i 2 -C public -v 2c
    Total RX Bytes: 83.59 MB, Total TX Bytes: 20.58 MB - Average Traffic: 3.17 kB/s (0.0%) in, 1.82 kB/s (0.0%) out
    Qq'un aurais-t-il une petite idée du souci ?

    2ème Pb :

    Ce sont les graphs qui ne s'affichent pas...
    Je créé bien les services et les templates d'host et de service et le fichier *.rrd est bien créé mais pas avec le bon ID puisque au lieu d'avoir un fichier du type HOSTID_SRVID.rrd j'ai un 1.rrd.
    lorsque je fais une propriété sur la croix que ca m'affiche au lieu du graph voici ce qu'il m'indique :
    generateRRDImagePlugins.php?session_id=7eafcc6436c 0342c25430ef56e728377&database=1_1.rrd&template_id =&end=1150804742&start=1150793702
    Je pense que tous les paquets sont installés sont installés et j'ai comme version de rrdtool la 1.2.13.

    S'il y avait une personne qui pourrais m'aider ca serait génial paske là j'ai regarder dans le forum avant de poster mais j'ai l'impression que personne a eu ces pbs et donc là je suis un peu decouragé...

  • #2
    J'ai le même problème :

    PHP Notice: Undefined index: ds_invert in /usr/local/oreon/www/include/views/graphs/generateImage/generateRRDImagePlugins.php on line 102, referer: http://10.211.162.xxx/oreon/oreon.ph...er&o=&p=4&min=

    We need you're help!!!!

    Comment


    • #3
      ceci :

      Code:
      ALTER TABLE `giv_components_template` ADD `ds_invert` INT NULL DEFAULT NULL AFTER `ds_transparency`;
      a résolu mes problèmes!!!

      Comment


      • #4
        Oui,

        C la requete dans le patch pour la RC1...je l'ai déjà passé.
        Et j'ai toujours le mm pb...

        Comment

        Working...
        X