Announcement

Collapse
No announcement yet.

Pas d'affichage apres l'install !

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Pas d'affichage apres l'install !

    Bonjour à tous, voilà j'ai effectué une installation d'oreon sous RedHat Linux Entreprise, et aucuns probleme lors de cette install, tout s'est bien deroulé ( Version 1.3 RC 1 ).

    Seulement apres m'être logué dans l'interface, rien ne s'affiche hormis le logo Oreon comme en témoigne cette capture d'écran :



    Je ne vois pas du tout d'ou cela pourrait venir, si vous pouviez m'aider ca serait vraiment sympa :P

    En vous remrciant

  • #2
    heu oui on a trouvé ce bug. Pb de compatibilité entre php4 et php5.

    corrigé dans la RC2 milieu de semaine.

    Désolé
    Julien Mathis
    Centreon Project Leader
    www.merethis.com |

    Comment


    • #3
      Si je repasse avec la beta 1 en attendant ca va macher ?

      Parceque en fait j'install cet outil dans le cadre de mon stage, et mon stage se termine vendredi donc j'aimerais bien leur installer ca avant

      Mais bon sinon tant pis on attendra

      Comment


      • #4
        oui normalement en version beta 1 c bon.
        Julien Mathis
        Centreon Project Leader
        www.merethis.com |

        Comment


        • #5
          A ben meme avec la beta 1 ca me fait le meme bug

          Je précise que j'ai php 4.3.9 et mysql 4.1.12

          Bon ben tant pis on va attendre la RC2, merci pour ta réponse rapide julio

          Comment


          • #6
            Bonjour ,
            je suis dans le même cas que toi ,sauf que moi j ' arrive juste a afficher les sessions (option -> sessions ).
            Personne aurait une petite idée de mon problème.

            Merçi


            nagios 1.4.1
            oreon 1.3-RC1
            php 5
            mySQL 4.1

            Comment


            • #7
              look in your error_log file of your apache
              Intel(R) Xeon(TM) CPU 3.4GHz - MemTotal : 1034476 kB
              Centreon 2.4.1 - Nagios 3.2.1 - Nagios Plugins 1.4.15 - Manubulon Plugins tuné
              Fedora Core 5 - 2.6.20-1.2320

              Comment


              • #8
                Bonjour,
                Dans mon fichier error_log j 'ai ca :
                [client 127.0.0.1] PHP Stack trace:, referer: http://127.0.0.1/oreon/oreon.php?p=601
                [client 127.0.0.1] PHP 1. {main}() /usr/local/oreon/www/oreon.php:0, referer: http://127.0.0.1/oreon/oreon.php?p=601
                [client 127.0.0.1] PHP 2. require_once() /usr/local/oreon/www/oreon.php:58, referer: http://127.0.0.1/oreon/oreon.php?p=601
                [client 127.0.0.1] PHP 3. require_once() /usr/local/oreon/www/modules/inventory/inventory.php:36, referer: http://127.0.0.1/oreon/oreon.php?p=601
                [client 127.0.0.1] PHP 4. require_once() /usr/share/pear/HTML/QuickForm/Renderer/ArraySmarty.php:23, referer: http://127.0.0.1/oreon/oreon.php?p=601
                [client 127.0.0.1] PHP Fatal error: main() [function.require]: Failed opening required 'HTML/QuickForm/Renderer.php' (include_path='.:/usr/lib/php/:/usr/share/pear/') in /usr/share/pear/HTML/QuickForm/Renderer/Array.php on line 24, referer: http://127.0.0.1/oreon/oreon.php?p=601


                Si quelqu' un pouvait m' aider.Merçi

                Comment


                • #9
                  Il te manque des prerequis pear apparement.
                  Reinstall les modules pear, notamment celui que tu as en erreur dans ta log :wink:
                  Intel(R) Xeon(TM) CPU 3.4GHz - MemTotal : 1034476 kB
                  Centreon 2.4.1 - Nagios 3.2.1 - Nagios Plugins 1.4.15 - Manubulon Plugins tuné
                  Fedora Core 5 - 2.6.20-1.2320

                  Comment


                  • #10
                    Je l' ai déja fait et cela na entrainer aucune modification.
                    Le HTML_QuickForm est bien installer.
                    Je ne comprends pas .Est t il possible que cela viennent d' une incompatibilité avec php5 ?
                    La je bloque.

                    Comment


                    • #11
                      Non, je suis full php5 et ça fonctionne.

                      Assure toi que pear est bien installé dans /usr/share/pear/

                      Que dans ce dossier il y a bien HTML/QuickForm/Renderer/Array.php et HTML/QuickForm/Renderer.php

                      Mais aussi qu'apache à les droits de lecture dessus.
                      Intel(R) Xeon(TM) CPU 3.4GHz - MemTotal : 1034476 kB
                      Centreon 2.4.1 - Nagios 3.2.1 - Nagios Plugins 1.4.15 - Manubulon Plugins tuné
                      Fedora Core 5 - 2.6.20-1.2320

                      Comment


                      • #12
                        Originally posted by DonKiShoot
                        Non, je suis full php5 et ça fonctionne.

                        Assure toi que pear est bien installé dans /usr/share/pear/

                        Que dans ce dossier il y a bien HTML/QuickForm/Renderer/Array.php et HTML/QuickForm/Renderer.php

                        Mais aussi qu'apache à les droits de lecture dessus.
                        Merçi pour tes réponse.
                        Sinon pear est bien installé ,les scripts php sont tous présent.
                        Et par contre comment donner à apache des droits de lecture dessus.

                        Comment


                        • #13
                          ls -ail par exemple.

                          Si tu vois 3 r c bon :wink:
                          Intel(R) Xeon(TM) CPU 3.4GHz - MemTotal : 1034476 kB
                          Centreon 2.4.1 - Nagios 3.2.1 - Nagios Plugins 1.4.15 - Manubulon Plugins tuné
                          Fedora Core 5 - 2.6.20-1.2320

                          Comment

                          Working...
                          X