No announcement yet.

can not see the graph

  • Filter
  • Time
  • Show
Clear All
new posts

  • can not see the graph

    I define the Hosts & services in the oreon web configuration in the “configuration” tab, when I try to browse the “Oreon' views” graph I cant see any graph there!!...

    also I can not see the list of Host/Services!!!... It is empty!!!...
    what may be the problem??!!.... hock:
    Attached Files

  • #2
    try to go in service detail list and click on the graph icon/sign/notice
    Intel(R) Xeon(TM) CPU 3.4GHz - MemTotal : 1034476 kB
    Centreon 2.4.1 - Nagios 3.2.1 - Nagios Plugins 1.4.15 - Manubulon Plugins tuné
    Fedora Core 5 - 2.6.20-1.2320


    • #3
      Nothing their!!!.... hock:

      Do you mean check it in the attached web interface or in the command line??!!!... :roll:
      Attached Files


      • #4
        I think there is a synchronization problem between my Nagios & my Oreon!!!...

        When I open the server command line & run the following command I got:
        [[email protected] etc]# /usr/local/nagios/bin/nagios - v /usr/local/nagios/etc/nagios.cfg

        Nagios 2.4
        Copyright (c) 1999-2006 Ethan Galstad (
        Last Modified: 05-31-2006
        License: GPL

        Reading configuration data...

        Running pre-flight check on configuration data...

        Checking services...
        Error: There are no services defined!
        Checked 0 services.
        Checking hosts...
        Error: There are no hosts defined!
        Checked 0 hosts.
        Checking host groups...
        Error: There are no host groups defined!
        Checked 0 host groups.
        Checking service groups...
        Checked 0 service groups.
        Checking contacts...
        Error: There are no contacts defined!
        Checked 0 contacts.
        Checking contact groups...
        Error: There are no contact groups defined!
        Checked 0 contact groups.
        Checking service escalations...
        Checked 0 service escalations.
        Checking service dependencies...
        Checked 0 service dependencies.
        Checking host escalations...
        Checked 0 host escalations.
        Checking host dependencies...
        Checked 0 host dependencies.
        Checking commands...
        Checked 44 commands.
        Checking time periods...
        Checked 4 time periods.
        Checking extended host info definitions...
        Checked 0 extended host info definitions.
        Checking extended service info definitions...
        Checked 0 extended service info definitions.
        Checking for circular paths between hosts...
        Checking for circular host and service dependencies...
        Checking global event handlers...
        Checking obsessive compulsive processor commands...
        Checking misc settings...

        Total Warnings: 0
        Total Errors: 5

        ***> One or more problems was encountered while running the pre-flight check...

        Check your configuration file(s) to ensure that they contain valid
        directives and data defintions. If you are upgrading from a previous
        version of Nagios, you should be aware that some variables/definitions
        may have been removed or modified in this version. Make sure to read
        the HTML documentation regarding the config files, as well as the
        'Whats New' section to find out what has changed.

        While when trying to restart Nagios from the Oreon web interface I got the same output + the following message:
        Configuration file /etc/nagios/nagios.cfg not found. Exiting.

        But please note that before installing Oreon-1.3 I installed Nagios 2.4 & run the same command with no errors, but after oreon installation & got these 5 errors…. I created the group & hosts from the web interface but I can not see them in the configuration files (from the command line)??!!!....

        Please advice what may be the problem & how can I fix it??!!!!.. :cry:


        • #5
          it seems there is no service and no host define.
          Are you sure all is ok when you generate the configurations files and restart nagios in the oreon GUI ?
          Watch you apache error log file.
          Intel(R) Xeon(TM) CPU 3.4GHz - MemTotal : 1034476 kB
          Centreon 2.4.1 - Nagios 3.2.1 - Nagios Plugins 1.4.15 - Manubulon Plugins tuné
          Fedora Core 5 - 2.6.20-1.2320


          • #6
            I already created the contact, contact group, host and host group from the Oreon web interface; but I can not create the services file!!!.....

            Every when I tried to create it fails & show me the same page & if I try to list the services I can not find it…

            Which error files I have to check??... And what is the name for the apache log file??

            Please note that if I execute the Nagios check command it gives me the same output with the 5 errors!!!!.... :cry:


            • #7
              I have had a samely problem when i create my first host and services
              because i missdeclared my contact and contactgroup
              therefore oreon doesn't generate correctely nagios configuration files
              verify this point first
              next, in configuration/nagios try different value for the interact element parameter before move conf & restart nagios

              PS: Don't use illegal charactere be more safe (just alphanumeric)
              Intel(R) Xeon(TM) CPU 3.4GHz - MemTotal : 1034476 kB
              Centreon 2.4.1 - Nagios 3.2.1 - Nagios Plugins 1.4.15 - Manubulon Plugins tuné
              Fedora Core 5 - 2.6.20-1.2320


              • #8
                I also have a similar problem, but I believe that I may be missing a step on how to setup the graph plugin for service and host. I created service templates and my host seem to work fine. From running the check_graph_traffic on the command line, it is working fine. Can anyone else point me to the right direction on where to go next to resolve this issue.

                Thanks in Advance.


                • #9
                  I did all these but it still the same problem.... :cry:

                  Can anyone please give me a documentation link (in English please) for how to create hosts & contacts using oreon with practical examples??!!!...

                  The wiki documentation doesnt give examples....