Announcement

Collapse
No announcement yet.

[RESOLU]pb rrdtool

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • poiuytrez
    replied
    En fait j'ai fini par contourner le proxy temporairement pour faire un
    yum install rrdtool perl-rrdtool
    et ça à marché...

    Par contre, le export HTTP_PROXY ne règle rien à mon ancien problème.

    Merci en tout cas de votre aide.

    @+

    Leave a comment:


  • DonKiShoot
    replied
    Originally posted by poiuytrez
    En fait,
    j'ai des problèmes avec yum car je suis derrière un proxy, donc je ne peux pas l'utiliser...
    http://www.fedora-france.org/modules...forumpost86971

    Sinon j'avais installé rrdtool à la main, c'est à dire grâce aux sources en les compilant, car lorsque je faisais :
    Code:
    [[email protected] guillaume]# rpm -ivh rrdtool-1.2.13-1.fc3.rf.i386.rpm
    j'obtenais:
    Code:
    attention: rrdtool-1.2.13-1.fc3.rf.i386.rpm: Entête V3 DSA signature: NOKEY, key ID 6b8d79e6
    erreur: Dépendances requises:
            perl(RRDp) est nécessaire pour rrdtool-1.2.13-1.fc3.rf.i386
            perl(RRDs) est nécessaire pour rrdtool-1.2.13-1.fc3.rf.i386
    Si quelqu'un sais où je peux trouver ces fameuses perl(RRDp) et perl(RRDs) et comment les installer....

    Merci de votre aide, c'est vraiment sympa :lol:
    yum derrière proxy marche chez moi, j'ai juste à exporter :
    http_proxy="http://192.168.10.1:80"
    Forcément il bloque sur les comptes ftp mais les http passent.

    yum install perl-rrdtool ou rrdtool-perl , je ne sais plus.

    Leave a comment:


  • rom
    replied
    Dans les deux sens tu auras un appel de dependance, fait un --force sur rrdtool, et apres tu installes perl-rrdtool.

    Leave a comment:


  • poiuytrez
    replied
    En fait,
    j'ai des problèmes avec yum car je suis derrière un proxy, donc je ne peux pas l'utiliser...
    http://www.fedora-france.org/modules...forumpost86971

    Sinon j'avais installé rrdtool à la main, c'est à dire grâce aux sources en les compilant, car lorsque je faisais :
    Code:
    [[email protected] guillaume]# rpm -ivh rrdtool-1.2.13-1.fc3.rf.i386.rpm
    j'obtenais:
    Code:
    attention: rrdtool-1.2.13-1.fc3.rf.i386.rpm: Entête V3 DSA signature: NOKEY, key ID 6b8d79e6
    erreur: Dépendances requises:
            perl(RRDp) est nécessaire pour rrdtool-1.2.13-1.fc3.rf.i386
            perl(RRDs) est nécessaire pour rrdtool-1.2.13-1.fc3.rf.i386
    Si quelqu'un sais où je peux trouver ces fameuses perl(RRDp) et perl(RRDs) et comment les installer....

    Merci de votre aide, c'est vraiment sympa :lol:

    Leave a comment:


  • julio
    replied
    mais au fait t'es en core 5, c'est un rpm pour core 3 ca...

    fais plutot :

    yum install perl-rrdtool

    ca passe tout seul je crois en core 5

    Leave a comment:


  • julio
    replied
    as tu mis rrdtool en RPM et dans cette version la ? soit
    rrdtool-1.2.13-1.fc3.rf.i386

    sinon fais le et apres si ca passe toujours pas fais :

    rpm -ivh --nodeps /home/guillaume/perl-rrdtool-1.2.13-1.fc3.rf.i386.rpm

    des fois les RPM se mordent la queue niveau dépendances....

    Leave a comment:


  • poiuytrez
    replied
    Merci, mais là je n'arrive pas installer perl-rddtool...

    Leave a comment:


  • julio
    replied
    oui en fait tu as installé RRDTool, le binaire, mais la perl-rrdtool c'est une librairie perl qui permet d'utiliser rrdtool direct.

    Leave a comment:


  • poiuytrez
    replied
    Ah merci, mais je viens faire

    Code:
    [[email protected] libexec]# rpm -ivh /home/guillaume/perl-rrdtool-1.2.13-1.fc3.rf.i386.rpm 
    attention: /home/guillaume/perl-rrdtool-1.2.13-1.fc3.rf.i386.rpm: Entête V3 DSA signature: NOKEY, key ID 6b8d79e6
    erreur: Dépendances requises:
            /usr/bin/rrdcgi est nécessaire pour perl-rrdtool-1.2.13-1.fc3.rf.i386
            librrd.so.2 est nécessaire pour perl-rrdtool-1.2.13-1.fc3.rf.i386
            rrdtool = 1.2.13 est nécessaire pour perl-rrdtool-1.2.13-1.fc3.rf.i386
    [[email protected] libexec]#
    c'est bizzare, j'ai bien installé rrdtool !
    Merci de ton aide..

    Leave a comment:


  • julio
    replied
    oui mais la c'est perl-rrdtool qui est demandé... c assez simple a trouvé ca normalement..

    Leave a comment:


  • poiuytrez
    started a topic [RESOLU]pb rrdtool

    [RESOLU]pb rrdtool

    Bonjour,
    je ne peut afficher aucun graph avec oreon. Je pense qu'il doit y avoir un problème avec mon rddtool, je n'ai pas de fichiers rdd qui se créent.
    Et lorsque je fais sur la console linux :

    Code:
    [[email protected] libexec]# ./check_graph_ping.pl 
    Can't locate loadable object for module RRDs in @INC (@INC contains: /usr/src/rrdtool-1.2.13/bindings/perl-shared ../lib/perl /usr/local/nagios/libexec /usr/lib/perl5/site_perl/5.8.8/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.7/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.6/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.5/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.4/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.3/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl/5.8.7 /usr/lib/perl5/site_perl/5.8.6 /usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl/5.8.4 /usr/lib/perl5/site_perl/5.8.3 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.7/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.6/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.5/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.4/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.3/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl/5.8.7 /usr/lib/perl5/vendor_perl/5.8.6 /usr/lib/perl5/vendor_perl/5.8.5 /usr/lib/perl5/vendor_perl/5.8.4 /usr/lib/perl5/vendor_perl/5.8.3 /usr/lib/perl5/vendor_perl /usr/lib/perl5/5.8.8/i386-linux-thread-multi /usr/lib/perl5/5.8.8 .) at /usr/local/nagios/libexec/oreon.pm line 36
    Compilation failed in require at /usr/local/nagios/libexec/oreon.pm line 36.
    BEGIN failed--compilation aborted at /usr/local/nagios/libexec/oreon.pm line 36.
    Compilation failed in require at ./check_graph_ping.pl line 32.
    BEGIN failed--compilation aborted at ./check_graph_ping.pl line 32.
    [[email protected] libexec]#/
    voilà le problème.
    Pourtant j'ai bien compilé à la main rrdtool...
    Pour info, je suis sur fedora core 5

    Merci de votre aide!
Working...
X